Subject: [lisp] Can not reach IPv6 site via LISP network

From: "Markus Moeller" <[email-masked]>
Date: Sat, 10 Dec 2011 13:20:38 -0000

Hi,

  I try to connect to a website on the ipv network and my ISP tells me it is a problem with the LISP prefix. I was asked to rais it with the WG.

Thank you
Markus

Can not reach server on ipv6 network
 Markus Moeller on Friday, 09 December 2011 19:59:04
Here are the traceroute details for the not working site:
C:\My Program Files\Windows Resource Kits\Tools>tracert www.ipv6-db.com

Tracing route to www.ipv6-db.com [2610:d0:2113:3::3]
over a maximum of 30 hops:

1 31 ms 28 ms 29 ms gw-1326.lon-02.gb.sixxs.net [2a01:348:6:52d::1]
2 28 ms 28 ms 29 ms ge-0-0-5-20.cs0.thw.uk.goscomb.net [2a01:348:0:4:0:3:0:1]
3 30 ms 31 ms 29 ms xe-0-0-0.rt0.the.uk.goscomb.net [2a01:348::27:0:1]
4 28 ms 31 ms 30 ms lonap.he.net [2001:7f8:17::1b1b:1]
5 97 ms 100 ms 96 ms 10gigabitethernet7-4.core1.nyc4.he.net [2001:470:0:3e::1]
6 120 ms 116 ms 124 ms 10gigabitethernet8-3.core1.chi1.he.net [2001:470:0:1c6::2]
7 189 ms 190 ms 187 ms 2001:470:1:34::2
8 187 ms 188 ms 191 ms iana.r1.ord1.isc.org [2001:500:71:6::1]
9 189 ms 207 ms 204 ms int-0-0-1-8.r1.pao1.isc.org [2001:4f8:0:1::4a:1]
10 190 ms 191 ms 191 ms int-0-1-0-0.r1.sql1.isc.org [2001:4f8:1b:1::8:2]
11 187 ms * 187 ms lisp-r1.sql1.isc.org [2001:4f8:3:d::60]
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.

 Jeroen Massar SixXS on Friday, 09 December 2011 20:15:39
> Tracing route to www.ipv6-db.com [2610:d0:2113:3::3]

That is a LISP prefix, there is some kind of magical routing involved there and it is all quite experimental.

See Cisco's LISP and the LISP beta site site for more details.

Please contact the site operator or the LISP WG to resolve this. There is nothing much we can do about this.

BTW I cant reach the lisp website over ipv4 either:

C:\My Program Files\Windows Resource Kits\Tools>tracert www.lisp4.net

Tracing route to noc.eid.lisp4.net [153.16.10.11]
over a maximum of 30 hops:

  1     1 ms     3 ms     5 ms  homerouter.windows.home [192.168.1.1]
  2    29 ms    30 ms    29 ms  lo0-central3.thn-ag2.plus.net [195.166.128.231]
  3    82 ms   212 ms   205 ms  gi1-11-231.thn-gw1.plus.net [84.92.6.208]
  4    29 ms    29 ms    28 ms  po4.thn-gw2.plus.net [212.159.1.135]
  5    29 ms    29 ms    28 ms  195.66.225.24
  6    49 ms    75 ms    49 ms  dk-ore.nordu.net [109.105.97.30]
  7    52 ms    58 ms    55 ms  dk-uni.nordu.net [109.105.97.14]
  8    59 ms    60 ms    60 ms  stolav-gw2.uninett.no [109.105.102.26]
  9    63 ms    64 ms   143 ms  oslo-gw.uninett.no [128.39.255.85]
 10    80 ms    71 ms    70 ms  trd-gw1.uninett.no [128.39.255.110]
 11    71 ms    71 ms    70 ms  trd-gw7.uninett.no [128.39.255.214]
 12    71 ms    71 ms    71 ms  uninett-pxtr.rloc.lisp4.net [158.38.1.92]
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15     *        *        *     Request timed out.
 16     *        *        *     Request timed out.
 17     *        *        *     Request timed out.
 18     *        *        *     Request timed out.
 19     *        *        *     Request timed out.
 20     *        *        *     Request timed out.
 21     *        *        *     Request timed out.
 22     *        *        *     Request timed out.
 23     *        *        *     Request timed out.
 24     *        *        *     Request timed out.
 25     *        *        *     Request timed out.
 26     *        *        *     Request timed out.
 27     *        *        *     Request timed out.
 28     *        *        *     Request timed out.
 29     *        *        *     Request timed out.
 30     *        *        *     Request timed out.

Trace complete.

---

From: Lori Jakab <[email-masked]>
Date: Sun, 11 Dec 2011 11:43:54 +0100

Hi Markus,

The LISP WG mailing list is dedicated to the LISP standardization
effort, so these kind of questions are better directed to the people
operating the LISP beta network.

Here are a few things you can try when debugging LISP related issues:

  * Check if the LISP mapping system knows about the destination you
    want to reach. You can use the open source 'lig' utility from one of
    your hosts not behind a firewall/NAT, or simply this LISP looking
    glass: http://lispmon.net/lig.cgi
  * Check the status page of all LISP sites http://www.lisp4.net/lisp-site/

If you try the first step, you will see:
# lig -m intouch-ams-mr-ms-1.rloc.lisp4.net www.ipv6-db.com
Send map-request to intouch-ams-mr-ms-1.rloc.lisp4.net for
www.ipv6-db.com ...
Received map-reply from 85.184.2.42 with rtt 0.05900 secs

Mapping entry for EID '2610:d0:2113:3::3':
2610:d0:2113::/48, via map-reply, record ttl: 1, not auth, not mobile
  Negative cache entry, action: forward-native

The negative cache entry hints at one of two things: the destination is
either not a LISP site, or if it is, it is currently not registering to
the LISP mapping system.

If you check the second step, and you seach that page for the prefix
2610:d0:2113, you will find it on the list, so it is a LISP site.
However, the third column shows that is not active at the moment. You
should probably contact the people managing the LISP routers for that
prefix, but I think that contact info is not public, the LISP beta
network operators can put you in contact.

Regards,
-Lori

On 12/10/11 14:20, Markus Moeller wrote:
> Hi,
>  
>   I try to connect to a website on the ipv network and my ISP tells me
> it is a problem with the LISP prefix. I was asked to rais it with the WG.
>  
> Thank you
> Markus
>  
>  
>  
> *Can not reach server on ipv6 network*
> [gb] Markus Moeller on Friday, 09 December 2011 19:59:04
> <http://www.lisp4.net>
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Lori Jakab <[email-masked]>
Date: Sun, 11 Dec 2011 14:53:10 +0100

Hi Markus,

On 12/11/11 14:27, Markus PlusNet wrote:
> Hi Lori,
>
>  Apologies if I sent it to the wrong list.
>
>  When you say "However, the third column shows that is not active at
> the moment". What is not active ?

LISP introduces an additional component, called the mapping system,
which maps the identifier 2610:d0:2113:3::3 to a routing locator. This
mapping fails currently. See this IP Journal article for an overview of
how LISP works, or check the latest drafts for details:
http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_11-1/111_lisp.html

>   If I check www.ipv6-db.com at
> http://ipv6-test.com/validate.php the site is responding as
>
> Checking for AAAA DNS record2610:d0:2113:3::3

This only means that the DNS lookup for www.ipv6-db.com works.

> Checking for IPv6 web serverApache/2.2.10 (Linux/SUSE)

This is strange, I assume it might be related to caching results on the
ipv6-test.com web site? I certainly cannot telnet to port 80 of
www.ipv6-db.com.

Regards,
-Lori

>
> Thank you
> Markus
>
> ----- Original Message ----- From: "Lori Jakab" <[email-masked]>
> To: "Markus Moeller" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Sunday, December 11, 2011 10:43 AM
> Subject: Re: [lisp] Can not reach IPv6 site via LISP network
>
>
>> Hi Markus,
>>