Subject: [lisp] Lisp for SDN

From: Sharon Barkai <[email-masked]>
Date: Fri, 22 Mar 2013 21:29:44 +0000

Fellow Lispers, 

Was good to meet last week and hear the presentations that demonstrate the "deep-ness" of the lisp threat analysis, the serious push for formal identity networking / address space, and what Dino demonstrated as the ease in which redundantly complex multicast signaling is shed in favor of simple mapping and overlay aggregation or 2tier networks. This lisp signaling-less ability is a great strength and facilitates the move from protocols to schemas.

Would like however to point 3 of the efforts we did not cover:

1) NVO Gap Analysis: last week it was clear that NVO wg realized that whenever there is an overlay there is also an underlay, and, that underlay can be used to build a global mapping service NVO called IMA (which means mother in Hebrew :)

I think it's key that as the most mature distributed overlay  lisp will make its mark on NVO .. especially since most serious SDN architectures are (justly) converging towards distributed overlays.

2) the SHDHT proposal: basically any contribution that can facilitate super flat mapping performance for exposing detail identity and affinity mapping is great step. Even if some of these mappings can only be used in an intra-provider.

3) last, the lisp4nfv I was going to cover. Not sure if anyone caught the etsi NFV presentation in David's SDNRG session. 

Basically a very large group of carriers plan a full isomorphism between the physical reality of functional-devices to a virtual reality of functional VMs. This group clearly did not internalize the gap between overlay virtualization and vlan/vpn presented in nvo3, nor realize the maturity if lisp as an nvo suite.

Anyway, thanks for reading and sorry for the long speech, hopefully we can catch up to these orthogonal domains by next ietf.

Sent from my iPhone 650 492 0794

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 22 Mar 2013 15:32:42 -0700

> Was good to meet last week and hear the presentations that demonstrate the "deep-ness" of the lisp threat analysis, the serious push for formal identity networking / address space, and what Dino de…

Let me summarize what I presented:

(1) How signaling only solutions can be used to build multicast overlays. That is, in-the-network protocols are used like the ones in draft-ietf-lisp-multicast/draft-arango-pim-attributes-for-lisp and draft-ietf-lisp-mr-signaling.
(2) How the Mapping Database System can participate with the in-the-network solutions.
(3) How a network controller can be used with (2).

The signaling-less solution is what came out of talks at IETF I had with Sharon and Joel. You can find an enclosed slide-set that describes the idea.

Dino

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp