Subject: [lisp] LISP as routing protocol in MESH networks

From: Rene Bartsch <[email-masked]>
Date: Tue, 17 Dec 2013 10:06:29 +0100

Hi, 

I've decided to use NROffEdit for writing my CGEID draft
(Cryptographically Generated Endpoint IDentifiers). 

While considering CGEIDs I got another idea: 

Would it be possible to use LISP as routing protocol for mesh networks
by announcing the CGEIDs of neighbour-nodes as RLOCs of a node? It would
be some kind of onion routing without encryption. 

The biggest problem of a node seems to be reaching the
map-servers/-resolvers when bootstrapping. Can a LISP tunnel
router/mobile node run it's own map-server/-resolver connecting directly
to the Tier 1 map-server mesh or is there some kind of authentication
between the map-servers? 

Regards, 

Renne 

-- 
Best regards,

Rene Bartsch, B. Sc. Informatics

Current Bitcoin Exchange Rate: https://www.bitcoin.de/de/r/mwfngu

---

From: Lori Jakab <[email-masked]>
Date: Tue, 17 Dec 2013 12:49:53 +0200

Hi Rene,

On Dec 17, 2013, at 11:06 AM, Rene Bartsch <[email-masked]> wrote:

[…]
> The biggest problem of a node seems to be reaching the map-servers/-resolvers when bootstrapping. Can a LISP tunnel router/mobile node run it's own map-server/-resolver connecting directly to the Tier 1 map-server mesh or is there some kind of authentication between the map-servers?
> 

There is no authentication for querying the DDT root nodes.  Just like with DNS, it is possible for a node to maintain a list with the root nodes and query iteratively for an EID, starting at the root. It may not be the fattest way, but it solves your bootstrapping problem.  The next version of LISPmob (0.3.4) will support this mode of operation.  AFAIK, no other implementation supports it though.

HTH,
-Lori

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 17 Dec 2013 07:31:08 -0800

Hi,
> 
> I've decided to use NROffEdit for writing my CGEID draft (Cryptographically Generated Endpoint IDentifiers).
> 
> Would it be possible to use LISP as routing protocol for mesh networks by announcing the CGEIDs of neighbour-nodes as RLOCs of a node? It would be some kind of onion routing without encryption.

I would think you would want RLOCs to continue to be Provider-Assigned addresses and thet CGEIDs are just like any other EID. That is, the CGEID's topological location could be found by doing a mapping database lookup.

But yes, I have seen use-cases where folks want tunnel-endpoints to be mobile. And if you want to find a new location of the tunnel end-point, then you assign the tunnel-endpoint an EID. So let me be more precise in my language. The requirement was to make a GRE tunnel mobile. So if you configured the ends of a GRE tunnel to be in EID-space, either end could move if those EIDs mapped to locators, and LISP encapsulation is performed to an xTR adjacent to the GRE end-point or co-located with the GRE end-point.

We have also see LISP use to make a routing protocol work over a wide-area network where multi-hop adjacencies were formed. cisco's EIGRP is doing this in some use-cases.

> The biggest problem of a node seems to be reaching the map-servers/-resolvers when bootstrapping. Can a LISP tunnel router/mobile node run it's own map-server/-resolver connecting directly to the T…

Yes, there are military applications that want to do this as well.

Dino

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp