Subject: Re: [lisp] draft-farinacci-lisp-crypto-00 posted last week

From: Robert Raszuk <[email-masked]>
Date: Mon, 3 Mar 2014 16:56:11 +0100

Hi Dino,

Thx for presentation !

Is the idea to use Difﬁe-Hellman forever ?

Don't you need some space for the versioning to accommodate easy upgrades
of the algorithms used between ITRs and ETRs ?

IMHO ON/OFF indication is not sufficient.

Thx,
R.

On Tue, Feb 18, 2014 at 6:33 PM, Dino Farinacci <[email-masked]> wrote:

> Just an FYI at a first stab at providing data-plane confidentiality in
> LISP.
>
> Dino
>
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 3 Mar 2014 17:00:50 +0100

Thx Joel !

Yes I did not mean to load mapping system with anything. It all should stay
out of mapping plane and be only exchanged between xTRs.

Cheers,
R.

On Mon, Mar 3, 2014 at 4:56 PM, Robert Raszuk <[email-masked]> wrote:

> On Tue, Feb 18, 2014 at 6:33 PM, Dino Farinacci <[email-masked]>wrote:
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 03 Mar 2014 11:01:20 -0500

Not sure if you are in the room, or listening remotely.  Just brought 
this up in the room, and indicated that we need to address agility in 
both key derivation functions and encryption algorithms.

Yours,
Joel

On 3/3/14, 10:56 AM, Robert Raszuk wrote:
> Don't you need some space for the versioning to accommodate easy
> upgrades of the algorithms used between ITRs and ETRs ?
>
> On Tue, Feb 18, 2014 at 6:33 PM, Dino Farinacci <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Just an FYI at a first stab at providing data-plane confidentiality
>     in LISP.
>
>     Dino
>
>     [email-masked] <mailto:[email-masked]>