Subject: [lisp] Locator ordering

From: Albert López <[email-masked]>
Date: Tue, 30 Sep 2014 17:50:01 +0200

Dear all,

We have seen that, according to RFC 6830, the locators appearing in a 
Map Reply must be "sorted in order of ascending IP address where an IPv4 
locator address is considered numerically 'less than' an IPv6 locator 
address". How should the locators be sorted if we also have LCAF 
addresses like ELP?

Best regards

Albert

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 30 Sep 2014 08:54:28 -0700

Sorted based on AFI. Which means LCAF/Type when multiple LCAF encodings occur. So if an locator-set had these addresses, they would be sorted in the following order:

AFI=1, <ipv4-address>
AFI=2, <ipv6-address>
AFI=16387, LCAF-type=5, <geo-coordinates>
AFI=16387, LCAF-type=10, <elp>

Dino

On Sep 30, 2014, at 8:50 AM, Albert López <[email-masked]> wrote:

> Dear all,
> 
> We have seen that, according to RFC 6830, the locators appearing in a Map Reply must be "sorted in order of ascending IP address where an IPv4 locator address is considered numerically 'less than' an IPv6 locator address". How should the locators be sorted if we also have LCAF addresses like ELP?
> 
> Best regards
> 
> Albert
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 30 Sep 2014 12:01:17 -0400

Is this be written down somewhere?  Should it be? (In the LCAF spec maybe?)
Yours,
Joel

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 30 Sep 2014 09:27:04 -0700

I had already thought of that. I'll take action item to do it. 

Dino

> On Sep 30, 2014, at 9:01 AM, Joel M. Halpern <[email-masked]> wrote:
>