Subject: Re: [lisp] Proposing "Encapsulation Format" LCAF type

From: Albert Cabellos <[email-masked]>
Date: Mon, 1 Dec 2014 12:40:28 +0100

Hi Luigi

> Is the WG OK to work on the proposed encoding and push the work on a more
general format to later times (i.e. after rechartering)?

I agree with the current format, existing data-planes are still a moving
target and it is hard to anticipate their requirements. Additionally some
requirements might result in multiple lookups.

Albert

---

From: Damien Saucez <[email-masked]>
Date: Tue, 2 Dec 2014 09:27:33 +0100

On 27 Nov 2014, at 16:34, Luigi Iannone <[email-masked]> wrote:

> Is the WG OK to work on the proposed encoding and push the work on a more general format to later times (i.e. after rechartering)?

Ok for me. At that time it will then be interesting to see if we can make
control-plane AND data-plane more general/extensible while keeping
backward compatible.

Damien Saucez

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Tue, 2 Dec 2014 17:52:15 +0000

I’m good with this approach.

-D
On Dec 2, 2014, at 12:27 AM, Damien Saucez <[email-masked]> wrote:

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Tue, 2 Dec 2014 17:54:35 +0000

On Nov 27, 2014, at 7:34 AM, Luigi Iannone <[email-masked]> wrote:

> 
> About point (1) of Dino’s mail: 
> 
> The proposed encoding is based on a bitwise approach that today reserves specific bits to encapsulation formats that at this time are not WG documents anywhere in the IETF. The WG should be aware that the dependencies introduced in the document may slow down its progress.

In general, I believe this points out that we need a Registry for LCAF types that is independent of this document status.  Certainly we want to encourage future types to be developed independent of the LCAF draft’s status.  That is, I would like to see LCAF go to publication independent of any particular AF extension’s progress/use.  I believe Joel said something similar at the mic a few meetings ago.

-DArrel

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 2 Dec 2014 11:01:53 -0800

So let's have one.

Dino

> On Dec 2, 2014, at 9:54 AM, Darrel Lewis (darlewis) <[email-masked]> wrote:
> 
>

---

From: Florin Coras <[email-masked]>
Date: Tue, 02 Dec 2014 12:00:54 -0800

+1

Florin

---

From: Sander Steffann <[email-masked]>
Date: Wed, 3 Dec 2014 14:16:56 +0100

> So let's have one.

+1
Sander