Subject: [lisp] About lisp crypto

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Tue, 28 Jul 2015 06:43:10 +0000

Hello Dino and others

In  the last LISP WG meeting you presented changes to lisp-cypto. On slide 4 it is said that IV was added to the start of payload and ICV at the end.
I cannot find them in the lisp-crypto-01.

See
https://tools.ietf.org/rfcdiff?url2=draft-farinacci-lisp-crypto-01.txt

I am curious about the use of IV particularly and it relationship to the key exchange via Mappings system. Hopefully this would be described in the draft where IV and ICV are to be discussed.

Best regards
Hannu

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 28 Jul 2015 17:13:03 -0700

> On Jul 27, 2015, at 11:43 PM, Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]> wrote:
> 
> Hello Dino and others 
>  

The draft is a working group document so the draft name is draft-ietf-lisp-crypto-01.txt.

> I am curious about the use of IV particularly and it relationship to the key exchange via Mappings system. Hopefully this would be described in the draft where IV and ICV are to be discussed.

The IV is locally generated by the ITR. We say how to use it in the draft.

> Hannu

Thanks,
Dino

>  
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp