Subject: Re: [lisp] Fwd: Expiration impending: <draft-farinacci-lisp-name-encoding-00.txt>

From: "jmh.direct" <[email-masked]>
Date: Mon, 03 Oct 2016 16:25:32 -0400

DNS names on the wire are ascii.  So the primary use case is covered as is as far as I can tell.
Yours,Joel

Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone
-------- Original message --------From: Dino Farinacci <[email-masked]> Date: 10/3/16  4:13 PM  (GMT-05:00) To: "Joel M. Halpern" <[email-masked]> Cc: LISP mailing list list <[email-masked]> Subject: Re: [lisp] Fwd: Expiration impending: <draft-farinacci-lisp-name-encoding-00.txt> 
> Are we sure that all the use cases for this AFI fall into the ASCII character set.  DNS names clearly do meet that restriction.  But many other names do not.  And while people can and do define escapes, it produces complicated and messy situations.

I would say so but maybe we should ask the group if there is a requirement for this feature to be in any non alphabetic languages.

> I ask because as defined, even if we wanted to, this can not be used to carry UTF-8 to the fact that bytes of all 0 may occur in UTF-8.

I am fine with documenting the restriction.

> There are many good reasons to keep this simple scope.  If we want to keep that restrictions, it seems to me that the introduction should be clear about the scope.

Let’s see if there is any input from the WG. 

So let me ask this question, can DNS names be transmitted in, say, a chinese character set?

Dino

> 
> Yours,
> Joel M. Halpern
> 
> On 10/3/16 12:28 PM, Dino Farinacci wrote:
>> Folks, I am going to update this draft so it doesn’t expire. At this time, I would like to request this a working group document. It is a very simple draft and would like to see if there are any comments and if we can start a last call on it. Chairs?
>> 
>> Dino
>> 
>>> Begin forwarded message:
>>> 
>>> From: IETF Secretariat <[email-masked]>
>>> Subject: Expiration impending: <draft-farinacci-lisp-name-encoding-00.txt>
>>> Date: October 3, 2016 at 4:42:10 AM PDT
>>> To: <[email-masked]>
>>> Resent-From: <[email-masked]>
>>> Resent-To: [email-masked]
>>> 
>>> The following draft will expire soon:
>>> 
>>> Name:     draft-farinacci-lisp-name-encoding
>>> Title:    LISP Distinguished Name Encoding
>>> State:    I-D Exists
>>> Expires:  2016-10-15 (in 1 week, 4 days)
>>> 
>> 
>> _______________________________________________
>> lisp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/lisp
>>

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 3 Oct 2016 13:31:32 -0700

> DNS names on the wire are ascii.  So the primary use case is covered as is as far as I can tell.

So we should be the same and put the restriction in the draft. Agree?

Dino

> Joel
> -------- Original message --------
> From: Dino Farinacci <[email-masked]>
> Date: 10/3/16 4:13 PM (GMT-05:00)
> To: "Joel M. Halpern" <[email-masked]>
> Cc: LISP mailing list list <[email-masked]>
> Subject: Re: [lisp] Fwd: Expiration impending: <draft-farinacci-lisp-name-encoding-00.txt>
>

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 4 Oct 2016 12:38:11 +0200

> On 3 Oct 2016, at 22:31, Dino Farinacci <[email-masked]> wrote:
> 

For clarification: The restriction would be that the document covers ascii-only encodings?

If yes, can you do the modifications before WG adoption call?

ciao

L.

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 5 Oct 2016 10:20:11 -0700

> For clarification: The restriction would be that the document covers ascii-only encodings?

Right.

> If yes, can you do the modifications before WG adoption call?

Submitting a new draft now. See diff file attached. Please ack.

Dino