Subject: [lisp] New name for upcoming LISP -OAM- document

From: Luigi Iannone <[email-masked]>
Date: Mon, 19 Mar 2018 16:25:33 +0000

Hi All,

during today f2f meeting concern has been expressed about the name to use for the document that will collect what is neither data-plane nor control-plane.

The name OAM was found not accurate because the document will not cover all of what is normally in a OAM document.

The suggested name is “LISP Mobility, Deployment and Traceroute considerations”.

The chairs would like to hear from the mailing list if there is any objection or you have a better name to suggest.

Please send an email by the end of the week.

Thanks

Jole and Luigi

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 19 Mar 2018 09:53:11 -0700

> The chairs would like to hear from the mailing list if there is any objection or you have a better name to suggest.

I don’t have a name suggestion (for the 3 items included in one document) but I would like to support an idea that Albert provided after the meeting today. 

He suggested to put the Mobility sections in an Appendix in RFC6830bis and put Deployment and Traceroute considerations in a document that now can be called “draft-ietf-lisp-oam”.

Wonder how people would feel about that?

Dino

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 20 Mar 2018 14:58:31 +0000

I don't have a name suggestion either, but I do find it odd having a document with these 3 seemingly unrelated items (mobility seems to be the odd one out). So I would be in favour of proposal from Albert below.

Regards,
Reshad.

    

    
    Dino
    
    _______________________________________________
    lisp mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lisp

---

From: Albert Cabellos <[email-masked]>
Date: Tue, 20 Mar 2018 16:32:20 +0000

Hi

I don't have a name suggestion either, but I do find it odd having a
> document with these 3 seemingly unrelated items (mobility seems to be the
> odd one out). So I would be in favour of proposal from Albert below.

I think that this another very good point, it is indeed strange and results
in a document without clear focus.

Kind regards

Albert

On Tue, Mar 20, 2018 at 2:58 PM, Reshad Rahman (rrahman) <[email-masked]>
wrote:

> I don't have a name suggestion either, but I do find it odd having a
> document with these 3 seemingly unrelated items (mobility seems to be the
> odd one out). So I would be in favour of proposal from Albert below.
>
> Regards,
> Reshad.
>
> On 2018-03-19, 4:53 PM, "lisp on behalf of Dino Farinacci" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     > The chairs would like to hear from the mailing list if there is any
> objection or you have a better name to suggest.
>
>     I don’t have a name suggestion (for the 3 items included in one
> document) but I would like to support an idea that Albert provided after
> the meeting today.
>
>     He suggested to put the Mobility sections in an Appendix in RFC6830bis
> and put Deployment and Traceroute considerations in a document that now can
> be called “draft-ietf-lisp-oam”.
>

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 20 Mar 2018 17:35:10 +0000

If the items are unrelated why should they go to 2 different document, knowing that are not related to the data-plane neither ?

L.

> On 20 Mar 2018, at 14:58, Reshad Rahman (rrahman) <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 20 Mar 2018 11:09:28 -0700

+1

Dino

> On Mar 20, 2018, at 9:32 AM, Albert Cabellos <[email-masked]> wrote:
> 
> Hi
> 
> I think that this another very good point, it is indeed strange and results in a document without clear focus. 
> 
> Kind regards
> 
> Albert
> 
> On Tue, Mar 20, 2018 at 2:58 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 20 Mar 2018 11:13:10 -0700

I think the problem is that RFC6830bis has too narrow a definition of “data-plane”. I believe you think it as the sole purpose of forwarding data packets. I view it as the “nodes that make up the data-plane” should be part of that.

Having said that, the Deployment section is saying where xTRs go and why. The Mobility section is saying where EIDs and RLOCs are and off often the can change. Both of these sections has nothing to do with control-plane and hence they shouldn’t go in RFC6833bis but should not go into a OAM document either.

The Traceroute section is probably the only section that should go in a document titled “OAM”. But what is the cost of putting just this section in a document?

The cost and time we have spent on this topic has already exceeded the benefit.

Dino

> On Mar 20, 2018, at 10:35 AM, Luigi Iannone <[email-masked]> wrote:
>

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 21 Mar 2018 08:37:07 +0000

> The cost and time we have spent on this topic has already exceeded the benefit.

This is also consuming my patience.

During f2f meeting decision has been made. The last question was the name and we opened for suggestion from the mailing list.

Let’s not start again  in endless discussion. 

By Friday we settle for a name and we move on AS DECIDED. 
Not opening again for any change that will trigger discussion.

We are close to finish this part of the work, so let’s do it.

L.

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 21 Mar 2018 08:39:40 +0000

> On 20 Mar 2018, at 18:13, Dino Farinacci <[email-masked]> wrote:
> 

p.s. I will not answer this part of the email because we are far over the discussion and I don’t want to open it again.
Let move on as planned.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 21 Mar 2018 11:22:20 +0000

Ack.

    

    

    L.

---

From: Fabio Maino <[email-masked]>
Date: Wed, 21 Mar 2018 16:05:48 +0000

I suggest "Considerations on LISP Mobility, Deployment and Traceroute" 
that puts a little less emphasis on mobility.

I second Luigi's call to get done with this document and move on.

Thanks,
Fabio

---

From: "Prakash Jain (prakjain)" <[email-masked]>
Date: Wed, 21 Mar 2018 23:17:56 +0000

Agree, OAM has much bigger scope than traceroute, so naming it with 'traceroute considerations' makes more sense.
Thanks,
Prakash

-----Original Message-----
From: lisp <[email-masked]> On Behalf Of Fabio Maino (fmaino)
Sent: Wednesday, March 21, 2018 9:06 AM
To: [email-masked]
Subject: Re: [lisp] New name for upcoming LISP -OAM- document

Thanks,
Fabio

---

From: Luigi Iannone <[email-masked]>
Date: Fri, 23 Mar 2018 11:12:52 +0000

HI all,

We  think that we can move on as planned.

The new document will be named "Considerations on LISP Mobility, Deployment and Traceroute”.

Since the text is coming from existing docs authorship will be preserved.

Albert is the appointed editor and will hold the pen.

Because the text has been already thoroughly reviewed in the past we expect to make rapid progress with this document.

Ciao

Joel & Luigi

> On 19 Mar 2018, at 16:25, Luigi Iannone <[email-masked]> wrote:
> 
> Hi All,
>