Subject: [lisp] Mapping System scalability

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Fri, 16 Mar 2018 01:19:50 -0700

Hi all,

In the DMM call this week, some people asked about the scalability of the
Mapping System. The LISP community has delivered different solutions to
address that challenge over the years. Here are some pointers to different
Mapping System implementations, I'm sure that the folks at the LISP WG list
can provide even more references.

LISP Delegated Database Tree (LISP DDT) [1] follows a DNS-like structure
and it's designed to be deployed at Internet scale. For an academic work on
a DNS-based Mapping System take a look at [2].

Designs leveraging DHTs have also been considered to enable high
scalabilty, see for instance [3][4]. For a survey on different Mapping
System options see [5] (I wasn't able to find an open version of this
article unfortunately).

For those interested in current research efforts, recent works include
decentralized designs [6] or even Blockchain-based approaches [7].

Hope this helps,
Alberto

[1] https://tools.ietf.org/html/rfc8111
[2] http://people.ac.upc.edu/ljakab/2010-jakab-jsac-lisp-tree.pdf
[3] https://tools.ietf.org/html/draft-cheng-lisp-shdht-04
[4]
http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.139.735&rep=rep1&type=pdf
[5] http://ieeexplore.ieee.org/document/6422285/
[6] https://tools.ietf.org/html/draft-farinacci-lisp-decent-00
[7]
https://datatracker.ietf.org/meeting/97/materials/slides-97-lisp-blockchain-based-mapping-system/

---

From: Michael Menth <[email-masked]>
Date: Fri, 16 Mar 2018 09:26:42 +0100

Am 16.03.2018 um 09:19 schrieb Alberto Rodriguez-Natal:
> Hi all,
> 
> In the DMM call this week, some people asked about the scalability of
> the Mapping System. The LISP community has delivered different solutions
> to address that challenge over the years. Here are some pointers to
> different Mapping System implementations, I'm sure that the folks at the
> LISP WG list can provide even more references.
> 
> and it's designed to be deployed at Internet scale. For an academic work
> on a DNS-based Mapping System take a look at [2].
> 
https://atlas.informatik.uni-tuebingen.de/~menth/papers/Menth13c.pdf

Regards,

Michael

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
> 

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: Arashmid Akhavain <[email-masked]>
Date: Sat, 17 Mar 2018 12:04:44 +0000

Alberto,

Our tests showed  very promising results for public cloud Pub/Sub (DHT based). We got about 120ms performance out of these systems.
Given that these systems are designed to mover large chunk of data, it is very reasonable to assume that the performance for these DHT based mapping systems can be further improved for 5G.

Arashmid

From: dmm [mailto:[email-masked]] On Behalf Of Alberto Rodriguez-Natal
Sent: Friday, March 16, 2018 4:20 AM
To: [email-masked]
Cc: [email-masked] list <[email-masked]>
Subject: [DMM] Mapping System scalability

Hi all,

In the DMM call this week, some people asked about the scalability of the Mapping System. The LISP community has delivered different solutions to address that challenge over the years. Here are some pointers to different Mapping System implementations, I'm sure that the folks at the LISP WG list can provide even more references.

LISP Delegated Database Tree (LISP DDT) [1] follows a DNS-like structure and it's designed to be deployed at Internet scale. For an academic work on a DNS-based Mapping System take a look at [2].

Designs leveraging DHTs have also been considered to enable high scalabilty, see for instance [3][4]. For a survey on different Mapping System options see [5] (I wasn't able to find an open version of this article unfortunately).

For those interested in current research efforts, recent works include decentralized designs [6] or even Blockchain-based approaches [7].

Hope this helps,
Alberto

[1] https://tools.ietf.org/html/rfc8111
[2] http://people.ac.upc.edu/ljakab/2010-jakab-jsac-lisp-tree.pdf
[3] https://tools.ietf.org/html/draft-cheng-lisp-shdht-04
[4] http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.139.735&rep=rep1&type=pdf
[5] http://ieeexplore.ieee.org/document/6422285/
[6] https://tools.ietf.org/html/draft-farinacci-lisp-decent-00
[7] https://datatracker.ietf.org/meeting/97/materials/slides-97-lisp-blockchain-based-mapping-system/