Subject: [lisp] MS-SMR draft

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Wed, 4 Apr 2018 23:49:06 -0700

Hi all,

We have just posted an updated version of the MS-originated SMRs draft [1].
The revised document discusses how/when the MS is supposed to send SMRs and
includes a note pointing to draft-rodrigueznatal-lisp-pubsub as the
preferred PubSub mechanism.

Let us know if you have any comment. As discussed in London, we would like
to move forward with this as informational (and preferably as a WG item).

Thanks,
Alberto

[1] https://tools.ietf.org/html/draft-rodrigueznatal-lisp-ms-smr-06

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 5 Apr 2018 09:47:12 -0700

Just one editorial comment Alberto. If the pubsub draft is about to be a working group document, maybe this document should point to draft-ietf-lisp-pubsub-00?

Dino

> On Apr 4, 2018, at 11:49 PM, Alberto Rodriguez-Natal <[email-masked]> wrote:
> 
> Hi all,
> 
> We have just posted an updated version of the MS-originated SMRs draft [1]. The revised document discusses how/when the MS is supposed to send SMRs and includes a note pointing to draft-rodrigueznatal-lisp-pubsub as the preferred PubSub mechanism.
> 
> Let us know if you have any comment. As discussed in London, we would like to move forward with this as informational (and preferably as a WG item).
> 
> Thanks,
> Alberto
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Thu, 5 Apr 2018 14:17:34 -0700

Sounds good to me Dino. I'll wait for the adoption call of lisp-pubsub to
end and will update this document as appropriate.

Thanks,
Alberto

On Thu, Apr 5, 2018 at 9:47 AM, Dino Farinacci <[email-masked]> wrote:

> Just one editorial comment Alberto. If the pubsub draft is about to be a
> working group document, maybe this document should point to
> draft-ietf-lisp-pubsub-00?
>
> Dino
>
> > We have just posted an updated version of the MS-originated SMRs draft
> [1]. The revised document discusses how/when the MS is supposed to send
> SMRs and includes a note pointing to draft-rodrigueznatal-lisp-pubsub as
> the preferred PubSub mechanism.
> >
> > Let us know if you have any comment. As discussed in London, we would
> like to move forward with this as informational (and preferably as a WG
> item).
> >
> > Thanks,
> > Alberto
> >

---

From: Luigi Iannone <[email-masked]>
Date: Fri, 6 Apr 2018 10:04:29 +0200

Hi,

I was wondering….. why not putting this as an appendix in the pubsub document? Stating that was the previous solution for what pubs does and that is kept in appendix as informational material.

any thoughts?

L.

> On 5 Apr 2018, at 23:17, Alberto Rodriguez-Natal <[email-masked]> wrote:
> 
> Sounds good to me Dino. I'll wait for the adoption call of lisp-pubsub to end and will update this document as appropriate.
> 
> Thanks,
> Alberto
> 
> On Thu, Apr 5, 2018 at 9:47 AM, Dino Farinacci <[email-masked] <mailto:[email-masked]>> wrote:
> > On Apr 4, 2018, at 11:49 PM, Alberto Rodriguez-Natal <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi all,
> >
> > [1] https://tools.ietf.org/html/draft-rodrigueznatal-lisp-ms-smr-06 <https://tools.ietf.org/html/draft-rodrigueznatal-lisp-ms-smr-06>
> >
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/lisp <https://www.ietf.org/mailman/listinfo/lisp>
> 
>

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 6 Apr 2018 08:07:00 -0700

Well it wasn’t a previous WG solution. It was an individual submission that one vendor implemented. Since the WG supports pubsub going forward, I think a forward pointer from the individual submission to the WG document is sufficient.

Dino

> On Apr 6, 2018, at 1:04 AM, Luigi Iannone <[email-masked]> wrote:
> 
> Hi,
>

---

From: Fabio Maino <[email-masked]>
Date: Fri, 6 Apr 2018 10:29:02 -0700

I agree with Dino.

Fabio

---

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Fri, 6 Apr 2018 11:20:42 -0700

That's a fair question Luigi. However, my personal opinion is that we
should not put this into the PubSub document since PubSub is deprecating
this.

I believe the redirection should be from MS-SMR to PubSub. Once you are
looking at PubSub there's no reason to look back at MS-SMR.

Alberto

On Fri, Apr 6, 2018 at 1:04 AM, Luigi Iannone <[email-masked]> wrote:

> Hi,
>
> I was wondering….. why not putting this as an appendix in the pubsub
> document? Stating that was the previous solution for what pubs does and
> that is kept in appendix as informational material.
>
> any thoughts?
>
> L.
>
>

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 9 Apr 2018 12:32:38 +0200

Alberto, Fabio, Dino,

thanks for the clarifications.

Ciao

L.

> On 6 Apr 2018, at 20:20, Alberto Rodriguez-Natal <[email-masked]> wrote:
> 
> That's a fair question Luigi. However, my personal opinion is that we should not put this into the PubSub document since PubSub is deprecating this. 
> 
> I believe the redirection should be from MS-SMR to PubSub. Once you are looking at PubSub there's no reason to look back at MS-SMR.
> 
> Alberto
> 
> On Fri, Apr 6, 2018 at 1:04 AM, Luigi Iannone <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
>> On 5 Apr 2018, at 23:17, Alberto Rodriguez-Natal <[email-masked] <mailto:[email-masked]>> wrote:
>>