Subject: Re: [lisp] draft-ietf-lisp-rfc6830bis-14

From: Dino Farinacci <[email-masked]>
Date: Mon, 20 Aug 2018 14:42:12 -0400

WG, here is a diff with changes to reflect Scott’s comment. I wanted the list of implementator to-be-aware changes to get working group quick review.

I’m about to add a “Changes since RFC 6833” section to RFC 6833bis as well.

Thanks,
Dino

> On Aug 20, 2018, at 9:03 AM, Scott O. Bradner <[email-masked]> wrote:
> 
> a specific section only dealing with the changes since the RFC is best
> 
> there is too much noise in the per iteration log (which as you already note should be removed)
> 
> Scott
> 
>> On Aug 20, 2018, at 8:57 AM, Dino Farinacci <[email-masked]> wrote:
>> 
>> Note we do have a Document Change Log in Appendix B detailing the changes put in each version starting with RFC6830. Would that suffice? Or you still think a specific section is required?
>> 
>> Dino
>> 
>> 
>>> On Aug 20, 2018, at 8:44 AM, Scott O. Bradner <[email-masked]> wrote:
>>> 
>>> it would be best to have a section called “changes since RFC 6830” so there is no ambiguity that the section covers the changes
>>> 
>>> it would be fine to have that section just say “See  “Implementation Considerations.”
>>> 
>>> Scott
>>> 
>>> 
>>>> On Aug 20, 2018, at 8:26 AM, Dino Farinacci <[email-masked]> wrote:
>>>> 
>>>> 
>>>>> Hi Dino
>>>>>> On Aug 20, 2018, at 8:18 AM, Dino Farinacci <[email-masked]> wrote:
>>>>>> 
>>>>>> There were little changes that an implementor would need to know about for the data-plane. But there were for the control-plane (i.e. RFC6833bis). But in either case, we’ll add a section in each bis document.
>>>>> 
>>>>> thanks - even if the section says “nothing to worry about” it will be useful
>>>> 
>>>> I’ll title it “Implementation Considerations” and place it between 17 and 18?
>>>> 
>>>> 14. Multicast Considerations  . . . . . . . . . . . . . . . . . .  29
>>>> 15. Router Performance Considerations . . . . . . . . . . . . . .  30
>>>> 16. Security Considerations . . . . . . . . . . . . . . . . . . .  31
>>>> 17. Network Management Considerations . . . . . . . . . . . . . .  32
>>>> 18. IANA Considerations . . . . . . . . . . . . . . . . . . . . .  32
>>>> 
>>>> 
>>>>>> 
>>>>>> Are you going to be reviewer for 6833bis as well?
>>>>> 
>>>>> not assigned that yet but I will take a look
>>>> 
>>>> I will try to get the sections done in the next day or so. I’m at the 3GPP meetings this week.
>>>> 
>>>> Dino
>>>> 
>>>>> 
>>>>> Scott
>>>>>> 
>>>>>> Dino
>>>>>> 
>>>>>>> On Aug 20, 2018, at 6:14 AM, Scott O. Bradner <[email-masked]> wrote:
>>>>>>> 
>>>>>>> I was just assigned to do a ops-dir review of  draft-ietf-lisp-rfc6830bis-14
>>>>>>> 
>>>>>>> this is not the review - that will come soon
>>>>>>> 
>>>>>>> but since this is a “bis” document that is to replace an existing RFC it needs to have a 
>>>>>>> “changes since RFC 6830” section so that implementors of the earlier RFC will be able to tell
>>>>>>> what they need to change to bring their code up to date without having to compare the 
>>>>>>> RFCs line by line (and likely miss something)
>>>>>>> 
>>>>>>> Scott
>>>>>> 
>>>>> 
>>>> 
>>> 
>> 
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 20 Aug 2018 14:48:39 -0400

looks good to me - thanks

Scott

> On Aug 20, 2018, at 2:42 PM, Dino Farinacci <[email-masked]> wrote:
> 
> <rfcdiff-rfc6830bis.html>
>

---

From: Fabio Maino <[email-masked]>
Date: Mon, 20 Aug 2018 11:56:50 -0700

Looks good Dino.

Noted one nit in section 18, not worth spinning a new version IMO:

"The is 1 remaining bit" -> "The 1 remaining bit"

Fabio

On 8/20/18 11:42 AM, Dino Farinacci wrote:
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 20 Aug 2018 15:29:59 -0400

And here is the diff for the same type of changes for 6833bis.

Thanks,
Dino

> On Aug 20, 2018, at 2:42 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 20 Aug 2018 15:32:37 -0400

Will fix. Thanks for the catch Fabio.

Dino

> On Aug 20, 2018, at 2:56 PM, Fabio Maino <fmaino=[email-masked]> wrote:
> 
> Looks good Dino. 
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 20 Aug 2018 15:34:49 -0400

looks just right 

thanks

Scott

> On Aug 20, 2018, at 3:29 PM, Dino Farinacci <[email-masked]> wrote:
> 
> <rfcdiff-rfc6833bis.html>
>

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 20 Aug 2018 15:42:54 -0400

I’ll post both in a few days giving WG some time.

Dino

> On Aug 20, 2018, at 3:34 PM, Scott O. Bradner <[email-masked]> wrote:
> 
> looks just right 
> 
> thanks
> 
> Scott
>

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 22 Aug 2018 09:51:10 +0200

Hi Dino,

the new section looks good to me. Just one comment: I would avoid use the word “draft” in the first sentence of the last bullet of the section.
So instead of 

"Data-plane gleaning for creating map-cache entries has been made optional in this draft.”

I would simply put:

"Data-plane gleaning for creating map-cache entries has been made optional.”

Just trimming the last part.

Ciao

L.

> On 20 Aug 2018, at 20:42, Dino Farinacci <[email-masked]> wrote:
>

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 22 Aug 2018 10:00:07 +0200

Hi Dino,

the new section in 6833bis looks good to me. Just two nits:
In the first line of the first bullet the word “document” is misspelled: docuemnt -> document
In the second sentence of the same bullet: "Any receivers" -> "Any receiver"

Ciao

L.

> On 20 Aug 2018, at 21:29, Dino Farinacci <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 22 Aug 2018 09:52:09 -0400

Updated. I also received requests to add other data planes that may be applicable. So references to SRv6 GRE, and GTP were added.

Diffs enclosed. I will submit both drafts on Friday.

Dino

> On Aug 22, 2018, at 3:51 AM, Luigi Iannone <[email-masked]> wrote:
> 
> Hi Dino,
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 27 Aug 2018 15:07:59 -0400

a quick look at the ToC of the ID & of RFC 6830 show a lot of things missing (the doc is a lot
shorter) - it might be useful to say something about that in the changes since section

Scott

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 27 Aug 2018 12:33:18 -0700

Right - we moved the control-plane to 6833bis. I’ll mention that in changes section. 

Dino

> On Aug 27, 2018, at 12:07 PM, Scott O. Bradner <[email-masked]> wrote:
> 
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 27 Aug 2018 15:40:30 -0400

thanks!

Scott

> On Aug 27, 2018, at 3:33 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 27 Aug 2018 13:48:26 -0700

Diffs enclosed.

Dino

> On Aug 27, 2018, at 12:40 PM, Scott O. Bradner <[email-masked]> wrote:
> 
> thanks!
> 
> Scott
> 
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 27 Aug 2018 17:19:01 -0400

wfm

Scott

> On Aug 27, 2018, at 4:48 PM, Dino Farinacci <[email-masked]> wrote:
> 
> Diffs enclosed.
> 
> Dino
> 
> <rfcdiff.html>
>