Subject: Re: [lisp] Moving forward with lisp-nexagon

From: Rotem Tamir <[email-masked]>
Date: Tue, 4 Aug 2020 20:40:50 +0300

Hi Sharon,

As a person coming from a non networking background, having worked on web
backend and data pipeline problems for many years I wanted to say that
working on this standard has been quite an eye opening experience.

I have not even heard of LISP before this work (when you first approached
me with this I thought you were referring to the programming language), and
I did struggle with the idea for a while. But looking at it now from an
system architecture perspective it is a brilliantly simple and scalable
approach to building a massive network of real-time geo spatial
communication.

Had we not gone with this approach we would have created yet another
version of the wheel, another proprietary  black box protocol.

These are very exciting times to be in the AI/vision/automotive field and I
really think we have a solid foundation to build upon.

So yes, I join the others in saying  I’m really looking forward to it
become a proper RFC,

Thanks for your work on this !!

R

On Tue, 4 Aug 2020 at 18:18 <[email-masked]> wrote:

> Send lisp mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/lisp
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of lisp digest..."
>
>
> Today's Topics:
>
>    1. I-D Action: draft-ietf-lisp-vpn-06.txt ([email-masked])
>    2. Re: Moving forward with lisp-nexagon (Lori Jakab (lojakab))
>    3. Re: Moving forward with lisp-nexagon (Fabio Maino (fmaino))
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 03 Aug 2020 15:38:14 -0700
> From: [email-masked]
> To: <[email-masked]>
> Cc: [email-masked]
> Subject: [lisp] I-D Action: draft-ietf-lisp-vpn-06.txt
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Locator/ID Separation Protocol WG of the
> IETF.
>
>         Title           : LISP Virtual Private Networks (VPNs)
>         Authors         : Victor Moreno
>                           Dino Farinacci
>         Filename        : draft-ietf-lisp-vpn-06.txt
>         Pages           : 17
>         Date            : 2020-08-03
>
> Abstract:
>    This document describes the use of the Locator/ID Separation Protocol
>    (LISP) to create Virtual Private Networks (VPNs).  LISP is used to
>    provide segmentation in both the LISP data plane and control plane.
>    These VPNs can be created over the top of the Internet or over
>    private transport networks, and can be implemented by Enterprises or
>    Service Providers.  The goal of these VPNs is to leverage the
>    characteristics of LISP - routing scalability, simply expressed
>    Ingress site TE Policy, IP Address Family traversal, and mobility, in
>    ways that provide value to network operators.
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-lisp-vpn/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-lisp-vpn-06
> https://datatracker.ietf.org/doc/html/draft-ietf-lisp-vpn-06
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-vpn-06
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 4 Aug 2020 10:03:01 +0000
> From: "Lori Jakab (lojakab)" <[email-masked]>
> To: Sharon Barkai <sharon.barkai=[email-masked]>
> Cc: "[email-masked] list" <[email-masked]>
> Subject: Re: [lisp] Moving forward with lisp-nexagon
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi Sharon,
>
> I think this draft addresses some really interesting use cases, so I would
> like to see it advanced.
>
> -Lori
>
> > On Aug 2, 2020, at 6:44 PM, Sharon Barkai <sharon.barkai=
> [email-masked]> wrote:
> >
> > We have presented the nexagon
> >  https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04? <
> https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>
> > work at several LISP WG sessions.  We have made significant improvements
> to the work over that time in AAA, security, privacy, and grammar thanks to
> prominent non author wg members.
> >
> > This ID can help show what can be done with lisp mapped
> addressable-states and brokered mp2mp channels by simply using standard
> lisp ucast/mcast interfaces.
> >
> > ID can also help iot / street-processing specs evolve from sending
> things to a ?server?. Show an interoperable extendible paradigm, and
> actually interoperate and extend themed-channels with enterprise EID
> ?MIBs?.
> >
> > Before asking the chairs for formal WG adoption as authors, would like
> to know if folks are interested in seeing this advanced, and willing to
> help move it forward.
> >
> > Thank you.
> >
> > --szb
> > Cell: +972.53.2470068
> > WhatsApp: +1.650.492.0794
> > _______________________________________________
> > lisp mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/lisp
>
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.htm
> >
> -------------- next part --------------
> A non-text attachment was scrubbed...
> Name: smime.p7s
> Type: application/pkcs7-signature
> Size: 3013 bytes
> Desc: not available
> URL: <
> https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.p7s
> >
>
> ------------------------------
>
> Message: 3
> Date: Tue, 4 Aug 2020 15:17:35 +0000
> From: "Fabio Maino (fmaino)" <[email-masked]>
> To: Sharon Barkai <sharon.barkai=[email-masked]>,
>         "[email-masked] list" <[email-masked]>
> Subject: Re: [lisp] Moving forward with lisp-nexagon
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
> It?s indeed a very interesting use case and application for the LISP
> protocol. As an author, I would like to see the WG involved with this topic.
>
> Thanks,
> Fabio
>
> From: lisp <[email-masked]> on behalf of Sharon Barkai
> <sharon.barkai=[email-masked]>
> Date: Sunday, August 2, 2020 at 9:45 AM
> To: "[email-masked] list" <[email-masked]>
> Subject: [lisp] Moving forward with lisp-nexagon
>
> We have presented the nexagon
>  https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04 <
> https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>
> work at several LISP WG sessions.  We have made significant improvements
> to the work over that time in AAA, security, privacy, and grammar thanks to
> prominent non author wg members.
>
>
> This ID can help show what can be done with lisp mapped addressable-states
> and brokered mp2mp channels by simply using standard lisp ucast/mcast
> interfaces.
>
>
> ID can also help iot / street-processing specs evolve from sending things
> to a ?server?. Show an interoperable extendible paradigm, and actually
> interoperate and extend themed-channels with enterprise EID  ?MIBs?.
>
>
> Before asking the chairs for formal WG adoption as authors, would like to
> know if folks are interested in seeing this advanced, and willing to help
> move it forward.
>
>
> Thank you.
>
> --szb
> Cell: +972.53.2470068
> WhatsApp: +1.650.492.0794
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/1ae462dc/attachment.htm
> >
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>
>
> ------------------------------
>
> End of lisp Digest, Vol 141, Issue 2
> ************************************
>

---

From: Sharon Barkai <[email-masked]>
Date: Sun, 16 Aug 2020 15:23:32 +0300

Thank you Rotem, Dino, Fabio, Alberto, and all other sent support notes.
I ask the chairs to move from adoption, steps following RFC are outlined bellow.

Understood the chairs would like lisp-nexagon to reference the 6830bis not rfc6830.
This makes sense, hopefully 6830bis will clear IESG soon. Tnx.

> On Aug 4, 2020, at 20:40, Rotem Tamir <rotemtamir=[email-masked]> wrote:
> 
> Hi Sharon,
> 
> As a person coming from a non networking background, having worked on web backend and data pipeline problems for many years I wanted to say that working on this standard has been quite an eye opening experience. 
> 
> I have not even heard of LISP before this work (when you first approached me with this I thought you were referring to the programming language), and I did struggle with the idea for a while. But looking at it now from an system architecture perspective it is a brilliantly simple and scalable approach to building a massive network of real-time geo spatial communication.
> 
> Had we not gone with this approach we would have created yet another version of the wheel, another proprietary  black box protocol.
> 
> These are very exciting times to be in the AI/vision/automotive field and I really think we have a solid foundation to build upon.
> 
> So yes, I join the others in saying  I’m really looking forward to it become a proper RFC,
> 
> On Tue, 4 Aug 2020 at 18:18 <[email-masked] <mailto:[email-masked]>> wrote:
>         [email-masked] <mailto:[email-masked]>
> 
>         https://www.ietf.org/mailman/listinfo/lisp <https://www.ietf.org/mailman/listinfo/lisp>
>         [email-masked] <mailto:[email-masked]>
> 
>         [email-masked] <mailto:[email-masked]>
> 
>    1. I-D Action: draft-ietf-lisp-vpn-06.txt ([email-masked] <mailto:[email-masked]>)
> From: [email-masked] <mailto:[email-masked]>
> To: <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> Message-ID: <[email-masked] <mailto:[email-masked]>>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Locator/ID Separation Protocol WG of the IETF.
> 
> https://datatracker.ietf.org/doc/draft-ietf-lisp-vpn/ <https://datatracker.ietf.org/doc/draft-ietf-lisp-vpn/>
> 
> https://tools.ietf.org/html/draft-ietf-lisp-vpn-06 <https://tools.ietf.org/html/draft-ietf-lisp-vpn-06>
> https://datatracker.ietf.org/doc/html/draft-ietf-lisp-vpn-06 <https://datatracker.ietf.org/doc/html/draft-ietf-lisp-vpn-06>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-vpn-06 <https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-vpn-06>
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> 
> 
> 
> From: "Lori Jakab (lojakab)" <[email-masked] <mailto:[email-masked]>>
> To: Sharon Barkai <sharon.barkai=[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]> list" <[email-masked] <mailto:[email-masked]>>
> Message-ID: <[email-masked] <mailto:[email-masked]>>
> I think this draft addresses some really interesting use cases, so I would like to see it advanced.
> 
> -Lori
> 
> > On Aug 2, 2020, at 6:44 PM, Sharon Barkai <sharon.barkai=[email-masked] <mailto:[email-masked]>> wrote:
> > 
> >  https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04 <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>? <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04 <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>> 
> > work at several LISP WG sessions.  We have made significant improvements to the work over that time in AAA, security, privacy, and grammar thanks to prominent non author wg members.
> > 
> > This ID can help show what can be done with lisp mapped addressable-states and brokered mp2mp channels by simply using standard lisp ucast/mcast interfaces. 
> > 
> > ID can also help iot / street-processing specs evolve from sending things to a ?server?. Show an interoperable extendible paradigm, and actually interoperate and extend themed-channels with enterprise EID  ?MIBs?.
> > 
> > Before asking the chairs for formal WG adoption as authors, would like to know if folks are interested in seeing this advanced, and willing to help move it forward.
> > 
> > Thank you.
> > 
> > --szb
> > Cell: +972.53.2470068
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/lisp <https://www.ietf.org/mailman/listinfo/lisp>
> 
> URL: <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.htm <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.htm>>
> URL: <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.p7s <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.p7s>>
> 
> From: "Fabio Maino (fmaino)" <[email-masked] <mailto:[email-masked]>>
> To: Sharon Barkai <sharon.barkai=[email-masked] <mailto:[email-masked]>>,
>         "[email-masked] <mailto:[email-masked]> list" <[email-masked] <mailto:[email-masked]>>
> Message-ID: <[email-masked] <mailto:[email-masked]>>
> It?s indeed a very interesting use case and application for the LISP protocol. As an author, I would like to see the WG involved with this topic.
> 
> Thanks,
> Fabio
> 
> From: lisp <[email-masked] <mailto:[email-masked]>> on behalf of Sharon Barkai <sharon.barkai=[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]> list" <[email-masked] <mailto:[email-masked]>>
>  https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04 <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04> <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04 <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>>
> work at several LISP WG sessions.  We have made significant improvements to the work over that time in AAA, security, privacy, and grammar thanks to prominent non author wg members.
> 
> 
> This ID can help show what can be done with lisp mapped addressable-states and brokered mp2mp channels by simply using standard lisp ucast/mcast interfaces.
> 
> 
> ID can also help iot / street-processing specs evolve from sending things to a ?server?. Show an interoperable extendible paradigm, and actually interoperate and extend themed-channels with enterprise EID  ?MIBs?.
> 
> 
> Before asking the chairs for formal WG adoption as authors, would like to know if folks are interested in seeing this advanced, and willing to help move it forward.
> 
> 
> Thank you.
> 
> --szb
> Cell: +972.53.2470068
> URL: <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/1ae462dc/attachment.htm <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/1ae462dc/attachment.htm>>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lisp <https://www.ietf.org/mailman/listinfo/lisp>
> 
>

---

From: "Victor Moreno (vimoreno)" <[email-masked]>
Date: Mon, 17 Aug 2020 20:36:09 +0000

You have my support as well.

-v

On Aug 16, 2020, at 5:23 AM, Sharon Barkai <sharon.barkai=[email-masked]<mailto:sharon.barkai=[email-masked]>> wrote:

On Aug 4, 2020, at 20:40, Rotem Tamir <rotemtamir=[email-masked]<mailto:rotemtamir=[email-masked]>> wrote:

Hi Sharon,

R

On Tue, 4 Aug 2020 at 18:18 <[email-masked]<mailto:[email-masked]>> wrote:
Send lisp mailing list submissions to
        [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
        https://www.ietf.org/mailman/listinfo/lisp
or, via email, send a message with subject or body 'help' to
        [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
        [email-masked]<mailto:[email-masked]>

Today's Topics:

   1. I-D Action: draft-ietf-lisp-vpn-06.txt ([email-masked]<mailto:[email-masked]>)
   2. Re: Moving forward with lisp-nexagon (Lori Jakab (lojakab))
   3. Re: Moving forward with lisp-nexagon (Fabio Maino (fmaino))

Message: 1
Date: Mon, 03 Aug 2020 15:38:14 -0700
From: [email-masked]<mailto:[email-masked]>
To: <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [lisp] I-D Action: draft-ietf-lisp-vpn-06.txt
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="utf-8"

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

Message: 2
Date: Tue, 4 Aug 2020 10:03:01 +0000
From: "Lori Jakab (lojakab)" <[email-masked]<mailto:[email-masked]>>
To: Sharon Barkai <sharon.barkai=[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]> list" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lisp] Moving forward with lisp-nexagon
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="utf-8"

Hi Sharon,

-Lori

> On Aug 2, 2020, at 6:44 PM, Sharon Barkai <sharon.barkai=[email-masked]<mailto:[email-masked]>> wrote:
>
>  https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04? <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>
> [email-masked]<mailto:[email-masked]>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3013 bytes
Desc: not available
URL: <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/02e1c68e/attachment.p7s>

Message: 3
Date: Tue, 4 Aug 2020 15:17:35 +0000
From: "Fabio Maino (fmaino)" <[email-masked]<mailto:[email-masked]>>
To: Sharon Barkai <sharon.barkai=[email-masked]<mailto:[email-masked]>>,
        "[email-masked]<mailto:[email-masked]> list" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lisp] Moving forward with lisp-nexagon
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="utf-8"

Thanks,
Fabio

From: lisp <[email-masked]<mailto:[email-masked]>> on behalf of Sharon Barkai <sharon.barkai=[email-masked]<mailto:[email-masked]>>
Date: Sunday, August 2, 2020 at 9:45 AM
To: "[email-masked]<mailto:[email-masked]> list" <[email-masked]<mailto:[email-masked]>>
Subject: [lisp] Moving forward with lisp-nexagon

We have presented the nexagon
 https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04 <https://tools.ietf.org/html/draft-ietf-lisp-nexagon-04>
work at several LISP WG sessions.  We have made significant improvements to the work over that time in AAA, security, privacy, and grammar thanks to prominent non author wg members.

Thank you.

--szb
Cell: +972.53.2470068
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/lisp/attachments/20200804/1ae462dc/attachment.htm>

Subject: Digest Footer

_______________________________________________
lisp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lisp

[email-masked]<mailto:[email-masked]>

<ietf-lisp-nexagon.model.1.5.pdf>