Subject: [lisp] I-D Action: draft-farinacci-lisp-name-encoding-10.txt

From: [email-masked]
Date: Sun, 30 Aug 2020 21:07:50 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Locator/ID Separation Protocol WG of the IETF.

        Title           : LISP Distinguished Name Encoding
        Author          : Dino Farinacci
	Filename        : draft-farinacci-lisp-name-encoding-10.txt
	Pages           : 6
	Date            : 2020-08-30

Abstract:
   This draft defines how to use the AFI=17 Distinguished Names in LISP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-farinacci-lisp-name-encoding/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-farinacci-lisp-name-encoding-10
https://datatracker.ietf.org/doc/html/draft-farinacci-lisp-name-encoding-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-farinacci-lisp-name-encoding-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Lori Jakab (lojakab)" <[email-masked]>
Date: Mon, 31 Aug 2020 13:37:53 +0000

Hi,

Just wanted to mention to the WG that support for decoding Distinguished Name Encoding in Wireshark was accepted into the master branch and will be part of the 3.4.x stable release series.

https://gitlab.com/wireshark/wireshark/-/commit/dc4a5b5addcf990589f7a1afa6963d9de9a5f2b2 <https://gitlab.com/wireshark/wireshark/-/commit/dc4a5b5addcf990589f7a1afa6963d9de9a5f2b2>
https://gitlab.com/wireshark/wireshark/-/commit/acbcfefa7ebe2b92d4c2e901c5b2c5b3c6271fe4 <https://gitlab.com/wireshark/wireshark/-/commit/acbcfefa7ebe2b92d4c2e901c5b2c5b3c6271fe4>

-Lori

> On Aug 31, 2020, at 6:07 AM, [email-masked] wrote:
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 31 Aug 2020 09:11:53 -0700

Great news Lori. I wish the working group would make this a working group document. There are so many use-cases for this encoding and relatively simpler to implement than LCAF encodings. 

I am hopeful that the WG will take this draft more seriously. I have requested it to be a working group document and move it to RFC many times. 

Dino

> On Aug 31, 2020, at 6:39 AM, Lori Jakab (lojakab) <lojakab=[email-masked]> wrote:
> 
> Hi,
> 
> https://gitlab.com/wireshark/wireshark/-/commit/dc4a5b5addcf990589f7a1afa6963d9de9a5f2b2
> https://gitlab.com/wireshark/wireshark/-/commit/acbcfefa7ebe2b92d4c2e901c5b2c5b3c6271fe4
> 
> -Lori
>