Subject: [lmap] LMAP framework issue #1 User-initiated Measurement Tasks

From: <[email-masked]>
Date: Tue, 3 Sep 2013 17:58:32 +0100

We've now started creating an LMAP framework doc that merges 3 I-Ds (terminology and the 2 framework docs) - hoping it could be the basis for a WG doc - as mentioned in Berlin.

One section will be about proposed constraints /assumptions - extending http://tools.ietf.org/html/draft-eardley-lmap-framework-02#section-3

I'm going to send a series of emails to try and capture where I think the discussion got to in Berlin &/or propose text for the I-D &/or generate discussion on open issues.

Constraint: User-initiated Measurement Tasks out of scope of LMAP WG
We expect LMAP & IPPM functionality to be used for user-initiated Measurement Tasks, but the WG will not define how. There are at least two ways user-initiation could happen, in outline
* a user could somehow (perhaps via a webpage) request the ISP- (or regulator-) run measurement system to test his/her line. The ISP (or regulator) Controller would then send an Instruction to the MA in the usual LMAP way. The Measurement Results could be returned back via the webpage. Note that a user can't directly initiate a Measurement Task on an ISP- (or regulator-) controlled MA in their home
* a user could deploy their own measurement system, with their own MA, Controller and Collector (possibly with all three functions in the same box). The user may also want to report Measurement Results to a third party. One possible situation is that the home contains a user-controlled MA and an ISP-controlled MA; then the test traffic of one MA is treated by the other MA just like any other user traffic. Note that a single MA is instructed by a single Controller and is only in one measurement system.
For further details see http://www.ietf.org/mail-archive/web/lmap/current/msg00714.html and related messages.

Comments?
Thanks
phil

---

From: Paul Aitken <[email-masked]>
Date: Tue, 03 Sep 2013 22:25:58 +0100

Phil,

> We expect LMAP & IPPM functionality to be used for user-initiated 
> Measurement Tasks, but the WG will not define how. There are at least 
> two ways user-initiation could happen, in outline
>
> * a user could somehow (perhaps via a webpage) request the ISP- (or 
> regulator-) run measurement system to test his/her line. The ISP (or 
> regulator) Controller would then send an Instruction to the MA in the 
> usual LMAP way. The Measurement Results could be returned back via the 
> webpage. Note that a user can't directly initiate a Measurement Task 
> on an ISP- (or regulator-) controlled MA in their home
>

- because the user doesn't own the (single) controller with which the MA 
is associated. Fine by me.

> * a user could deploy their own measurement system, with their own MA, 
> Controller and Collector (possibly with all three functions in the 
> same box). The user may also want to report Measurement Results to a 
> third party.
>

I seem to recall that the controller / MA / collector were assumed to 
belong to a single entity - in which case, reporting results to a third 
party is out of scope. Any number of means could be used to transfer 
results from your collector to the third party collector - including, 
pretending that the third-party collector is part of your own network - 
which raises authentication and security issues.

> One possible situation is that the home contains a user-controlled MA 
> and an ISP-controlled MA; then the test traffic of one MA is treated 
> by the other MA just like any other user traffic.
>

This could introduce a problem, depending upon the exact test 
conditions. See next email.

> Note that a single MA is instructed by a single Controller and is only 
> in one measurement system.
>

Definitely.

P.

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 04 Sep 2013 09:30:06 +0200

So, my concern here is that in the first option, it seems that the user 
initiated tests can be controlled by the ISP and the ISP could be aware 
fo what tests the user is trying to do and react accordingly (suppose 
the ISP usually caps some type of traffic and when it realizes the user 
is trying to test for the capacity, it opens the cap).

The second option, i think it is the way to go, but as you wrote it it 
reads a bit weak. I woudl rather a stronger wording, like a MUST or at 
least a SHOULD (i mean, the user initiated measurement function MUST be 
availabel in the MA)

regards, marcelo

El 03/09/13 18:58, [email-masked] escribió:
>
> We’ve now started creating an LMAP framework doc that merges 3 I-Ds 
> (terminology and the 2 framework docs) – hoping it could be the basis 
> for a WG doc – as mentioned in Berlin.
>
> One section will be about proposed constraints /assumptions – 
> extending 
> http://tools.ietf.org/html/draft-eardley-lmap-framework-02#section-3
>
> I’m going to send a series of emails to try and capture where I think 
> the discussion got to in Berlin &/or propose text for the I-D &/or 
> generate discussion on open issues.
>
> webpage. Note that a user can’t directly initiate a Measurement Task 
> third party. One possible situation is that the home contains a 
> user-controlled MA and an ISP-controlled MA; then the test traffic of 
> one MA is treated by the other MA just like any other user traffic. 
> For further details see 
> http://www.ietf.org/mail-archive/web/lmap/current/msg00714.html and 
> related messages.
>
> Comments?
>
> Thanks
>
> phil
>
>
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: <[email-masked]>
Date: Wed, 4 Sep 2013 08:49:20 +0100

I think both are very valid options. Comments below...

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>marcelo bagnulo braun
>Sent: 04 September 2013 08:30
>To: [email-masked]
>Subject: Re: [lmap] LMAP framework issue #1 User-initiated Measurement
>Tasks
>
>initiated tests can be controlled by the ISP and the ISP could be aware fo
>what tests the user is trying to do and react accordingly (suppose the ISP
>usually caps some type of traffic and when it realizes the user is trying to
>test for the capacity, it opens the cap).

It is the ISPs measurement system. It is a perfectly valid option for the ISP to allow the users to use the same measurement system. The scenario you describe could actually be a benefit since the test traffic is known to the ISP who will discount this traffic from usage caps.

I really don't see any ISP trying to pretend their line speeds etc. are higher than they actually are - they wouldn't have to modify the network to do this - just lie about the result, but I really don't see this as plausible.

>The second option, i think it is the way to go, but as you wrote it it reads a
>bit weak. I woudl rather a stronger wording, like a MUST or at least a
>SHOULD (i mean, the user initiated measurement function MUST be availabel
>in the MA)

If this is a separate measurement system there IS a Controller. The user owns that Controller. There will be some management interface to that Controller to schedule or request tests, or maybe it's just a standard test schedule that is run. The management interface I think doesn't need to be standardised.

>> We've now started creating an LMAP framework doc that merges 3 I-Ds
>> (terminology and the 2 framework docs) - hoping it could be the basis
>> for a WG doc - as mentioned in Berlin.
>>
>> One section will be about proposed constraints /assumptions -
>> extending
>> I'm going to send a series of emails to try and capture where I think

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 04 Sep 2013 10:20:02 +0200

> I really don't see any ISP trying to pretend their line speeds etc. are higher than they actually are - they wouldn't have to modify the network to do this - just lie about the result, but I really…

mmm, i think it is a legitimate need that the user can do measurements 
that are not supervised by the ISP.

> If this is a separate measurement system there IS a Controller. The user owns that Controller. There will be some management interface to that Controller to schedule or request tests, or maybe it's…

the way i see it is that the controller is the user itself i.e. the user 
interface. I mean, something like speedtest, right? The user clicks a 
button in the GUI and it triggers a test. The wording here would simply 
say that the user must have access to a UI with the MA and that it will 
allow the user to initate measurements.

Regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 04 Sep 2013 10:22:41 +0200

El 03/09/13 23:25, Paul Aitken escribió:
>
>
>
>> * a user could deploy their own measurement system, with their own 
>> MA, Controller and Collector (possibly with all three functions in 
>> the same box). The user may also want to report Measurement Results 
>> to a third party.
>>
>
> belong to a single entity - in which case, reporting results to a 
> third party is out of scope. Any number of means could be used to 
> transfer results from your collector to the third party collector - 
> including, pretending that the third-party collector is part of your 
> own network - which raises authentication and security issues.
>

right. From my perspective, the user intiated MA function is just 
another user application generating traffic in the user network and 
should be treated as such.

does that makes sense?

Regards, marcelo

>> Note that a single MA is instructed by a single Controller and is 
>> only in one measurement system.
>>
>
> Definitely.
>
> P.
>
>

---

From: <[email-masked]>
Date: Wed, 4 Sep 2013 10:26:53 +0100

Thanks for the comments - conclusion so far I think the text needs to be clarified:-

- make sure it's clear these are both possibilities, with various pros and cons
- clarify that in case 2 there'd be a GUI or mgt interface to request tests and see results (just as this is mentioned for case 1)
- clarify that in case 2 - if a user reports Measurement Results to a third party, these would be sent by the Collector and not direct from the MA

> Sent: 04 September 2013 09:20
> To: Burbridge,T,Trevor,TUB8 R
> Cc: [email-masked]
> >> From: [email-masked] [mailto:[email-masked]] On Behalf
> >> Of marcelo bagnulo braun
> >> Subject: Re: [lmap] LMAP framework issue #1 User-initiated
> >> Measurement Tasks
> >>
> >> So, my concern here is that in the first option, it seems that the
> >> user initiated tests can be controlled by the ISP and the ISP could
> >> be aware fo what tests the user is trying to do and react
> accordingly
> >> (suppose the ISP usually caps some type of traffic and when it
> >> realizes the user is trying to test for the capacity, it opens the
> cap).
> > It is the ISPs measurement system. It is a perfectly valid option for
> the ISP to allow the users to use the same measurement system. The
> scenario you describe could actually be a benefit since the test
> traffic is known to the ISP who will discount this traffic from usage
> caps.
> >
> > I really don't see any ISP trying to pretend their line speeds etc.
> are higher than they actually are - they wouldn't have to modify the
> network to do this - just lie about the result, but I really don't see
> this as plausible.
> >
> 
> > If this is a separate measurement system there IS a Controller. The
> user owns that Controller. There will be some management interface to
> that Controller to schedule or request tests, or maybe it's just a
> standard test schedule that is run. The management interface I think
> doesn't need to be standardised.
> 
> MA,

---

From: Paul Aitken <[email-masked]>
Date: Wed, 04 Sep 2013 10:35:58 +0100

Phil,

> - clarify that in case 2 there'd be a GUI or mgt interface to request tests and see results (just as this is mentioned for case 1)

Say no more than it's some out-of-scope mechanism. It could be an email, 
SMS, intervention of local politician... LMAP doesn't know and doesn't 
care, as long as the test sequence is initiated from the single 
controller which is associated with the MA.

P.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 4 Sep 2013 20:41:32 +0000

> - clarify that in case 2 - if a user reports Measurement Results to a third party,
> these would be sent by the Collector and not direct from the MA

I don't see a need to say this. If the user has configured the results to be sent to a 3rd party, then that should be an easy thing to describe. This doesn't change the information model, doesn't change the list of potential Collector protocols, nor the data models for those protocols.

But it does mean we need to say something about such an MA making sure the user has the choice and allowing the user to suppress sending of any info the user considers private. I think this is a worthwhile statement.

I suppose, though, that since the Collector can be collocated with the MA, we could make the case of it being the collocated Collector sending the data along, and not the MA. That seems like an attempt to dodge making the statement about user choice and suppression for privacy.
Barbara

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Wed, 4 Sep 2013 21:45:06 +0000

The initial drawings I have seem decompose the MA from a scheduler and collector -

However I think Barbara is correct, a customer MA should be a "MA application"...  BUT that is not LMAP it's a customer home test MA not part of a larger system.

So are we discussing a Large scale, or a Home testing component... or both and how they fit together?

Just doing a logic check..
Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of STARK, BARBARA H
Sent: Wednesday, September 04, 2013 3:42 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [lmap] LMAP framework issue #1 User-initiated Measurement Tasks

> - clarify that in case 2 - if a user reports Measurement Results to a 
> third party, these would be sent by the Collector and not direct from 
> the MA

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 4 Sep 2013 22:36:12 +0000

> However I think Barbara is correct, a customer MA should be a "MA
> application"...  BUT that is not LMAP it's a customer home test MA not part of
> a larger system.
> 

I was thinking of a MA that the customer downloads onto a customer-owned device that tests the Internet connection. It may test against the same MPs being used by entities that publish provider performance statistics. It may even be provided by such an entity. I'm not thinking of a MA that just tests the home network. I'm not thinking of how they fit together. 

If it can test against a MP, is controlled by a single entity, and can potentially report its info, then (1) I don't see where having it in scope adds much complexity, and (2) by having it in scope, that means things can be said about it. For example, by having it in scope, it's possible to provide it with guidance around how to interpret results and how to get and use service attributes and how to play nice with others. And how to ensure customer privacy.

When something is out of scope, there's no ability to say anything about it.
If this customer-controlled MA is going to play in the same sandbox with all the other little MAs, I'd prefer for it to abide by sandbox etiquette.
Barbara

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 10 Sep 2013 11:41:12 -0400

In what we now call case 2, the user-deployed measurement system:

Phil wrote:
... There are at least two ways user-initiation could happen, in outline
<snip case 1>
* a user could deploy their own measurement system, with their own MA, Controller and Collector
(possibly with all three functions in the same box). The user may also want to report
Measurement Results to a third party. One possible situation is that the home contains
a user-controlled MA and an ISP-controlled MA; then the test traffic of one MA is
treated by the other MA just like any other user traffic.
Note that a single MA is instructed by a single Controller and is only in one measurement system.

The issue I see is that an LMAP system of Controller, MA and Collector is incomplete.
In the active measurement scenario, the user's MA needs a remote partner in most cases.
Sure, you could run the DNS measurement, or GET a web page. But to measure anything interesting
the user needs a partner: a Measurement Peer who runs a compatible test protocol
(unspecified by LMAP).

-  In user-deployed case 2, the Measurement Peer (MP) is likely to be operated by a
   different organization (users have limited span of control)

-  The Measurement Peer's org. is likely to have access to some test results
   (through timestamps) and certainly an IP address. Users give-up some info
   to get access to a Measurement Peer.

So, case 2 seems to stretch the bounds of LMAP, because the LMAP-unspecified measurement protocol
between MA and MP spans org. boundaries, and conveys measurement info and user info.
Today's web-based testing services provide a partner IP addrs and a let you see the results,
but they keep copies of those things too.

How can we negotiate the charter's privacy requirements in user-deployed case 2?
We might have to accept that the measurement protocol gives some info away.
I'm interested to learn more from folks with experience in this area.

Al

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, September 03, 2013 12:59 PM
To: [email-masked]
Subject: [lmap] LMAP framework issue #1 User-initiated Measurement Tasks

Comments?
Thanks
phil

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 10 Sep 2013 11:41:06 -0400

Sorry for joining this thread so late. Here's what I had at the end:

Phil's points (now lettered) with Paul's clarification and Barbara's observation:
> A - make sure it's clear these are both possibilities, with various pros and cons
> B - clarify that in case 2 there'd be a GUI or mgt interface to request tests and see results 
     (just as this is mentioned for case 1)

Paul: Say no more than it's some out-of-scope mechanism. It could be an email, 
	SMS, intervention of local politician... LMAP doesn't know and doesn't 
	care, as long as the test sequence is initiated from the single 
	controller which is associated with the MA.

> C - clarify that in case 2 - if a user reports Measurement Results to a third party, these would be sent by the Collector and not direct from the MA

Barb: I don't see a need to say this. ... This doesn't change the information model, 
	doesn't change the list of potential Collector protocols, nor the data models for those protocols.
	But .<snip>. say something about such an MA making sure the user has the choice 
	and allowing the user to suppress sending of any info the user considers private. 

and later Barb said:
	If it can test against a MP, is controlled by a single entity, 
	and can potentially report its info, 
	then (1) I don't see where having it in scope adds much complexity, and 
	(2) by having it in scope, that means things can be said about it. 
	For example, by having it in scope, it's possible to provide it with 
	guidance around how to interpret results and how to get and use service 
	attributes and how to play nice with others. And how to ensure customer privacy.
	<play nice in sandbox metaphor deleted>

This last idea has implications for item B, the request for tests and the results.
So we might recognize the overarching privacy consideration in the charter, and say:

  B - clarify that in case 2 there'd be an *unspecified* interface to request tests and see results 
     (just as this is mentioned for case 1), which will conform to LMAP guidance on privacy
     and user information control.
  C - clarify that in case 2 - if a user reports Measurement Results to another party, they have
      the option to suppress information in the report to conform to LMAP guidance on privacy
      and user information control.
      
(I have another discussion point with case 2, but I'll send that separately.)
Al

> STARK, BARBARA H
> Sent: Wednesday, September 04, 2013 6:36 PM
> To: Bugenhagen, Michael K; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
> 
> > So are we discussing a Large scale, or a Home testing component... or
> both
> > and how they fit together?
> >
> I was thinking of a MA that the customer downloads onto a customer-owned
> device that tests the Internet connection. It may test against the same
> MPs being used by entities that publish provider performance statistics.
> It may even be provided by such an entity. I'm not thinking of a MA that
> just tests the home network. I'm not thinking of how they fit together.
> 
> If it can test against a MP, is controlled by a single entity, and can
> potentially report its info, then (1) I don't see where having it in scope
> adds much complexity, and (2) by having it in scope, that means things can
> be said about it. For example, by having it in scope, it's possible to
> provide it with guidance around how to interpret results and how to get
> and use service attributes and how to play nice with others. And how to
> ensure customer privacy.
> 
> If this customer-controlled MA is going to play in the same sandbox with
> all the other little MAs, I'd prefer for it to abide by sandbox etiquette.
> Barbara
>