Subject: [lmap] LMAP Framework issue #2 (take 2) Starting and stopping Measurement Tasks

From: <[email-masked]>
Date: Thu, 12 Sep 2013 17:40:42 +0100

Thanks for the great discussion about this point as well. again I adjusted the title. I think we converged on this issue - well let's see if I'm wrong!

Starting and stopping Measurement Tasks
Many Active Measurement Tasks begin with a pre-check before the test traffic is sent. Action could include:
*  the MA checking that there is no cross-traffic (ie that the user isn't already sending traffic);
*  the MA checking with the Measurement Peer that it can handle a new Measurement Task (in case the MP is already handling many Measurement Tasks with other MAs);
*  the first part of the Measurement Task consisting of traffic that probes the path to make sure it isn't overloaded.

It is possible that similar checks continue during the Measurement Task, especially one that is long-running &/or creates a lot of traffic, and it is abandoned whilst in-progress. Action could include:

*         For 'upload' tests, the MA not sending traffic

*         For 'download' tests, the MA closing the TCP connection or sending a TWAMP Stop control message.

If there is some unexpected network issue, the measurement system may want to eliminate inessential traffic. Therefore the Controller has the ability to send a "suppress" message to MAs. As a result, temporarily the MA does not start new Active Measurement Tasks, and it may also stop in-progress Measurement Tasks, especially ones that are long-running &/or creates a lot of traffic.

The LMAP WG does not define a generic start and stop process, since the correct approach depend on the particular Measurement Task; the details are defined as part of each Measurement Method, and hence potentially by the IPPM WG. This also means that the LMAP framework doesn't define a coordination process between MAs; whilst a measurement system may define coordinated Measurement Schedules across its various MAs, there is no direct coordination between MAs.

The MA does not inform the Controller about Measurement Tasks starting or stopping. The Measurement Report includes the start and end of suppression, and it labels (or perhaps doesn't include) Measurement Results impacted by for instance cross-traffic.

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 03 September 2013 18:23
To: [email-masked]
Subject: [lmap] LMAP Framework issue #2 Admission control and measurement suppression

Another issue....

Admission control functionality pre-checks that it is a suitable moment to carry out a Measurement Task. It is the job of the Measurement Method to define such a pre-check - hence this is in the scope of IPPM rather than LMAP. Action could include:
*  the MA checking that there is no cross-traffic (ie that the user isn't already sending traffic) before the Measurement Task starts sending traffic;
*  the first part of the Measurement Task consisting of the MA asking the Measurement Peer whether it can send test traffic;
*  the first part of the Measurement Task consisting of traffic that probes the path to make sure it isn't overloaded;
*  the Measurement Task detecting the presence of cross-traffic after the MA (&/or MP) has started sending traffic.

Note that the LMAP WG does not define a generic admission control process, since the correct approach depends on the particular Measurement Task. This also means that the framework doesn't define a coordination process between MAs; whilst a measurement system may define coordinated Measurement Schedules across its various MAs, there is no direct coordination between MAs.

In addition the Controller may want to send a "suppress" message to some MAs so that they temporarily stop performing Active Measurement Tasks - perhaps there is some unexpected network issue and the ISP wants to eliminate inessential traffic. Since some Measurement Tasks involve the MP sending traffic to the MA, so this suggests the MA may sometimes need to send a "suppress" message to the MP.

Discussion needed...
1. the Broadband Forum liaison mentioned a generic admission process, but my impression is that people no longer think this is needed. Just wanted to make sure I got that right.
2. I've heard a couple of comments that suppression is needed, but we haven't had much discussion - do people agree?
3. the Information Model should discuss how suppression gets recorded in the results (perhaps the on-going results get scrapped - perhaps the results are marked with a warning - perhaps it depends on the metric?)
4. suppress is a bit messy if the MP is sending traffic to the MA (eg download speed test). One MP may be sending to several MAs. perhaps the suppress msg should go directly to the MP? Of course if the MP doesn't have lmap functionality then there's nothing that can be done in any case.

Comments?
Thanks
phil

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 13 Sep 2013 11:50:15 +0200

Hi Phil,

one comment below...

El 12/09/13 18:40, [email-masked] escribió:
>
> Thanks for the great discussion about this point as well. again I 
> adjusted the title. I think we converged on this issue – well let’s 
> see if I’m wrong!
>
> * the MA checking that there is no cross-traffic (ie that the user 
> isn’t already sending traffic);
>
> * the MA checking with the Measurement Peer that it can handle a new 
> Measurement Task (in case the MP is already handling many Measurement 
> Tasks with other MAs);
>
> * the first part of the Measurement Task consisting of traffic that 
> probes the path to make sure it isn’t overloaded.
>
> It is possible that similar checks continue during the Measurement 
> Task, especially one that is long-running &/or creates a lot of 
> traffic, and it is abandoned whilst in-progress. Action could include:
>
> ·For ‘upload’ tests, the MA not sending traffic
>
> ·For ‘download’ tests, the MA closing the TCP connection or sending a 
> TWAMP Stop control message.
>
> If there is some unexpected network issue, the measurement system may 
> want to eliminate inessential traffic. Therefore the Controller has 
> the ability to send a “suppress” message to MAs. As a result, 
> temporarily the MA does not start new Active Measurement Tasks, and it 
> may also stop in-progress Measurement Tasks, especially ones that are 
> long-running &/or creates a lot of traffic.
>
> The LMAP WG does not define a generic start and stop process, since 
> the correct approach depend on the particular Measurement Task;
>

i think that the last exchange with Al we converged to:
- lmap will define a generic mechanism to inform from the controller to 
the MA that the current and ongoing tests are to be stopped.
- the actuall messages and actions that need to happen in order to 
actually do this depends on the specific test, hence out of the scope 
for lmap

regards, marcelo

> the details are defined as part of each Measurement Method, and hence 
> potentially by the IPPM WG. This also means that the LMAP framework 
> doesn’t define a coordination process between MAs; whilst a 
> measurement system may define coordinated Measurement Schedules across 
> its various MAs, there is no direct coordination between MAs.
>
> The MA does not inform the Controller about Measurement Tasks starting 
> or stopping. The Measurement Report includes the start and end of 
> suppression, and it labels (or perhaps doesn’t include) Measurement 
> Results impacted by for instance cross-traffic.
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of [email-masked]
> *Sent:* 03 September 2013 18:23
> *To:* [email-masked]
> *Subject:* [lmap] LMAP Framework issue #2 Admission control and 
> measurement suppression
>
> Another issue….
>
> Admission control functionality pre-checks that it is a suitable 
> moment to carry out a Measurement Task. It is the job of the 
> Measurement Method to define such a pre-check – hence this is in the 
> scope of IPPM rather than LMAP. Action could include:
>
> * the MA checking that there is no cross-traffic (ie that the user 
> isn’t already sending traffic) before the Measurement Task starts 
> sending traffic;
>
> * the first part of the Measurement Task consisting of the MA asking 
> the Measurement Peer whether it can send test traffic;
>
> * the first part of the Measurement Task consisting of traffic that 
> probes the path to make sure it isn’t overloaded;
>
> * the Measurement Task detecting the presence of cross-traffic after 
> the MA (&/or MP) has started sending traffic.
>
> Note that the LMAP WG does not define a generic admission control 
> process, since the correct approach depends on the particular 
> Measurement Task. This also means that the framework doesn’t define a 
> coordination process between MAs; whilst a measurement system may 
> define coordinated Measurement Schedules across its various MAs, there 
> is no direct coordination between MAs.
>
> In addition the Controller may want to send a “suppress” message to 
> some MAs so that they temporarily stop performing Active Measurement 
> Tasks – perhaps there is some unexpected network issue and the ISP 
> wants to eliminate inessential traffic. Since some Measurement Tasks 
> involve the MP sending traffic to the MA, so this suggests the MA may 
> sometimes need to send a “suppress” message to the MP.
>
> Discussion needed…
>
> 1. the Broadband Forum liaison mentioned a generic admission process, 
> but my impression is that people no longer think this is needed. Just 
> wanted to make sure I got that right.
>
> 2. I’ve heard a couple of comments that suppression is needed, but we 
> haven’t had much discussion – do people agree?
>
> 3. the Information Model should discuss how suppression gets recorded 
> in the results (perhaps the on-going results get scrapped – perhaps 
> the results are marked with a warning – perhaps it depends on the metric?)
>
> 4. suppress is a bit messy if the MP is sending traffic to the MA (eg 
> download speed test). One MP may be sending to several MAs. perhaps 
> the suppress msg should go directly to the MP? Of course if the MP 
> doesn’t have lmap functionality then there’s nothing that can be done 
> in any case.
>
> Comments?
>
> Thanks
>
> phil
>
>
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: <[email-masked]>
Date: Fri, 13 Sep 2013 17:31:19 +0100

[phil] that's what i meant - the way you put it is clearer!

---

From: "Sharam Hakimi" <[email-masked]>
Date: Fri, 13 Sep 2013 13:28:33 -0400

Is the assumption here for all MAs under a controller control, and not
MAs under user control. MAs under user control would not necessarily
respond to this command.

Sharam

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Friday, September 13, 2013 12:31 PM
To: [email-masked]; [email-masked]
Subject: Re: [lmap] LMAP Framework issue #2 (take 2) Starting and
stopping Measurement Tasks

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 13 Sep 2013 14:11:26 -0400

Editing the second point slightly, if I may:

 - the actual messages and actions needed to
 do this depends on the specific test, hence are unspecified by LMAP
                                             ^^^^^^^^^^^^^^^^^^^^^^^
(we expect the scope of LMAP's control to include actions in 
 the test protocol, but we leave it to those protocols to 
 do what they can to abort a test)

Al

> Subject: Re: [lmap] LMAP Framework issue #2 (take 2) Starting and stopping
> Measurement Tasks
>

---

From: <[email-masked]>
Date: Mon, 16 Sep 2013 09:04:10 +0100

>Sharam Hakimi
>Sent: 13 September 2013 18:29
>To: Eardley,PL,Philip,TUB8 R; [email-masked]; [email-masked]

It would be the same. The user may have scheduled long-term tests that they want to temporarily suppress.

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Mon, 16 Sep 2013 14:43:23 +0000

I agree with a "red light" command to push out to MA's.

But this also suggests we need a green light to allow testing, and since we're on the topic is there any such use case where a yellow light might be wise (say I know there's problems so I don't want to throughput test, but I do want to do OAM, and passive testing) ?

-M