Subject: Re: [lmap] New Version Notification for draft-liu-lmap-rest-03.txt

From: "Vic Liu(CMCC)" <[email-masked]>
Date: Mon, 11 May 2015 12:51:16 +0800

Hi Dear Juergen

1)For one example:
in Information Model of Report: (Four element are defined)
     object {
         datetime            ma-report-date;
        [uuid                ma-report-agent-id;]
        [string              ma-report-group-id;]
        [ma-report-task-obj  ma-report-tasks<0..*>];
     } ma-report-obj;

In the data model, there are two questions, firstly the four element is not defined as the same name as information model. Secondly, the ro header and re raw is not defined in information model.
      +---n report
         +--ro date        yang:date-and-time
         +--ro agent-id?   yang:uuid
         +--ro group-id?   string
         +--ro task* [name]
         |  +--ro name                   string
         |  +--ro (task-identification)
         |  |  +--:(registry)
         |  |  |  +--ro registry?              inet:uri
         |  |  +--:(program)
         |  |     +--ro program?               string
         |  +--ro option* [name]
         |  |  +--ro name     string
         |  |  +--ro value?   string
         |  +--ro tag*                   string
         |  +--ro suppress-by-default?   boolean
         +--ro header
         |  +--ro column*   string
         +--ro row*
            +--ro start       yang:date-and-time
            +--ro end?        yang:date-and-time
            +--ro conflict*   string
            +--ro value*      string

2)What I mean the subset of RESTconf is that we used PUT/POST/GET function which is subset of all RESTconf function. 

Thank you!

BTW, I didn't see how to join tomorrow's meeting, there is no VoIP number?

ALL THE BEST!
---------------------------------------------------------------------------------------------
Vic Liu
China Mobile Research Network Dept.
Mobile: +86- 13810761678
Email: [email-masked]
---------------------------------------------------------------------------------------------
「梦は逃げない、逃げるのはいつも自分だ」

-----邮件原件-----
发件人: lmap [mailto:[email-masked]] 代表 Juergen Schoenwaelder
发送时间: 2015年5月10日, 星期日 14:51
收件人: Vic Liu(CMCC)
抄送: 'Romascanu, Dan (Dan)'; [email-masked]
主题: Re: [lmap] New Version Notification for draft-liu-lmap-rest-03.txt

On Sun, May 10, 2015 at 02:20:21PM +0800, Vic Liu(CMCC) wrote:
> Hi Dear Juergen
> 
> Thank you very much for your comment and question.
> For your question about YANG:
> 	In July 2014, we submitted the draft using Rest-style http and Json 
> for the LMAP protocol draft and we ran demo afterwards. The JSON 
> formats are follow the working group information model. As the discuss 
> going on and well in our working group, YANG model is accepted by 
> theWG(which is your draft [draft-ietf-lmap-yang-00], and it’s really 
> an amazing work I have to say) and we start to follow the working 
> group and add YANG model. We add YANG also follow the information 
> model. (The YANG Model here is more like a schema and real data is still JSON.)
> 	We realized your question that it's not well format as the 
> [draft-ietf-lmap-yang-00] because We find out that some definition of 
> parameters are different between the information model draft and YANG 
> model draft. So that's also our question to the working group that we 
> think it should have the same definition of parameter of both two draft.

Please tell us where you think the YANG data model and the information model are not consistent. Give us details. I am not going through some other YANG model that does not even have descriptions to search for possible differences.
 
> For your second about RESTCONF:
> 	Firstly we do have to apologized for not reference RESTCONF draft, 
> it's a big mistake and we'll add the reference ASAP in the next 
> update(Sorry for the careless). The answer for your statement can be 
> the second one, a subset of RESTconf, because firstly to achieve YANG 
> model transit, the Restconf is the one to do it easily. Secondly, 
> because of the previous draft is based on Rest-style http, it's not so 
> different to change it to REST conf.

Please explain why you think a subset of RESTCONF should be defined and why simply using RESTCONF is not feasible.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

_______________________________________________
lmap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lmap

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 11 May 2015 07:49:58 +0200

On Mon, May 11, 2015 at 12:51:16PM +0800, Vic Liu(CMCC) wrote:
> In the data model, there are two questions, firstly the four element is not defined as the same name as information model.

There is no requirement that the same name is used. That said, I think

>          +--ro agent-id?   yang:uuid

is a very close match.

> Secondly, the ro header and re raw is not defined in information model.

Yes, but there is no requirement that there must be a 1:1
translation. We found that separating header information from row
information adds clarity. Note also that the result rows are actually
in a separate ma-report-row-obj; so I could argue that for rows the
separation is even in the information model.
 
> 2)What I mean the subset of RESTconf is that we used PUT/POST/GET function which is subset of all RESTconf function.

You need to provide a reason why this is useful. For example, leaving
out HEAD is I think a major problem.

/js