Subject: [lmap] draft-ietf-lmap-information-model-05: Calendar attributes

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 12 May 2015 15:43:41 +0000

Team,

I was reviewing draft-ietf-lmap-information-model-05 and I think we have a problem with the new definitions.

We changed the attribution from int to a string to allow for wildcards - I guess.

The problem is with empty lists and the meaning of no months|days|hours|minutes|seconds. If I would evaluate this correctly anytime I have an empty list value all the other attribute values would be left mute.

For example a schedule with no months would mean that any constraint (e.g., between the hours of 2-3pm all days would not be considered as the days are in a month context. So we are assuming an empty list to be "ALL" values anyway - which means the same thing as *.

In the TR-069 model I simply has if the list was empty then all values would be considered.

I would recommend we put this back to the way it was in draft 04 and simply indicate an empty list means all values are to be considered (e.g., wildcard)

BTW - days-of-week has a typo it should default to no days instead of no months.

Thanks,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 12 May 2015 18:59:51 +0200

> We changed the attribution from int to a string to allow for wildcards - I guess.

Yes.
 
> I would recommend we put this back to the way it was in draft 04 and simply indicate an empty list means all values are to be considered (e.g., wildcard)

This leads to the problem that led to the introduction of wildcards.
If everything is left empty (or unconfigured), you fire things with a
very high frequency. You can still get that with wildcards but you
have to explicitely configure them - you do not get this aggressive
behaviour by accidentally emptying the last element. This change was
discussed on the list a while ago.

> BTW - days-of-week has a typo it should default to no days instead of no months.

Thanks, fixed in my sources.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 12 May 2015 18:05:04 +0000

Juergen,

So what is the behavior when I have an empty month but non-empty entries in the other criteria?

For example empty months with * days of week, * days of month, *etc...

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Tuesday, May 12, 2015 12:00 PM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] draft-ietf-lmap-information-model-05: Calendar attributes

Yes.
 
> I would recommend we put this back to the way it was in draft 04 and 
> simply indicate an empty list means all values are to be considered 
> (e.g., wildcard)

This leads to the problem that led to the introduction of wildcards.
If everything is left empty (or unconfigured), you fire things with a very high frequency. You can still get that with wildcards but you have to explicitely configure them - you do not get this aggressive behaviour by accidentally emptying the last element. This change was discussed on the list a while ago.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 13 May 2015 07:59:24 +0200

> For example empty months with * days of week, * days of month, *etc...

"If not present, it defaults to no months."

This means no action will be triggered. In other words, all components
need to be explicitely configured for some action to be triggered.

/js