Subject: [lmap] draft-ietf-lmap-information-model-05: MA task capabilities

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Mon, 11 May 2015 19:33:01 +0000

Team,

I was reviewing draft-ietf-lmap-information-model-05 and had a question on the what happened to the task capabilities and conditions as part of the MA status. The text is still in the draft but the elements are gone...

Any help would be appreciated

Thanks,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 12 May 2015 11:55:37 +0200

> I was reviewing draft-ietf-lmap-information-model-05 and had a question on the what happened to the task capabilities and conditions as part of the MA status. The text is still in the draft but the…

There is ma-task-status-obj defined in section 3.5.2. Is this what you
are looking for? Otherwise, please tell me which text you refer to
where you can't find matching definitions.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 12 May 2015 11:46:26 +0000

Juergen,

Yes in draft 04 there were 2 attributes in section 3.5 which are not in draft 05:
ma-supported-tasks and ma-conditions.

BR,
Tim
-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Tuesday, May 12, 2015 4:56 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] draft-ietf-lmap-information-model-05: MA task capabilities

> I was reviewing draft-ietf-lmap-information-model-05 and had a question on the what happened to the task capabilities and conditions as part of the MA status. The text is still in the draft but the…

There is ma-task-status-obj defined in section 3.5.2. Is this what you are looking for? Otherwise, please tell me which text you refer to where you can't find matching definitions.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 12 May 2015 14:28:42 +0200

On Tue, May 12, 2015 at 11:46:26AM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> Yes in draft 04 there were 2 attributes in section 3.5 which are not
> in draft 05: ma-supported-tasks and ma-conditions.

-04 had in ma-status-obj:

    ma-task-capability-obj  ma-supported-tasks<0..*>;
   [ma-condition-obj        ma-conditions<0..*>;]

    object {
      string              ma-task-name;
      string              ma-task-role;
      uri                 ma-task-registry;
    } ma-task-capability-obj;

    object {
      int                   ma-condition-code;
      string                ma-condition-text;
    } ma-condition-obj

-05 has instead in ma-status-obj:

   [ma-task-status-obj      ma-task-status<0..*>;]

   object {
       string              ma-task-name;
       [uri                ma-task-registry-entry;]
       [string             ma-task-role<0..*>;]
       datetime            ma-task-last-invocation;
       datetime            ma-task-last-completion;
       int                 ma-task-last-status;
       string              ma-task-last-message;
       datetime            ma-task-last-failed-completion;
       int                 ma-task-last-failed-status;
       string              ma-task-last-failed-message;
   } ma-task-status-obj;

In other words, the attributes formerly contained in
ma-task-capability-obj became attributes of ma-task-status-obj and
instead of having a static list of condition codes and texts, we now
have the condition code and text of the last execution and the last
failed execution. This change was discussed on the mailing list (the
motivation is that this is useful information to troubleshoot things
while a static code/text list does not necessarily belong into the
information model / data model).

/js