Subject: [lmap] New Version Notification for draft-liu-lmap-rest-03.txt

From: "Vic Liu(CMCC)" <[email-masked]>
Date: Wed, 6 May 2015 17:09:45 +0800

Dear Dan and Work Group

We've upload the protocol draft of LMAP. Please kindly have a review.
In this draft we update the protocol using YANG model and modify the rest-style to RESTconf along with the protocol code implementations. 
Hope we can discuss in 5/11 meeting. 

All the Best!
Vic

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2015年5月6日, 星期三 17:02
收件人: Dapeng Liu; Vic Liu; Cathy Li; Shu Liu; Deng Lingli; Shu Liu; Lingli Deng; Dapeng Liu; Cathy Li; vic
主题: New Version Notification for draft-liu-lmap-rest-03.txt

A new version of I-D, draft-liu-lmap-rest-03.txt has been successfully submitted by Vic Liu and posted to the IETF repository.

Name:		draft-liu-lmap-rest
Revision:	03
Title:		REST Style Large MeAsurement Platform Protocol
Document date:	2015-05-06
Group:		Individual Submission
Pages:		46
URL:            https://www.ietf.org/internet-drafts/draft-liu-lmap-rest-03.txt
Status:         https://datatracker.ietf.org/doc/draft-liu-lmap-rest/
Htmlized:       https://tools.ietf.org/html/draft-liu-lmap-rest-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-liu-lmap-rest-03

Abstract:
   This document defines and implements a LMAP protocol based on YANG
   Model and Rest-style http for control and report in Large Scale
   Performance Measurement (LMAP).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 6 May 2015 09:10:05 +0000

Thanks, Vic!

Please all WG members - read and send your comments to the WG mail list. 

We shall include a discussion of this I-D on the agenda of the LMAP interim meeting on Monday, but best will be if questions and comments are submitted before the meeting. 

Regards,

Dan

> -----Original Message-----
> From: Vic Liu(CMCC) [mailto:[email-masked]]
> Sent: Wednesday, May 06, 2015 12:10 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Subject: New Version Notification for draft-liu-lmap-rest-03.txt
> 
> Dear Dan and Work Group
> 
> In this draft we update the protocol using YANG model and modify the rest-
> style to RESTconf along with the protocol code implementations.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 6 May 2015 11:39:26 +0200

> Hope we can discuss in 5/11 meeting. 

Can you explain how the YANG fragments embedded in your I-D differ
from draft-ietf-lmap-yang-00.txt? Is this just material copied from
the YANG LMAP I-D with descriptions removed and then somewhat
modified? I do not know how to parse this statement:

  Some work can refer to [[I-D.ietf-lmap-yang-00]].

Unfortunately, there are no description clauses in your YANG fragments

Also for the protocol, can you explain how this relates to RESTCONF?
Are you proposing to use (i) something like RESTCONF or (ii) a subset
of RESTCONF or (iii) simply RESTCONF? From looking at the document, it
seems you propose (i) (why would you otherwise go into the details of
defining response codes, something that RESTCONF already takes care
of; and I also note that you do not reference RESTCONF at all).

I like to see some clear technical arguments for the following two
questions:

- Why do you think RESTCONF can't be used as is?
- Why do you think the YANG data model for LMAP can't be used as is.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>