Subject: Re: [Lsvr] [Dcrouting] A comment on draft-keyupate-idr-bgp-spf

From: Keyur Patel <[email-masked]>
Date: Tue, 2 Jan 2018 17:49:07 +0000

+1 to what Acee said.

Furthermore, we could chose to consider such an interaction as a matter of local policy (implementation specific).

Regards,
Keyur

From: Lsvr <[email-masked]> on behalf of "Acee Lindem (acee)" <[email-masked]>
Date: Tuesday, January 2, 2018 at 9:29 AM
To: Alvaro Retana <[email-masked]>, Xuxiaohu <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Lsvr] [Dcrouting] A comment on draft-keyupate-idr-bgp-spf

Used as an underlay, BGP SPF just works. What needs to be defined are the rules when the same prefix is advertised in both address families.
Thanks,
Acee

From: Dcrouting <[email-masked]<mailto:[email-masked]>> on behalf of Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 22, 2017 at 9:20 AM
To: Xiaohu Xu <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Dcrouting] A comment on draft-keyupate-idr-bgp-spf

On December 22, 2017 at 3:27:24 AM, Xuxiaohu ([email-masked]<mailto:[email-masked]>) wrote:

Xiaohu:

Hi!

I wonder whether it's worthwhile to consider the coexistence of the traditional BGP-DV protocol and the BGP-SPF protocol on a given node. If so...

Yes, I think so.

That (coexistence with/separation from traditional BGP) is one of the pieces that I expect to see in a forthcoming proposed charter for lsvr — please subscribe to that list (cc’d here) and contribute your comments and ideas there. :-)

Thanks!!

Alvaro.

---

From: Randy Bush <[email-masked]>
Date: Wed, 03 Jan 2018 12:21:16 +0900

> Furthermore, we could chose to consider such an interaction as a
> matter of local policy (implementation specific).

pedantry: s/implementation/configuration/.  i.e. op chooses, not vendor.

randy

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 3 Jan 2018 12:40:53 +0000

Agreed. Thanks Randy!

Plan to refresh the draft this week.

Acee

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 3 Jan 2018 10:07:22 -0500

It seems to me that having two different BGP decision processes 
available is going to have significant impact on achieving consistency 
so taht routing actually converges. I suspect it willnot take much to 
define what choices are stable and effective.

Leaving out any comments on how to make this (coexistence) work seems a 
mistake.

Yours,
Joel

On 1/3/18 7:40 AM, Acee Lindem (acee) wrote:
> _______________________________________________
> Dcrouting mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dcrouting
>

---

From: Keyur Patel <[email-masked]>
Date: Wed, 3 Jan 2018 17:59:28 +0000

Yep. Agreed.

    
    
    randy

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Jan 2018 17:39:24 +0000

Hi Joel, 

Yes - this is one of the areas of complexity when implementing BGP SPF. It
is the reason why we allocate a separate SAFI from normal BGP-LS state
distribution. 

Thanks,
Acee

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 5 Jan 2018 20:09:20 +0000

Today there are well defined (perhaps vendor-specific) procedures to choose if an OSPF route or a BGP route is used for a particular prefix. I assume if we treat BGP-SPF as a another protocol, then the problems is solved already?

Jeffrey

> -----Original Message-----
> From: Acee Lindem (acee) [mailto:[email-masked]]
> Sent: Friday, January 5, 2018 12:39 PM
> To: Joel M. Halpern <[email-masked]>; EXT - randy <[email-masked]>;
> Keyur Patel <[email-masked]>
> Cc: Xuxiaohu <[email-masked]>; [email-masked]; [email-masked];
> Alvaro Retana <[email-masked]>
> Subject: Re: [Dcrouting] [Lsvr] A comment on draft-keyupate-idr-bgp-spf
> 
> Hi Joel,
> 
> 
> 
> >>> pedantry: s/implementation/configuration/.  i.e. op chooses, not
> 
> >>>vendor.
> 
> >>>
> 
> >>> randy
> 
> >>
> 
> >> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_dcrouting&d=DwIGaQ&c=HAkYuh63rsuh
> r6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=McIBlcLiNR1_v9Xp7j78qy127iH7R2ligpIRqY90OIU&s=_17xJYnJBWF_Rzk4scZ
> 2p_3JsJiY5mknH-oXOsDVfn4&e=
> 
> >>
> 
> >
> 
> >https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_dcrouting&d=DwIGaQ&c=HAkYuh63rsuh
> r6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=McIBlcLiNR1_v9Xp7j78qy127iH7R2ligpIRqY90OIU&s=_17xJYnJBWF_Rzk4scZ
> 2p_3JsJiY5mknH-oXOsDVfn4&e=
> 
>

---

From: Michael Hallgren <[email-masked]>
Date: Fri, 05 Jan 2018 23:12:15 +0100

Hi guys,

Yes, normally. Now, I guess the question that we have on our table
is: what fundamental problem has been identified to trigger the proposed 
solution? No?

Cheers,
mh

Le 2018-01-05 21:09, Jeffrey (Zhaohui) Zhang a écrit :
> Today there are well defined (perhaps vendor-specific) procedures to
> choose if an OSPF route or a BGP route is used for a particular
> prefix. I assume if we treat BGP-SPF as a another protocol, then the
> problems is solved already?
> 
> Jeffrey
>