Subject: [Maprg] Suggested minor tweak to proposed charter text

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 15 Jan 2016 09:47:23 -0600

(Speaking as an individual)

I like where the proposed charter is headed, but struggled with the first
few sentences:

Our Internet has grown into something that differs from what was envisioned.

Its protocols sometimes operate in an environment other than than that for

which they were designed. For instance, some network elements treat some

protocols differently than others and those protocols themselves are sometimes

reused and abused in ways initially unforseen.

You might consider something like

Our Internet continues to evolve in ways that were not anticipated
when protocols

and policies were put in place. The end-to-end design principle is now
competing

with the inclusion of intelligence in network elements, so that protocol-

specific functionality is often encountered on a network path.
Protocols are reused

in surprising ways, and this reuse may reach the level of abuse.

Thanks.

Spencer

---

From: Brian Trammell <[email-masked]>
Date: Fri, 15 Jan 2016 16:53:05 +0100

hi Spencer,

> On 15 Jan 2016, at 16:47, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> I like where the proposed charter is headed, but struggled with the first few sentences:
> 
> Our Internet continues to evolve in ways that were not anticipated when protocols
> and policies were put in place. The end-to-end design principle is now competing

I really like this bit, and think we should use it instead of the current first paragraph.

> Protocols are reused in surprising ways, and this reuse may reach the level of abuse.

I'm not following you here though, could you illustrate what you mean a bit?

Thanks, cheers,

Brian

> Thanks.
> 
> Spencer
> _______________________________________________
> Maprg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/maprg

---

From: "SCHARF, Michael (Michael)" <[email-masked]>
Date: Fri, 15 Jan 2016 16:02:10 +0000

I agree that Spencer's wording is better.

Two smaller nits:

I am not a native speaker, but I would recommend to review the wording "Our Internet".  

Also, the text uses the term "Internet measurements" a number of times. Maybe that could be relaxed in some cases. I might be wrong, but there is some believe that e.g. TCP middleboxes are relatively common in private networks (e.g., corporate LANs), unlike in the public Internet. Whether data about private networks will indeed be shared is a separate question...

Michael

-----Original Message-----
From: Maprg [mailto:[email-masked]] On Behalf Of EXT Brian Trammell
Sent: Friday, January 15, 2016 4:53 PM
To: Spencer Dawkins at IETF
Cc: [email-masked]
Subject: Re: [Maprg] Suggested minor tweak to proposed charter text

hi Spencer,

> Its protocols sometimes operate in an environment other than than that 
> for which they were designed. For instance, some network elements 
> treat some protocols differently than others and those protocols 
> themselves are sometimes reused and abused in ways initially unforseen.
> 
> when protocols and policies were put in place. The end-to-end design 
> principle is now competing with the inclusion of intelligence in 
> network elements, so that protocol- specific functionality is often encountered on a network path.

Thanks, cheers,

Brian

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 15 Jan 2016 10:03:54 -0600

Hi, Brian,

On Fri, Jan 15, 2016 at 9:53 AM, Brian Trammell <[email-masked]> wrote:

> for

I was chewing on "those protocols themselves are sometimes reused and
abused in ways initially unforseen", so I'm not entirely sure what the
current charter text means by that, but I had immediately assumed that
https://tools.ietf.org/html/bcp56 would qualify as an example of what the
proposed charter was talking about.

If my proposal wasn't clear, perhaps adding "For example, the HTTP
application protocol has been widely reused as a transport protocol for
other applications" would be helpful.

Thanks for considering this.

Spencer