Subject: RE: [Mobike] New issue 17: Full connectivity

From: <[email-masked]>
Date: Fri, 3 Sep 2004 15:38:36 +0300

Hi,

Yes, I certainly agree that we should not assume this. I brought this 
up because at some point, Francis was suggesting that each end 
should be responsible for only changing its own address 
(e.g. 2004-07-29), but probably I misunderstood him here.

This question also has an important relationship to issue 16: in 
general, it may be difficult to tell the difference between lack of 
full connectivity and a failure somewhere in the middle of the 
network (and usually there is even no need to tell the difference).

So the answers to these issues are related: if we handle the lack 
of full connectivity properly, we most likely have everything needed 
to recover from problems that can only be detected by end-to-end 
messages (e.g., failure in the "middle of the network"); and vice
versa.

Best regards,
Pasi

> -----Original Message-----
> From: Mohan Parthasarathy
> Sent: Friday, September 03, 2004 3:14 AM
> To: Eronen Pasi (Nokia-NRC/Helsinki); [email-masked]
> Subject: Re: [Mobike] New issue 17: Full connectivity
> 
> Pasi,
> 
> I might have missed this at San Deigo. Why would anybody
> assume about the connectivity about the address i.e why is
> this question even coming up ?  If both the peers have
> multiple address, then you have to support address list and
> can't make any assumptions about the connectivity. You said
> below that if we don't make the assumption, then both address
> can change at the same time on the SAs. Perhaps, i am missing
> the "assumption" part.  Assuming something is fully connected
> at some point in time does not mean that it stays that way
> forever. So, even if we make the assumption, both the address
> may change at the same time, right ? What am i missing ?
>  
> -mohan
> 
> ----- Original Message ----- 
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, August 24, 2004 8:10 AM
> Subject: [Mobike] New issue 17: Full connectivity
> 
> 
> Hi,
> 
> Based on talks at San Diego, I've created a new issue
> on the issue tracker:
> 
>    "If both parties have several addresses, do we assume 
>   that all pairs have connectivity between them?"
> 
> There was discussion about this in mid-April (one example 
> mentioned was two SGWs connected via two different private 
> networks), and most people thought we should not assume this.
> 
> Assuming this would also seem to largely rule out IPv4/v6
> mobility.
> 
> If we decide _not_ to make this assumption, then we have cases 
> where we have to change both parties's addresses in SAs 
> at the same time.
> 
> It also seems the protocol will require some kind of address
> lists, so something like SMOBIKE won't work (unless we assume 
> one party knows several addresses for the other party via some 
> other means than address lists sent within the protocol).
> 
> Any comments?
> 
> Best regards,
> Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Sat, 04 Sep 2004 16:56:36 +0200

In your previous mail you wrote:

=> perhaps a SHOULD is a bit too strong here, IMHO this is only the
common/likely case. There is a known exception: when the addresses
are paired, it is better to change both addresses.
I have two arguments in favor of my opinion:
 - a node has a better control on the condition of its own addresses
 - when an address becomes unusable, the only critical thing is to
   change the local address of *inbound* SAs.

Thanks

[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike