Subject: RE: [Mobike] transport mode document as WG item

From: <[email-masked]>
Date: Mon, 27 Sep 2004 17:05:37 -0400

Hi Francis,

In the roaming laptop scenario, when the address changes, how would
the mechanism needed to update the address on the remote side 
(corporate gateway) differ whether tunnel mode or transport mode
is used?

That is true tunnel endpoint address in the tunnel mode is maintained
just by IKE demon and localized to IKE. But even in the transport case,
the peer addresses are endpoint addresses, and we change the endpoint 
addresses maintained by IKE, just like we would change TEP in the tunnel 
case. So, thinking out loud, as far as MOBIKE is concerned the mechanism
should be similar whether we are using tunnel or transport mode?

I was just trying to understand, what we will need to do things differently
for the transport case, as far as MOBIKE is concerned?

Regards,
Atul

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of ext Francis Dupont
> Sent: Sunday, September 26, 2004 1:37 PM
> To: [email-masked]
> Subject: [Mobike] transport mode document as WG item
> 
> 
> We have two weeks before the initial WG document submission cut-off
> so I ask the WG item status for the MOBIKE & transport mode document
> (currently draft-dupont-mobike-transport-00.txt). BTW I'd like to get
> comments about it.
> 
> Regards
> 
> [email-masked]
> _______________________________________________
> Mobike mailing list
> [email-masked]
> https://www.machshav.com/mailman/listinfo.cgi/mobike
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Tue, 28 Sep 2004 00:00:11 +0200

In your previous mail you wrote:

=> these addresses have a very different role: in tunnel mode they
are the endpoint addresses, in transport mode they are the traffic
selectors.

=> no, changing an address in transport mode implies far more than
in tunnel mode: MOBIKE must be integrated into the whole IPsec architecture.
We can specify something specific for transport mode, my proposal is to
put transport mode outside the scope of MOBIKE for the moment.

Regards