Subject: RE: [Mobike] issues 18, 15, 6 -- return routability

From: <[email-masked]>
Date: Mon, 9 May 2005 17:29:22 +0300

Hi,

I think we came to agreement on when we can skip the test 
completely (by default, do the check; fancier authorization
is possible but does not have to be standardized). But what
about the before/after moving the traffic part?

(My suggestion would be that this does not have to be 
standardized either. Implementations could even decide it 
on the fly based on some fancy criteria such as credit-based 
things or something.)

Best regards,
Pasi

> -----Original Message-----
> From: Jari Arkko
> Sent: Friday, May 06, 2005 5:03 PM
> To: Francis Dupont
> Cc: [email-masked]
> Subject: Re: [Mobike] issues 18, 15, 6 -- return routability
> 
> 
> Hi Francis,
> 
> >     - If the specific IP address can be found in the peer's 
> >     certificate, you can skip the test
> >   
> > => I maintain my proposal to change this into "if the 
> > specific IP address is already authorized, you can skip 
> > the test".This is more general (as there can be other ways 
> > to authorized an address) and more accurate (so it should 
> > answer Vijay's concern).
>
> Agreed. I think we can close this issue now.
> 
> (At first when I saw this I thought there might be an issue
> with regards to having clear implementation requirements.
> I.e. what is the minimum that an implementation has to do.
> But then I realized that the way that we are apparently going
> to write this is that the additional authorization mechanisms
> are optional, i.e. the minimum you have to do is to always
> do the test. It doesn't matter if you support certificates or
> xmlconf admin interface or look at the moon's phase...)
> 
> --Jari
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Thu, 12 May 2005 13:31:23 +0300

>is possible but does not have to be standardized). But what
Yes.

>about the before/after moving the traffic part?
There was a proposal in [1] with some support
from [2] and [3], a related other question in [4],
no opposition, but not a whole lot of discussion. But
maybe this is in fact enough. Unless you see a
significant technical issue, perhaps we should stick
with the proposal, which was "do it before (if done at
all)".

[1] http://www.machshav.com/pipermail/mobike/2005-March/000692.html
[2] http://www.machshav.com/pipermail/mobike/2005-March/000706.html
[3] http://www.machshav.com/pipermail/mobike/2005-March/000708.html
[4] http://www.machshav.com/pipermail/mobike/2005-March/000694.html

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Fri, 13 May 2005 11:24:08 +0300

Here's a more detailed text proposal: "By default,
return routability test is done before moving the
traffic. However, [as decided in issue 18] these tests
are optional. Nodes MAY also perform these tests upon
their own initiative at other times."

This seems to cover the opinion of the folks expressed
earlier on the list, as well as your comments. Ok?

--Jari

---

From: Tero Kivinen <[email-masked]>
Date: Fri, 13 May 2005 13:27:54 +0300

> their own initiative at other times."

That text looks good for me. 
-- 
[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 13 May 2005 14:25:55 -0700

> earlier on the list, as well as your comments. Ok?

shouldnt the return routability test be highly encouraged,
though? the above text tells me that return routability
tests are completely optional. the responder can do the
test if it wants to.

or is there some other text in some other document which
says this? sorry I havent been following the discussion.

Vijay

---

From: Jari Arkko <[email-masked]>
Date: Wed, 18 May 2005 14:40:16 +0300

I agree. But I think issue 18 covers this already; the
text below is just for discussing when to do it.

(Issue 18 result was that its by default done but there
MAY be some fancier authorization mechanism or
configuration that enables skipping it.)

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Sun, 29 May 2005 17:38:15 +0300

> their own initiative at other times."

(Vijay, I'm hoping that my answer to your question
was satisfactory. Let us know otherwise.)

--Jari