Subject: RE: [Mobike] issue 11 -- window size

From: <[email-masked]>
Date: Fri, 13 May 2005 10:51:57 +0300

Tero Kivinen writes:

> It is possible, the protocol just needs to be written so it
> supports it. If you want to get it working with IKEv2 NAT-T
> you need to add modify the NAT-T behavior when using MOBIKE
> little more (You need to modify the NAT-T behavior in all
> cases)
>
<snip>
> 
> Then you simply say that only N(MOVE TRAFFIC) is the only
> method of updating the addresses. I.e. disable dynamic
> updating of IKEv2 NAT-T (it is already allowed as dynamic
> update is SHOULD not MUST).

Ok, reading this and your previous messages, I think I finally
understood what you meant.. Yes, it seems that this can be made
to work (but IMHO it's much more complicated than a separate
path test message).

Best regards,
Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Fri, 13 May 2005 11:14:13 +0300

>to work (but IMHO it's much more complicated than a separate
Good, so we have two window=1 alternatives. The
problem that we have, however, is that we've only got
one that is described in a very detailed manner, i.e.
what you Pasi have in MOPO. But I talked to Tero and he
promised to write up a more detailed proposal about
this at some point. So I would suggest that we conclude
this issue, for now -- the discussion seems to converge
on some window=1 alternative, as far as I can see.

--Jari