Subject: Re: [Mobike] Issue 64 - Stephane Beaulieu's commentsondraft-mobike-protocol-04.txt

From: "Stephane Beaulieu (stephane)" <[email-masked]>
Date: Mon, 7 Nov 2005 16:56:34 -0500

Sounds good.

Stephane. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Monday, November 07, 2005 4:19 PM
> To: Stephane Beaulieu (stephane)
> Cc: [email-masked]
> Subject: RE: [Mobike] Issue 64 - Stephane Beaulieu's 
> commentsondraft-mobike-protocol-04.txt
> 
> Stephane Beaulieu wrote:
> > > > Section 4.2
> > > > 
> > > > I don't understand why we need to switch to port 4500 even if 
> > > > there is no NAT in the path.  Can someone explain this 
> to me?  Or 
> > > > better yet, explain it in the draft?
> > 
> > > I raised this question also earlier, and the answer was: 
> In case we 
> > > later move to the path that has a NAT box between, and we need to 
> > > enable NAT-T, then we must be on the port 4500 before we enable 
> > > NAT-T.  To avoid hassle to do the changing of the port at 
> that time, 
> > > we do it in the beginning. It does not hurt at all to 
> move to port 
> > > 4500 immediately, if both ends support NAT-T, and it will make 
> > > enabling NAT-T very simple when we later in the 
> UPDATE_SA_ADDRESSES 
> > > notice there is NAT between us.
> > 
> > [SB] Ah.  That makes sense.  Perhaps the reasoning here should be 
> > documented as well.
> 
> The text currently says:	
> 
>    To simplify things, implementations that support both this
>    specification and NAT Traversal MUST change to port 4500 if the
>    correspondent also supports both, even if no NAT was detected
>    between them (this way, there is no need to change the ports
>    later).
> 
> But perhaps the last part could be slightly rephrased. 
> How about this?
> 
>   "(this way, there is no need to change the ports later if a 
>    a NAT is detected on some other path)"
> 
> Best regards,
> Pasi
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: <[email-masked]>
Date: Mon, 7 Nov 2005 23:18:58 +0200

Stephane Beaulieu wrote:
> > > Section 4.2
> > > 
> > > I don't understand why we need to switch to port 4500 even 
> > > if there is no NAT in the path.  Can someone explain this 
> > > to me?  Or better yet, explain it in the draft?
> 
> > I raised this question also earlier, and the answer was: In case
> > we later move to the path that has a NAT box between, and we 
> > need to enable NAT-T, then we must be on the port 4500 before we 
> > enable NAT-T.  To avoid hassle to do the changing of the port at 
> > that time, we do it in the beginning. It does not hurt at all to 
> > move to port 4500 immediately, if both ends support NAT-T, and 
> > it will make enabling NAT-T very simple when we later in the
> > UPDATE_SA_ADDRESSES notice there is NAT between us.
> 

The text currently says:	

Best regards,
Pasi