Subject: Re: [Mobike] Issue 46 (was: protocol draft status and movingforward)

From: <[email-masked]>
Date: Tue, 8 Nov 2005 05:07:24 +0200

Mohan Parthasarathy wrote:
>
> If there is only one address, why do you need to
> explicitly tell your peer that you have
> NO_ADDITIONAL_ADDRESS ? 

Tero already answered this, but here's another take:
we update the address list only if the request contains 
either NO_ADDITIONAL_ADDRESS or ADDITIONAL_*_ADDRESS.
Otherwise, we would have to include the whole address
list in every single IKEv2 request, even when the list
has not changed.

Best regards,
Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Mohan Parthasarathy <[email-masked]>
Date: Tue, 8 Nov 2005 09:35:31 -0800 (PST)

Ok, face to face exchange clarified this.

You send NO_ADDITIONAL_ADDRESS whenever you are left
with just one address and that address appears
in the IP header. ADDITIONAL_ADDRESS is sent only
when you have more than one address. 
 
Perhaps, i am the only one so confused :-) 

-mohan