Subject: [Mobike] Issue 73: Port numbers in examples

From: <[email-masked]>
Date: Mon, 14 Nov 2005 15:51:18 +0200

Stephane pointed out in the WG meeting that the examples
in Section 2.2 don't change to port 4500 as they should.

Best regards,
Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "Stephane Beaulieu (stephane)" <[email-masked]>
Date: Tue, 15 Nov 2005 14:59:28 -0500

Just changing the port values in the example is fine with me.  

The rest appears to have been confusion on my part.

Stephane. 

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Tuesday, November 15, 2005 1:25 PM
> To: Tero Kivinen
> Cc: Stephane Beaulieu (stephane); [email-masked]; 
> [email-masked]
> Subject: Re: [Mobike] Issue 73: Port numbers in examples
> 
> I agree with what Tero is writing below. But from what I 
> understood we are just describing the port numbers in the 
> example, not adding any other new text. Correct?
> 
> Tero Kivinen wrote:
> 
> >Yes. We simply move all IKE traffic to port 4500 immediately when we 
> >notice that other end supports NAT regardless whether there 
> is NAT or 
> >not. The IPsec SAs are still created using normal ESP 
> packets in case 
> >there is no NAT, and if we move behind NAT then we change 
> those IPsec 
> >SAs to use UDP encapsulation too. If we move away from NAT then we 
> >again disable the UDP encapsulation of IPsec packets, but 
> keep the IKE 
> >traffic on port 4500.
> >
> >The reason for this is that if we would do the port switch when we 
> >later detect NAT, it would cause the additional complexity, as 
> >responder do not know the addresses that are going to be used in the 
> >encapsulated packets, as initiator wouldn't had sent any 
> packets with 
> >those addresses and NAT wouldn't have created mapping for 
> the packets 
> >yet.
> >  
> >
>