Subject: [Mobike] D109 design draft issue: security considerations

From: Tero Kivinen <[email-masked]>
Date: Tue, 3 Jan 2006 19:12:49 +0200

Jari Arkko writes:
[issue list: http://www.kivinen.iki.fi/ietf/mobike-design-issues.html
 working copy of document:
 http://www.kivinen.iki.fi/ietf/draft-ietf-mobike-design-06.txt]

> > 7.  Security Considerations
> 
> This section seems weak compared to the one in
> the protocol draft. Consider simply referring to the
> protocol spec unless there is some new information
> (e.g. design decisions not covered in the protocol
> spec).

As we do not really define protocol here, there is not that much of
real security considerations. The current security considerations
lists the generic problems against all protocols of this type.

I am not sure adding pointer to the protocol document helps that much,
as I assume people will read the protocol document anyways, but
perhaps adding text "See Security considerations section of <xref
target="I-D.ietf-mobike-protocol"/> for more information about
security considerations of the actual protocol." helps. 
-- 
[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Thu, 26 Jan 2006 15:52:38 +0200

>security considerations of the actual protocol." helps. 
Yes. Maybe you could also cut the paragraph about
ICMP (since it isn't complete).

--Jari

---

From: Tero Kivinen <[email-masked]>
Date: Fri, 27 Jan 2006 15:43:53 +0200

> ICMP (since it isn't complete).

What do you mean that it is not complete?
-- 
[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Fri, 27 Jan 2006 16:24:54 +0200

It treats only one aspect of unreliable indications (namely,
ICMP), and does not explain everything that should probably
be explained, if you compare with the protocol draft.