Subject: Re: [Mobike] Preliminary minutes from the WG last week

From: "Vijay Devarapalli" <[email-masked]>
Date: Sun, 2 Apr 2006 23:28:26 -0700

hi Yaron,

I think Jim was talking about Mobile IPv6 and
Mobike. The drafts you point to below are all 
Mobile IPv4 related. 

Vijay

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Yaron Sheffer
> Sent: Sunday, April 02, 2006 3:39 AM
> To: 'Paul Hoffman'; [email-masked]
> Subject: Re: [Mobike] Preliminary minutes from the WG last week
> 
> Regarding the combination of MOBIKE and Mobile IP, there are 3 current
> drafts in MIP4 that deal with this:
> 
> - draft-ietf-mip4-vpn-problem-solution-02 (this one is pre-MOBIKE)
> - draft-ietf-mip4-mobike-connectivity-00
> - draft-meghana-mip4-mobike-optimizations-00
> 
> So it's a stretch to say "don't do" MOBIKE and Mobile IP together.
> 
> 	Yaron
> 
> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]] 
> Sent: Wednesday, March 29, 2006 5:49
> To: [email-masked]
> Subject: [Mobike] Preliminary minutes from the WG last week
> 
> Please let me know if you have any changes.
> 
> MOBIKE WG minutes
> IETF 65
> 
> [deleted]
> 
> James Kempf - discussion in Mobile IP group - what happens if 
> you try to
> use Mobile IP and MOBIKE together? Some people believe the answer is
> "don't do that". May need an informational draft (as a new 
> work item) to
> address that.
> 
> [deleted]
> 
> 
> _______________________________________________
> Mobike mailing list
> [email-masked]
> https://www.machshav.com/mailman/listinfo.cgi/mobike
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 4 Apr 2006 00:44:54 -0700

> Personally, I am not as convinced as you are that they should never
> be used together to the same box. What if the client is
> on a v4 network? Or on two separate connections, including
> mixed v4/v6 and NATs. 

ok. for this you would use DS-MIPv6 to setup
an ESP protected IPv6-over-IPv4 tunnel 
between the mobile node and the home agent
with UDP encapsulation for the ESP packets.
DS-MIPv6 should be sufficient. the 'K' bit
would work for the DS-MIPv6 tunnel too. it
wouldn't matter if the outer source address
is IPv4.

> Popping up a level, it seems like
> some combination of IKE/MOBIKE/NAT-T, Mobile IPv6, Mobile
> IPv6 transition mechanisms, and MONAMI6 should be able
> to cover the following situations and combinations of them:
> 
> - Having a separate SGW before you can reach your HA
> - Integrated SGW/HA
> - IPv4 access networks
> - IPv6 access networks
> - NATs and firewalls
> - Multihomed mobile nodes
> - Mobile nodes that you cannot fully trust (e.g. might need
>   a RR before believing their new location)
> - Mobile IPv6 service that requires EAP authentication
> 
> What exact combination of solutions we should use
> is less clear to me. 

here I am afraid we are getting to system 
specifications. not protocols anymore.

Vijay