Subject: Re: [Mobike] Preliminary minutes from the WG last week

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 3 Apr 2006 11:31:03 -0700

hi Jim,

with Mobile IPv6, one can create an IPsec 
protected Mobile IP tunnel between the mobile 
node and the home agent. further, the binding 
update is used as a trigger to update the IKE 
SA too. so Mobile IPv6 provides a solution 
similar to MOBIKE already. so that's why I don't 
expect someone to use the two together between 
the mobile node and the home agent.

Mobile IPv4 does not use IPsec and is a very
different protocol.

Vijay 

ps: FYI, the solution described in 
draft-ietf-mip4-mobike-connectivity-00 has 
been adopted by 3GPP2 for their 3GPP2-WLAN
interworking solution.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James Kempf
> Sent: Monday, April 03, 2006 9:41 AM
> To: Yaron Sheffer; 'Paul Hoffman'; [email-masked]
> Subject: Re: [Mobike] Preliminary minutes from the WG last week
> 
> Yaron,
> 
> Thanx for sending out pointers to these.
> 
> In the MIP6 group, there was some discussion about this, and 
> the message 
> that came up was, in fact, "don't do it". I'll post 
> references to these 
> drafts to the MIP6 list.
> 
>             jak
> 
> ----- Original Message ----- 
> From: "Yaron Sheffer" <[email-masked]>
> To: "'Paul Hoffman'" <[email-masked]>; <[email-masked]>
> Sent: Sunday, April 02, 2006 3:38 AM
> Subject: Re: [Mobike] Preliminary minutes from the WG last week
> 
> 
> > Regarding the combination of MOBIKE and Mobile IP, there 
> are 3 current
> > drafts in MIP4 that deal with this:
> >
> > - draft-ietf-mip4-vpn-problem-solution-02 (this one is pre-MOBIKE)
> > - draft-ietf-mip4-mobike-connectivity-00
> > - draft-meghana-mip4-mobike-optimizations-00
> >
> > So it's a stretch to say "don't do" MOBIKE and Mobile IP together.
> >
> > Yaron
> >
> > -----Original Message-----
> > From: Paul Hoffman [mailto:[email-masked]]
> > Sent: Wednesday, March 29, 2006 5:49
> > To: [email-masked]
> > Subject: [Mobike] Preliminary minutes from the WG last week
> >
> > Please let me know if you have any changes.
> >
> > MOBIKE WG minutes
> > IETF 65
> >
> > [deleted]
> >
> > James Kempf - discussion in Mobile IP group - what happens 
> if you try to
> > use Mobile IP and MOBIKE together? Some people believe the answer is
> > "don't do that". May need an informational draft (as a new 
> work item) to
> > address that.
> >
> > [deleted]
> >
> >
> > _______________________________________________
> > Mobike mailing list
> > [email-masked]
> > https://www.machshav.com/mailman/listinfo.cgi/mobike
> > 
> 
> 
> _______________________________________________
> Mobike mailing list
> [email-masked]
> https://www.machshav.com/mailman/listinfo.cgi/mobike
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: gabriel montenegro <[email-masked]>
Date: Mon, 3 Apr 2006 12:16:00 -0700 (PDT)

I'm confused. In the 3GPP2 solution (draft-ietf-mip4-mobike-connectivity-00)
MOBIKE is not used between MN-HA, right? The separation is:

between MN-HA: mipv4 tunnel
between MN and VPN gateway: mobike+IPsec

Are you folks saying that the above is wrong/discouraged?

Or are you saying that it is wrong/discouraged *only* if the MN-HA is a MIP6/IPsec
tunnel?

-gabriel

> > > "don't do that". May need an informational draft (as a new 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Tue, 04 Apr 2006 09:37:46 +0300

>the mobile node and the home agent.
Personally, I am not as convinced as you are that they should never
be used together to the same box. What if the client is
on a v4 network? Or on two separate connections, including
mixed v4/v6 and NATs. Popping up a level, it seems like
some combination of IKE/MOBIKE/NAT-T, Mobile IPv6, Mobile
IPv6 transition mechanisms, and MONAMI6 should be able
to cover the following situations and combinations of them:

- Having a separate SGW before you can reach your HA
- Integrated SGW/HA
- IPv4 access networks
- IPv6 access networks
- NATs and firewalls
- Multihomed mobile nodes
- Mobile nodes that you cannot fully trust (e.g. might need
  a RR before believing their new location)
- Mobile IPv6 service that requires EAP authentication

What exact combination of solutions we should use
is less clear to me. But I confess that I haven't read the
most recent documents on Mobile IPv6 transition
mechanisms.

Anyway, as Paul said maybe someone who cares needs
to write a document about this...

--Jari