Subject: [Mops] Updated proposed charter for a MOPS WG

From: "Leslie Daigle" <[email-masked]>
Date: Fri, 23 Aug 2019 11:22:07 -0400

Hi,

The two clear takeaways I had from the MOPS bof at IETF 105 were that 
there is interest in “this area of work” and that the proposed 
charter was not nearly crisp enough to agree on what the area of work 
was, or the specific things to be done.

As I said in the meeting, the challenge in trying to be crisp by 
narrowing the focus is that we actually need a rather broad 
“catchment” area, specifically pulling in things from several areas 
within the IETF and being open to input from other organizations.  To 
achieve some level of sanity, I’ve attempted to make things clearer by 
being more specific about the work to be done.  I’ve copied below an 
UPDATED proposed charter, that is aiming to be at least a little more 
concrete.

Action items:

1/ Please review the draft charter and provide feedback.  (Yes, it looks 
like the sort of thing you would like to see chartered; suggestions for 
greater crispness, etc).

2/ Of particular importance, we need more work items in the Milestones.  
I told the ADs that I didn’t want to just write a bunch of things and 
then try to badger people into working on them (though I will if I have 
to :^) ).  I’d rather have suggestions from interested parties about 
the things they are willing to work on in this area, or that they’d 
like to see done with a little help from others.

Okay — please comment.

Leslie.

—8<——8<——8<—

Media OPS WG

Internet- and Internet-protocol-delivered media is widespread, leading 
to significant technology development across industries not 
traditionally thought of as Internet technology developers or operators, 
as well as considerable quantities of traffic on local and transit 
networks. MOPS’ focus is on identifying areas where existing protocols 
and/or networks are inadequate to meet these updated requirements.

MOPS will solicit input on operational issues and practices, existing 
and proposed technologies related to the deployment, engineering, and 
operation of media streaming and manipulation protocols and procedures 
in the global Internet, inter-domain and single domain networking. In 
this case, media is considered to include the transport of video, audio, 
objects and any combination thereof, possibly non-sequentially. The 
scope is media and media protocols’ interactions with the network, but 
not the technologies of control protocols or media formats.

The premise of MOPS is that continued development of Internet-using 
technologies should be properly coordinated in order to ensure that the 
existing technologies are well-utilized, and new ones are developed in 
sympathy with the Internet’s core protocols and design. MOPS acts as a 
clearinghouse to identify appropriate venues for further protocol 
development, where necessary.

MOPS goals include documenting existing protocol and operational issues 
with media on the Internet, and identifying requirements for potential 
IETF work.

To those ends, MOPS will:

1/ Solicit regular updates from other media technology developing 
consortia/standards bodies working with IETF-developed protocols.

2/ Solicit input from network operators and users to identify 
operational issues with media delivery in and across networks, and 
determine solutions or workarounds to those issues.

3/ Solicit discussion and documentation of the issues and opportunities 
in media acquisition and delivery,  and of the resulting innovations 
developed outside the IETF

4/ Document operational requirements for media acquisition and delivery.

5/ Develop operational information to aid in operation of media 
technologies in the global Internet.

These activities should document media operational experience, including 
global Internet, inter-domain and within-domain operations.

Media operational and deployment issues with specific protocols or 
technologies (such as Applications, Transport Protocols, Routing 
Protocols, DNS or Sub-IP Protocols) are the primary responsibility of 
the groups or areas responsible for those protocols or technologies. 
However, the MOPS Working Group may provide input to those areas/groups, 
as needed, and cooperate with those areas/groups in reviewing solutions 
to MOPS operational and deployment problems.

Future work items within this scope will be adopted by the Working Group 
only if there is a substantial expression of interest from the community 
and if the work clearly does not fit elsewhere in the IETF.

There must be a continuous expression of interest for the Working Group 
to work on a particular work item. If there is no longer sufficient 
interest in the Working Group in a work item, the item may be removed 
from the list of Working Group items.

Milestones

July 2020  Taxonomy of Issues in Internet Media

<more concrete, committed work items needed>

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

---

From: [email-masked]
Date: Fri, 30 Aug 2019 14:09:51 +0000

Hi Leslie – The proposed charter looks good. I just have a comment RE need of clarity on the text “or networks are inadequate to meet these updated requirements”.

Otherwise, the charter seems consistent with the discussions during the BOF.

Thanks
Sanjay

From: Mops [mailto:[email-masked]] On Behalf Of Leslie Daigle
Sent: Friday, August 23, 2019 11:22 AM
To: [email-masked]
Subject: [E] [Mops] Updated proposed charter for a MOPS WG

Hi,

The two clear takeaways I had from the MOPS bof at IETF 105 were that there is interest in “this area of work” and that the proposed charter was not nearly crisp enough to agree on what the area of work was, or the specific things to be done.

As I said in the meeting, the challenge in trying to be crisp by narrowing the focus is that we actually need a rather broad “catchment” area, specifically pulling in things from several areas within the IETF and being open to input from other organizations. To achieve some level of sanity, I’ve attempted to make things clearer by being more specific about the work to be done. I’ve copied below an UPDATED proposed charter, that is aiming to be at least a little more concrete.

Action items:

1/ Please review the draft charter and provide feedback. (Yes, it looks like the sort of thing you would like to see chartered; suggestions for greater crispness, etc).

2/ Of particular importance, we need more work items in the Milestones. I told the ADs that I didn’t want to just write a bunch of things and then try to badger people into working on them (though I will if I have to :^) ). I’d rather have suggestions from interested parties about the things they are willing to work on in this area, or that they’d like to see done with a little help from others.

Okay — please comment.

Leslie.

—8<——8<——8<—

Media OPS WG

Internet- and Internet-protocol-delivered media is widespread, leading to significant technology development across industries not traditionally thought of as Internet technology developers or operators, as well as considerable quantities of traffic on local and transit networks. MOPS’ focus is on identifying areas where existing protocols and/or networks are inadequate to meet these updated requirements.

[I would like to add that the issue is more than to meet these “updated” requirements. In fact, I see MOPS to focus specifically on how protocols coming out of the IETF “factory” when used in “real-world” may have implications across the service delivery food chain. Some of the implications may be by design or not as expected. MOPS will help bring operational issue whether it relates to delivery of service using a protocol that is efficient (or inefficient), or, is the network on which protocol is running supporting the protocol “as-is” or is there a need for network operators adjust the network, or is there an issue for UA conforming to delivery using a particular protocol.].

Not necessarily suggesting above commentary as a substitute text as it is not meant to be, but, a little more specificity will be helpful. I know, you do go into that part of specificity in the next paragraph but some up front clarity is useful.

MOPS will solicit input on operational issues and practices, existing and proposed technologies related to the deployment, engineering, and operation of media streaming and manipulation protocols and procedures in the global Internet, inter-domain and single domain networking. In this case, media is considered to include the transport of video, audio, objects and any combination thereof, possibly non-sequentially. The scope is media and media protocols’ interactions with the network, but not the technologies of control protocols or media formats.

The premise of MOPS is that continued development of Internet-using technologies should be properly coordinated in order to ensure that the existing technologies are well-utilized, and new ones are developed in sympathy with the Internet’s core protocols and design. MOPS acts as a clearinghouse to identify appropriate venues for further protocol development, where necessary.

MOPS goals include documenting existing protocol and operational issues with media on the Internet, and identifying requirements for potential IETF work.

1/ Solicit regular updates from other media technology developing consortia/standards bodies working with IETF-developed protocols.

2/ Solicit input from network operators and users to identify operational issues with media delivery in and across networks, and determine solutions or workarounds to those issues.

3/ Solicit discussion and documentation of the issues and opportunities in media acquisition and delivery, and of the resulting innovations developed outside the IETF

5/ Develop operational information to aid in operation of media technologies in the global Internet.

These activities should document media operational experience, including global Internet, inter-domain and within-domain operations.

Media operational and deployment issues with specific protocols or technologies (such as Applications, Transport Protocols, Routing Protocols, DNS or Sub-IP Protocols) are the primary responsibility of the groups or areas responsible for those protocols or technologies. However, the MOPS Working Group may provide input to those areas/groups, as needed, and cooperate with those areas/groups in reviewing solutions to MOPS operational and deployment problems.

Future work items within this scope will be adopted by the Working Group only if there is a substantial expression of interest from the community and if the work clearly does not fit elsewhere in the IETF.

There must be a continuous expression of interest for the Working Group to work on a particular work item. If there is no longer sufficient interest in the Working Group in a work item, the item may be removed from the list of Working Group items.

Milestones

--

________________________________

Leslie Daigle

[email-masked]<mailto:[email-masked]>