Subject: Re: [MSEC] Comments on draft-ietf-msec-gkmarch-00.txt

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

Mark Baugher wrote:

> >2. From section 3.2:
> > > The Re-key message is optional because all keys, KEK and TEKs,
> > > can be delivered by the Registration Protocol exchanges shown in
> > > Figure 1.
> >
> >Two comments:
> >a. If there is no Re-key, then a KEK is not necessary.
> 
> We should remove "KEK" from the sentence you cite in 3.2.
> 
> >b. This should also state the obvious, which is the Re-key message is
> >optional because rekey may be necessary in some scenarios.
> 
> "optional because rekey may be necessary" does not make sense to me.

Sorry, I should have had a comma between "optional" and "because". My
point was really that rekey is optional, and if there is no rekey there
is no need for a KEK because you won't be sending any more keying data.

> >I suggest the following re-written sentence: "The Re-key message is
> >optional because the keys can be delivered by the Registration Protocol
> >exchanges shown in Figure 1, and those keys may not require updating."
> 
> Why not substitute "TEK" for "key" in your re-written sentence?

That would be fine too.

Thanks,
Brian

> Mark
> 
> >Brian
> >
> >--
> >Brian Weis
> >Strategic Cryptographic Development, ITD, Cisco Systems
> >Telephone: +1 408 526 4796
> >Email: [email-masked]
> >
> >_______________________________________________
> >msec mailing list
> >[email-masked]
> >http://www.pairlist.net/mailman/listinfo/msec

-- 
Brian Weis
Strategic Cryptographic Development, ITD, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian

---

From: Brian Weis <[email-masked]>
Date: Sat, 30 Jun 2001 11:32:38 -0700

That would be fine too.

Thanks,
Brian