Subject: [MSEC] Mikey CS ID map type question.

From: "Christian Beaulieu" <[email-masked]>
Date: Tue, 8 Mar 2005 09:39:28 -0500

We are asking ourselves a question here. In the RFC for MIKEY it states
that the CS ID map info is 16 bits long, then it goes to state that for
SRTP it is variable.

What we want to know is when parsing a message that would have a CS Is
map type different from SRTP, can we assume that the length of the CS ID
map info field will be 16 bits to continue parsing the rest of the
message or we should bail out immediately and return an error.

Thanks in advance.

Christian

_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: "Elisabetta Carrara (AL/EAB)" <[email-masked]>
Date: Tue, 8 Mar 2005 16:04:17 +0100

Christian, 
thanks for having spotted this. The field is variable size, 16 bits was a typo :o(
 
cheers
/Elisabetta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Christian Beaulieu
Sent: den 8 mars 2005 15:39
To: [email-masked]
Subject: [MSEC] Mikey CS ID map type question.

We are asking ourselves a question here. In the RFC for MIKEY it states that the CS ID map info is 16 bits long, then it goes to state that for SRTP it is variable.

What we want to know is when parsing a message that would have a CS Is map type different from SRTP, can we assume that the length of the CS ID map info field will be 16 bits to continue parsing the rest of the message or we should bail out immediately and return an error.

Thanks in advance.

Christian