Subject: [MSEC] SHA-1 analyses of MSEC protocols

From: Lakshminath Dondeti <[email-masked]>
Date: Sun, 05 Mar 2006 17:19:10 +0900

Hi all,

Soon after the Vancouver meeting, we have had a pretty active 
discussion (a combination of MSEC list discussions and some off-line 
ones) on Russ' action to all SEC area WGs to analyze hash function agility.

I was wondering if people can provide a summary of what they have 
done.  I guess I can collect some of these from various emails and 
draft updates, but if you are so kind to write a quick note to the 
list, it will save me some time :-).  I appreciate it very much.

thanks and regards,
Lakshminath

_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: "Euchner, Martin" <[email-masked]>
Date: Mon, 6 Mar 2006 18:53:56 +0100

Lakshminath,

Not too long ago, I provided some analysis of MIKEY-DHHMAC w.r.t. to SHA-1. The analysis was discussed on the MSEC mailing list and was agreed with slight editorial corrections. The analysis will be incorporated into the final published version of the yet to be published RFC.

The major findings are:
It is believed that MIKEY DHHMAC should be considered secure enough for the time being. Thus, there is no need to change the underlying security mechanism within the MIKEY DHHMAC protocol.

With kind regards

Martin Euchner.
---------------------------------------------------------------------
| Dipl.-Inf.                     
| Martin Euchner                 Phone: +49 89 722 55790
| Siemens AG.....................Fax  : +49 89 722 62366
| COM GCM PS 3                    mailto:[email-masked]
|                                mailto:[email-masked]
| Hofmannstr. 51                 Intranet: http://ietf.icn.siemens.de/sr3/Standardisation_Topics/security/
| D-81359 Muenchen               Internet: http://www.siemens.de/
| __________________
| Germany     
---------------------------------------------------------------------

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lakshminath Dondeti
Sent: Sonntag, 5. März 2006 09:19
To: [email-masked]
Cc: canetti; Russ Housley
Subject: [MSEC] SHA-1 analyses of MSEC protocols

Hi all,

thanks and regards,
Lakshminath