Subject: RE: [MSEC] Fwd: I-D ACTION:draft-ietf-msec-mikey-rsa-r-03.txt

From: "Fries, Steffen" <[email-masked]>
Date: Thu, 30 Mar 2006 08:48:28 +0200

Hi Lakshminath,

I just read through the changes. They are fine with me, the draft looks
pretty stable now.
The adpoption of SHOULD in section 3.2 for
" ...The Initiator SHOULD indicate the number of CSs supported, and
SHOULD fill in the CS ID map type and CS ID info	fields for the
RTP/RTCP streams it originates. "
is also fine. The resonning is clear now (I suggested MUST originally,
but it becomes clear now that a also the responder can chose the SSRC,
so SHOUL is okay).

Regards
	Steffen

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Lakshminath Dondeti
> Sent: Thursday, March 30, 2006 7:07 AM
> To: [email-masked]
> Subject: [MSEC] Fwd: I-D ACTION:draft-ietf-msec-mikey-rsa-r-03.txt 
> 
> Vesa and Steffen and others,
> 
> Dragan and I incorporated the changes you requested (please 
> do a diff; I find the tools at tools.ietf.org/wg/msec useful) 
> http://tools.ietf.org/wg/msec/draft-ietf-msec-mikey-rsa-r/draf
> t-ietf-msec-mikey-rsa-r-03-from-02.diff.html
> 
> Please let us know if the new version is satisfactory.
> 
> thanks and regards,
> Lakshminath
> 
> 
> >To: [email-masked]
> >From: [email-masked]
> >Date: Wed, 29 Mar 2006 18:50:02 -0500
> >X-Spam-Score: 0.3 (/)
> >X-Scan-Signature: 386e0819b1192672467565a524848168
> >Cc: [email-masked]
> >Subject: I-D ACTION:draft-ietf-msec-mikey-rsa-r-03.txt
> >X-BeenThere: [email-masked]
> >X-Mailman-Version: 2.1.5
> >Reply-To: [email-masked]
> >List-Id: i-d-announce.ietf.org
> >List-Unsubscribe: 
> <https://www1.ietf.org/mailman/listinfo/i-d-announce>,
> >         <mailto:[email-masked]?subject=unsubscribe>
> >List-Post: <mailto:[email-masked]>
> >List-Help: <mailto:[email-masked]?subject=help>
> >List-Subscribe: 
> <https://www1.ietf.org/mailman/listinfo/i-d-announce>,
> >         <mailto:[email-masked]?subject=subscribe>
> >X-PMX-Version: 4.7.0.111621
> >X-PMX-Version: 5.1.2.240295, Antispam-Engine: 2.3.0.1,
> >Antispam-Data: 2006.3.29.153608
> >X-OriginalArrivalTime: 29 Mar 2006 23:51:09.0900 (UTC) 
> >FILETIME=[A74C68C0:01C6538B]
> >
> >A New Internet-Draft is available from the on-line Internet-Drafts 
> >directories.
> >This draft is a work item of the Multicast Security Working 
> Group of the IETF.
> >
> >         Title           : An additional mode of key distribution in 
> > MIKEY: MIKEY-RSA-R
> >         Author(s)       : D. Ignjatic, et al.
> >         Filename        : draft-ietf-msec-mikey-rsa-r-03.txt
> >         Pages           : 17
> >         Date            : 2006-3-29
> >
> >The Multimedia Internet Keying (MIKEY) specification 
> describes several 
> >modes of key distribution solution that addresses multimedia 
> scenarios 
> >(e.g., SIP calls and RTSP sessions) -- using pre-shared keys, public 
> >keys, and optionally a Diffie-Hellman key exchange.  In the 
> public-key 
> >mode, the Initiator encrypts a random key with the 
> Responder's public 
> >key and sends it to the Responder.  In many communication scenarios, 
> >the Initiator may not know the Responder's public key, or in 
> some cases 
> >the Responder's ID (e.g., call
> >forwarding) in advance.  We propose a new MIKEY mode that 
> works well in 
> >such scenarios.  This mode also enhances the group key management 
> >support in MIKEY; it supports member-initiated group key 
> download (in 
> >contrast to group manager pushing the group keys to all members).
> >
> >A URL for this Internet-Draft is:
> >http://www.ietf.org/internet-drafts/draft-ietf-msec-mikey-rsa
> -r-03.txt
> >
> >To remove yourself from the I-D Announcement list, send a message to 
> >[email-masked] with the word unsubscribe in 
> the body of 
> >the message.
> >You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> >to change your subscription settings.
> >
> >
> >Internet-Drafts are also available by anonymous FTP. Login with the 
> >username "anonymous" and a password of your e-mail address. After 
> >logging in, type "cd internet-drafts" and then
> >         "get draft-ietf-msec-mikey-rsa-r-03.txt".
> >
> >A list of Internet-Drafts directories can be found in 
> >http://www.ietf.org/shadow.html or 
> >ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >
> >Internet-Drafts can also be obtained by e-mail.
> >
> >Send a message to:
> >         [email-masked].
> >In the body type:
> >         "FILE /internet-drafts/draft-ietf-msec-mikey-rsa-r-03.txt".
> >
> >NOTE:   The mail server at ietf.org can return the document in
> >         MIME-encoded form by using the "mpack" utility.  To use this
> >         feature, insert the command "ENCODING mime" before 
> the "FILE"
> >         command.  To decode the response(s), you will need 
> "munpack" or
> >         a MIME-compliant mail reader.  Different 
> MIME-compliant mail readers
> >         exhibit different behavior, especially when dealing with
> >         "multipart" MIME messages (i.e. documents which 
> have been split
> >         up into multiple messages), so check your local 
> documentation on
> >         how to manipulate these messages.
> >
> >
> >Below is the data which will enable a MIME compliant mail reader 
> >implementation to automatically retrieve the ASCII version of the 
> >Internet-Draft.
> >
> >Content-Type: text/plain
> >Content-ID: <[email-masked]>
> >
> >ENCODING mime
> >FILE /internet-drafts/draft-ietf-msec-mikey-rsa-r-03.txt
> >
> >
> ><ftp://ftp.ietf.org/internet-drafts/draft-ietf-msec-mikey-rsa
> -r-03.txt>
> >_______________________________________________
> >I-D-Announce mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/i-d-announce
> 
> _______________________________________________
> msec mailing list
> [email-masked]
> http://six.pairlist.net/mailman/listinfo/msec
> 
_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: Lakshminath Dondeti <[email-masked]>
Date: Thu, 30 Mar 2006 07:16:34 -0800

Steffen,

Yes, indeed we debated the suggestions and finally decided on what's 
right and provided explanation for the choice (e.g., the MUST vs. 
SHOULD below).  I am glad you interpreted the changes as intended :-).

Thanks for your considered review.

best regards,
Lakshminath

At 10:48 PM 3/29/2006, Fries, Steffen wrote:
> > ><ftp://ftp.ietf.org/internet-drafts/draft-ietf-msec-mikey-rsa> -r-03.txt>