Subject: RE: [MSEC] Fwd: I-D ACTION:draft-dondeti-msec-mikey-genext-oma-00.txt

From: "Frank Hartung \(AC/EDD\)" <[email-masked]>
Date: Fri, 5 May 2006 16:44:25 +0200

Dear Laksminath and all,

I read your draft with interest. As you know, I am working in the 
OMA BCAST group and appreciate that you propose this draft.

Some detail comments though:

- It is not clear to me what the ambition level of the draft is with
respect
  to specifying the parameters to be carried in the payload.
  I think you should either fully specify in the draft all the
parameters and
  the format how they are carried, or, alternatively, not talk at all
  about the parameters that shall be carried (and leave it to OMA to
  specify this). Right now it is a, as I find, bad compromise: it lists 
  the parameters but does not specify how they are formatted/encoded.
  It is not even specified how to distinguish STKM and LTKM information.

- If you decide to keep the list of STKM/LTKM paremeters in section 3
you
  should clearly refer to the OMA spec [2] in that section

- The name of the I-D and the new field seem to imply that this is a
generic
  BCAST extension payload, while it is in fact an STKM/LTKM payload.
This seems
  to be some mismatch that should be clarified. Do you want to keep this
open for
  other use than STKM/LTKM (then it should be said) or restrict to
STKM/LTKM (then 
  the title may be too broad and misleading) ?

- You talk about 
  - "OMA BCAST MIKEY General Extension Payload " (title)
  - "OMA General Extension payload" (section 2 and 3)
  - "MIKEY General Extension Payload " (section 3)
  - "OMA BCAST's MIKEY General extension payload" (section 5)
  this should be made uniform

- The references maybe should not be against specific versions of 3GPP
and OMA 
  specs as those are updated several times a year. Instead they should
refer to the 
  plain spec number without the revision info, unless there is a reason
to have 
  some specific version.

- Some abbreviations need to be explained (maybe twice, once in the
abstract and
  ocne in the body), like BDS and *TKM and MBMS 

- There is a typo 
  - "specification [1]defines " to "specification [1] defines "

If you would like some concrete proposals for changes corresponding to
these
comments please contact me.

Thanks for your consideration and best regards, Frank

===========================
Dr. Frank Hartung
Ericsson Research
52134 Herzogenrath, Germany
[email-masked]

> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of Lakshminath
> > > Dondeti
> > > Sent: Saturday, April 29, 2006 1:40 AM
> > > To: [email-masked]
> > > Subject: [MSEC] Fwd: I-D
> > > ACTION:draft-dondeti-msec-mikey-genext-oma-00.txt
> > >
> > > Strictly as an IETF contributor, I am requesting reviews on this
> > > document.  This is an IANA registration request of a new GenExt
> > > payload for MIKEY.
> > >
> > > regards,
> > > Lakshminath
> > >
> > >
> > > >To: [email-masked]
> > > >Cc:
> > > >From: [email-masked]
> > > >Date: Fri, 28 Apr 2006 15:50:01 -0400
> > > >X-Spam-Score: -2.6 (--)
> > > >X-Scan-Signature: 32b73d73e8047ed17386f9799119ce43
> > > >Subject: I-D ACTION:draft-dondeti-msec-mikey-genext-oma-00.txt
> > > >X-BeenThere: [email-masked]
> > > >X-Mailman-Version: 2.1.5
> > > >Reply-To: [email-masked]
> > > >List-Id: i-d-announce.ietf.org
> > > >List-Unsubscribe:
> > > <https://www1.ietf.org/mailman/listinfo/i-d-announce>,
> > > >         
> <mailto:[email-masked]?subject=unsubscribe>
> > > >List-Archive: <http://www1.ietf.org/pipermail/i-d-announce>
> > > >List-Post: <mailto:[email-masked]>
> > > >List-Help: <mailto:[email-masked]?subject=help>
> > > >List-Subscribe:
> > > <https://www1.ietf.org/mailman/listinfo/i-d-announce>,
> > > >         <mailto:[email-masked]?subject=subscribe>
> > > >X-PMX-Version: 4.7.0.111621
> > > >X-PMX-Version: 5.1.2.240295, Antispam-Engine: 2.3.0.1,
> > > >Antispam-Data: 2006.4.28.135109
> > > >X-OriginalArrivalTime: 28 Apr 2006 21:15:10.0229 (UTC)
> > > >FILETIME=[D4E47450:01C66B08]
> > > >
> > > >A New Internet-Draft is available from the on-line 
> Internet-Drafts
> > > >directories.
> > > >
> > > >
> > > >         Title           : OMA BCAST MIKEY General 
> Extension Payload
> > > > Specification
> > > >         Author(s)       : L. Dondeti, D. Castleford
> > > >         Filename        : 
> draft-dondeti-msec-mikey-genext-oma-00.txt
> > > >         Pages           : 7
> > > >         Date            : 2006-4-28
> > > >
> > > >    This document specifies a new general extension payload
> > > type for use
> > > >    in the Open Mobile Alliance's (OMA) Browser and Content (BAC)
> > > >    Broadcast (BCAST) group.  OMA BCAST's service and
> > > content protection
> > > >    specification uses short term key message (STKM) and
> > > long term key
> > > >    message (LTKM) payloads that in certain broadcast 
> distribution
> > > >    systems (BDS) are carried in the IETF MIKEY protocol 
> [1].  A new
> > > >    MIKEY general extension payload specified in this
> > > document will be
> > > >    used for that purpose.
> > > >
> > > >
> > > >
> > > >A URL for this Internet-Draft is:
> > > >http://www.ietf.org/internet-drafts/draft-dondeti-msec-mikey-
> > > genext-oma
> > > >-00.txt
> > > >
> > > >To remove yourself from the I-D Announcement list, send 
> a message to
> > > >[email-masked] with the word unsubscribe in
> > > the body of
> > > >the message.
> > > >You can also visit
> > > https://www1.ietf.org/mailman/listinfo/I-D-announce
> > > >to change your subscription settings.
> > > >
> > > >
> > > >Internet-Drafts are also available by anonymous FTP. 
> Login with the
> > > >username "anonymous" and a password of your e-mail address. After
> > > >logging in, type "cd internet-drafts" and then
> > > >         "get draft-dondeti-msec-mikey-genext-oma-00.txt".
> > > >
> > > >A list of Internet-Drafts directories can be found in
> > > >http://www.ietf.org/shadow.html or
> > > >ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > > >
> > > >
> > > >Internet-Drafts can also be obtained by e-mail.
> > > >
> > > >Send a message to:
> > > >         [email-masked].
> > > >In the body type:
> > > >         "FILE
> > > /internet-drafts/draft-dondeti-msec-mikey-genext-oma-00.txt".
> > > >
> > > >NOTE:   The mail server at ietf.org can return the document in
> > > >         MIME-encoded form by using the "mpack" utility. 
>  To use this
> > > >         feature, insert the command "ENCODING mime" before
> > > the "FILE"
> > > >         command.  To decode the response(s), you will need
> > > "munpack" or
> > > >         a MIME-compliant mail reader.  Different
> > > MIME-compliant mail readers
> > > >         exhibit different behavior, especially when dealing with
> > > >         "multipart" MIME messages (i.e. documents which
> > > have been split
> > > >         up into multiple messages), so check your local
> > > documentation on
> > > >         how to manipulate these messages.
> > > >
> > > >
> > > >Below is the data which will enable a MIME compliant mail reader
> > > >implementation to automatically retrieve the ASCII version of the
> > > >Internet-Draft.
> > > >
> > > >Content-Type: text/plain
> > > >Content-ID: <[email-masked]>
> > > >
> > > >ENCODING mime
> > > >FILE /internet-drafts/draft-dondeti-msec-mikey-genext-oma-00.txt
> > > >
> > > >
> > > 
> ><ftp://ftp.ietf.org/internet-drafts/draft-dondeti-msec-mikey-
> genext-oma
> > > >-00.txt> _______________________________________________
> > > >I-D-Announce mailing list
> > > >[email-masked]
> > > >https://www1.ietf.org/mailman/listinfo/i-d-announce
_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: Lakshminath Dondeti <[email-masked]>
Date: Fri, 05 May 2006 14:15:22 -0700

Hi Frank,

Thanks for your comments.  Please see inline:

>   should clearly refer to the OMA spec [2] in that section

The intention for the next revision is to remove the list of 
parameters and instead describe those parameters mainly for 
informative purposes.  The payload is for OMA uses and the listing is 
to indicate the type of information included in the payload, more 
importantly the type of protection required for the information 
therein.  We note that the GenExt payload is integrity protected and 
not encrypted.  So, for instance we cannot put keys in that payload :-).

I will add the reference to the OMA specification.

>   the title may be too broad and misleading) ?

I can name it as an OMA TKM payload, but would like to leave the TKM 
type management to OMA so new TKM types in future OMA BCAST versions 
can be added without a need to go to IANA.

>   this should be made uniform

Will do.

>   plain spec number without the revision info, unless there is a reason

Could you send me the correct reference?  Thanks.

>   ocne in the body), like BDS and *TKM and MBMS

Sure.

Thanks for your review Frank.

regards,
Lakshminath

> > ><ftp://ftp.ietf.org/internet-drafts/draft-dondeti-msec-mikey-> genext-oma