Subject: [MSEC] TESLA documents

From: Lakshminath Dondeti <[email-masked]>
Date: Wed, 12 Jul 2006 11:42:23 -0700

Folks,

It looks like we need to think through the TESLA document 
organization a bit more:

++++++++++++
Option 1:

RFC 4082 (with Errata)  --  TESLA introduction

RFC 4383                     --  TESLA-SRTP

Revive draft-ietf-msec-tesla-spec (Proposed Standard)   which is currently dead

Write a new draft draft-ietf-msec-mesp (old expired draft) -- this 
would be similar to 4383, but for IPsec.
++++++++++++++++

+++++++++++++
Option 2:

Revise RFC 4082     --  TESLA Specification

Keep RFC 4383 as is

Write draft-ietf-msec-ipsec-tesla
+++++++++++++++

I think Option 2 is most logical and has the fewest TESLA-related 
RFCs.  I would like to hear others' opinions.

thanks,
Lakshminath

_______________________________________________
MSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/msec

---

From: canetti <[email-masked]>
Date: Wed, 12 Jul 2006 14:55:13 -0400 (EDT)

I agree.

Need to add that 4082 is informational, while 4383 and the
to-be tesla-ipsec are standards track.
(actually, tesla-esp is a better name than tesla-ipsec.)

Ran

---

From: canetti <[email-masked]>
Date: Wed, 12 Jul 2006 14:55:13 -0400 (EDT)

I agree.

Ran

---

From: Brian Weis <[email-masked]>
Date: Thu, 13 Jul 2006 18:29:04 -0700

I have no objection to option 2, as long as there is consensus that RFC 
4082 is actually a definitive protocol definition.

Brian

Lakshminath Dondeti wrote:
> Folks,
> 
> It looks like we need to think through the TESLA document organization a 
> bit more:
> 
> ++++++++++++
> Option 1:
> 
> Write a new draft draft-ietf-msec-mesp (old expired draft) -- this would 
> be similar to 4383, but for IPsec.
> ++++++++++++++++
> 
> +++++++++++++
> Option 2:
> 
> I think Option 2 is most logical and has the fewest TESLA-related RFCs.  
> I would like to hear others' opinions.
> 
> thanks,
> Lakshminath
> 
> 

-- 
Brian Weis
Advanced Security Development, Security Technology Group, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]

---

From: Brian Weis <[email-masked]>
Date: Thu, 13 Jul 2006 18:29:04 -0700

Brian

---

From: Lakshminath Dondeti <[email-masked]>
Date: Sat, 15 Jul 2006 08:56:03 -0700

At 06:29 PM 7/13/2006, Brian Weis wrote:
>I have no objection to option 2, as long as there is consensus that 
>RFC 4082 is actually a definitive protocol definition.

Brian,

The proposal is to revise 4082 to make it a protocol specification.

regards,
Lakshminath

---

From: Lakshminath Dondeti <[email-masked]>
Date: Sat, 15 Jul 2006 08:56:03 -0700

Brian,

regards,
Lakshminath

---

From: Vincent Roca <[email-masked]>
Date: Tue, 18 Jul 2006 16:59:10 +0200

Hello Lakshminath and al,

> The proposal is to revise 4082 to make it a protocol specification.

In that case, do you plan to extend RFC 4082 significantly or will you 
keep it
more or less as it is today (with clarifications/corrections when 
needed)? In
particular, do you plan to specify with enough details the following
mechanisms:
- key chain switch (not mentioned at all);
- indirect time synchronization mechanism and upper delay bound calculation
  (only general guidelines are provided);

Will this specification also include the various possible packet formats 
or not
(in general it's typically the kind of information expected from a spec)?
I see we have some in the the oether ipsec-tesla I-D, but perhaps you'll
move them back to the specification I-D? What are your plans and
how generic do you want to keep the (revised RFC4082) specs?

Anyway, since several features will be shared with our TESLA for
ALC/NORM I-D, we definitively need to synchronize.

I also guess that it's too early to comment 
draft-dondeti-msec-ipsec-tesla-00
(since you explained it was only a very preliminary version)... Tell me 
if I'm
wrong.

Cheers,

   Vincent

---

From: Vincent Roca <[email-masked]>
Date: Tue, 18 Jul 2006 16:59:10 +0200

Cheers,

   Vincent