Subject: [MSEC] Re: draft-ietf-msec-mikey-ecc-01.txt

From: "Eugene Chin" <[email-masked]>
Date: Mon, 18 Dec 2006 17:27:26 -0500

I would very much prefer that you submit a new draft for adding ECGDSA to
MIKEY.  In the current working copy of the draft, I've addressed already the
comments from the last meeting.  That is, to allow for SHA-2 to be used
instead of just allowing SHA-1 only, and some minor editorial changes.  It
seems the path to WGLC is clear now, and do not want to add another
algorithm.

Can others please comment as well?

On 11/3/06, Fries, Steffen <[email-masked]> wrote:
>
>  HI Eugene,
>
> if you need further information on ECGDSA, just let me know.
>
> Ciao
>     Steffen
>
>  ------------------------------
> *From:* Eugene Chin [mailto:[email-masked]]
> *Sent:* Friday, November 03, 2006 1:21 PM
> *To:* Fries, Steffen
> *Cc:* [email-masked]
> *Subject:* Re: draft-ietf-msec-mikey-ecc-01.txt
>
> Hi Steffen,
>
>   In the comments I sent to the former version of the draft, there was
> > also ECGDSA included.
> >
>
> Oops, I appear to have missed this point from your previous comments.  To
> be honest, I am not familiar with ECGDSA, and will get back to you.
>
> Thanks,
> Eugene.
>
>
>
>
_______________________________________________
MSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/msec

---

From: "Eugene Chin" <[email-masked]>
Date: Mon, 18 Dec 2006 17:27:26 -0500

---

From: "Fries, Steffen" <[email-masked]>
Date: Tue, 19 Dec 2006 08:52:29 +0100

Hi,
 
the proposal to include ECGDSA to the ECC draft has been discussed for
the 00 version (I submitted text for the draft update in 07/2005) as
well as during the last IETF meeting (see also the minutes from
Lakshminath), so it is not the attempt to add another algorithm during
WGLC.
 
Just as a short summary of ECGDSA. It  provides some advantages compared
to ECDSA especially when implementation on embedded devices is targeted.
As implementations are moving more and more to embedded devices, this
solution may be interesting. Here just short a couple of comments to
draw a picture about ECGDSA advantages:
- The difference to ECDSA is that there is no need to calculate the
inverse of the 
   ephemeral key k within the signature routine. This will provide
performance advantages 
   on platforms were the calculation of the inverse can not be done
efficently.
- The ephemeral key k will be chosen randomly for every signature
operation. This k must 
   not become known (not even in parts as if k and a valid signature is
know, the private 
   key may be calculated). Therefore, calculating the inverse of k in
ECDSA should be 
   protected against side channel attacks. This is not necessary in
ECGDSA.
- The calculation of the inverse of k is saved compared to ECDSA through
the calculation 
   of the inverse of the private key during  signature generation. This
means that ECDSA 
   and ECGDSA are not compatible but the change from ECDSA to ECGDSA can
be done 
   quickly.
- Best of all, it has no IPRs associated with it.
 
As the ECC draft describes the extension of MIKEY with ECC algorithms, I
would propose to include ECGDSA also into the ECC draft instead of
submitting a seperate document. Again, the offer, if you need text for
the draft or more information on ECGDSA, I will be happy to provide it.
 
Regards
    Steffen

________________________________

	From: Eugene Chin [mailto:[email-masked]] 
	Sent: Monday, December 18, 2006 11:27 PM
	To: Fries, Steffen
	Cc: [email-masked]
	Subject: Re: draft-ietf-msec-mikey-ecc-01.txt

	I would very much prefer that you submit a new draft for adding
ECGDSA to MIKEY.  In the current working copy of the draft, I've
addressed already the comments from the last meeting.  That is, to allow
for SHA-2 to be used instead of just allowing SHA-1 only, and some minor
editorial changes.  It seems the path to WGLC is clear now, and do not
want to add another algorithm. 

	

		HI Eugene,
		 
		if you need further information on ECGDSA, just let me
know.
		 
		Ciao
		    Steffen

________________________________

			From: Eugene Chin [mailto:[email-masked]]

			Sent: Friday, November 03, 2006 1:21 PM
			To: Fries, Steffen
			Cc: [email-masked]
			Subject: Re: draft-ietf-msec-mikey-ecc-01.txt

			Hi Steffen,

				In the comments I sent to the former
version of the draft, there was also ECGDSA included.

			Oops, I appear to have missed this point from
your previous comments.  To be honest, I am not familiar with ECGDSA,
and will get back to you. 
			
			Thanks,
			Eugene.

---

From: "Fries, Steffen" <[email-masked]>
Date: Tue, 19 Dec 2006 08:52:29 +0100

Hi,

 
 
Regards
    Steffen

	

		HI Eugene,

		Ciao
		    Steffen

			
			Hi Steffen,

			
			Thanks,
			Eugene.