Subject: [Mud] DHCP lease expiry

From: "M. Ranganathan" <[email-masked]>
Date: Sat, 8 Jun 2019 20:41:41 -0400

What (if anything) should the mud server do with the device to MUD URL
association when the DHCP lease expires?

TIA for clarifications,

Ranga

-- 
M. Ranganathan

---

From: Michael Richardson <[email-masked]>
Date: Sat, 08 Jun 2019 21:06:44 -0400

> association when the DHCP lease expires?

Depends upon how things are index and firewalled.

We are building firewalls based upon L2 (ethernet) addresses.
So we keep them and we don't care about the L3 address.
A malicious device can always lie easily about L3 addresses.
And IPv6 privacy extensions are basically continuous "lies"

L2 addresses are also easily changed, but doing so can invalidate the WIFI
connection, so it seems less likely thing to do.

So, I'd keep it. The device might be coming back.
Perodically, maybe old devices (or old firewall entries) need to be purged.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [