Subject: If IPv6 multihomed sites were cars

From: Michel Py <[email-masked]>
Date: Sun, 9 Sep 2001 12:58:30 -0700 (PDT)

As the author of the original post (was: A new spin on
multihoming: multihoming classes), and given what I
have read here recently, I thought I neeeded to post
this:

If IPv6 multihomed sites were cars:

Some people have posted drafts describing a a 3-ton
truck. They have been told "this design is not good,
we need a sports car". Some people have posted drafts
describing a sports car. They have been told "this
design is not good, we need a truck". Some poeple have
said "It is pointless designing a Mercedes, I can't
afford it". Some other people have said "Don't buy a
Yugo, it's a piece of junk".

A few facts of life: A small truck and a sports car
cost about the same, $50,000. They both have an
engine, 4 wheels and a steering wheel. They are very
different though, because they are not used for the
same thing. A $2,000 Yugo is inexpensive, but a
$200,000 Mercedes is a lot nicer and more reliable. On
the same road, you can see trucks, sports cars,
Mercedes', and Yugos.

This specialization applies to almost technology item.
Let's look at airplanes:
A Boeing 737 and an F-15 Eagle cost about the same
($35M). They both have wings, 2 jet engines and a
retractable landing gear. They are very different
though, because they are not used for the same thing.
A $100,000 Cessna is inexpensive, but a $10M Learjet
is a lot nicer and faster. In the same airspace, you
can spot jetliners, combat aircraft, single prop
airplanes, and personal jets.

Computers:
A nice color PDA and a standard desktop PC cost about
the same, $600. They both have a screen, an operating
system, and a USB interface. They are very different
though, because they are not used for the same thing.
A $400 stripped-down Celeron with IDE, 64 megs and Win
Me is inexpensive, but a $5,000, dual P4, 15KRPM SCSI
drives raid array, 21" screen is a lot nicer and it
makes a hell of a game machine, too. On the Internet,
you can find any kind of computer there is.

More facts of life:

- Some people don't have a car. Some drive a truck.
Some drive a sports car, some drive a Mercedes.
- Some people have never flown in an airplaine. In the
same jetliner, you find the pilot, who gets paid to
fly, and the guy in first that paid twice as much as
the one in coach for a few more inches of leg space.
- Some don't have a computer, some have a basic one,
and some have a big honkin' setup.
- Some people won't have a multihomed IPv6 setup, some
people will have a $49.95/mo multihomed IPv6 setup,
and some people will have a $50K/mo setup. I don't
think the $49.95/mo will be as nice as the $50k/mo.

- The car that can carry 3 tons of cargo, accelerates
like a Ferrari, is luxurious like a Mercedes, gives
you 40 miles/gallon, can fit in a standard garage and
costs $5,000 does not exist.
- The airplane that can carry 400 passengers for
10,000 miles at mach 2.3, can land on 1,500 ft of
runway and costs $100,000 does not exist.
- The computer that has 1 gig of ram, 1 terabyte of
hot-swap raid storage, quad 2ghz processors, fits in a
shirt pocket and cost $500 does not exist.
- The IPv6 multihoming solution that can host
amazon.com, work over a 64k dialback ISDN, does not
care about BGP nor the DFZ, can be configured by
grandma and costs $49.95 a month does not exist.

Michel.

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

---

From: Michael Richardson <[email-masked]>
Date: Mon, 10 Sep 2001 15:17:54 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Michel" == Michel Py <[email-masked]> writes:
    Michel> A few facts of life: A small truck and a sports car
    Michel> cost about the same, $50,000. They both have an
    Michel> engine, 4 wheels and a steering wheel. They are very
    Michel> different though, because they are not used for the
    Michel> same thing. A $2,000 Yugo is inexpensive, but a
    Michel> $200,000 Mercedes is a lot nicer and more reliable. On
    Michel> the same road, you can see trucks, sports cars,
    Michel> Mercedes', and Yugos.

    Michel> This specialization applies to almost technology item.

  I guess I fail to see what your point is.

  You seem to be saying that different people will get different
results using the same mechanisms.  If this is your point, then we agree.
But, you have argued for different mechanisms before.

  In each category you describe several variations on the same theme which
result in differing qualities in the return on investment. 

  But, in each category there are some essential principles which are
the same. airplanes have wings and means of propulsion, cars and trucks have
wheels, brakes, steering and propulsion, and PDAs and Celerons have I/O, CPU
and storage.

  You are suggesting that part of the population should use PDAs to drive
on roads and the other part should use F-15s. Yet that was your proposal
before about having different mechanisms for different classes of
multihoming.

]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another NetBSD/notebook using, kernel hacking, security guy");  [

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 11 Sep 2001 11:21:26 +0200 (CEST)

>     Michel> On the same road, you can see trucks, sports cars,

> wheels, brakes, steering and propulsion, and PDAs and Celerons have I/O, CPU

I think what we're doing here compares to building roads in the car
analogy. Unfortunately, the differences in IP are somewhat bigger than an
order of magnitude in size or the quality of the seats. The slowest
devices on the network are five orders of magnitude slower than the
fastest. If we compare DS3 to the Mercedes and an ADSL user to a
pedestrian, there are also snails (cell phone modem) and vehicles going
mach 4 (Gigabit Ethernet) on the road.

I feel we shouldn't spend too much time figuring out the perfect
multihoming solution for a certain group of users, when each form of
multihoming we've discussed so far has serious drawbacks and none of them
is likely to be perfect anyway. And users have the annoying habit to use
the technology in the way it best suits them, rather than in the way the
designers intended.

That being said, there are already multihoming solutions on the table that
cater to the needs of four groups.

ISPs can still do what they do now by getting a TLA address block and
using BGP.

Enterprises and smaller ISPs can take an address block from an upstream
ISP and announce it to several ISPs over BGP. Since these announcements
will very likely be filtered in the DFZ, there is no guaranteed
network-wide redundancy, but when done carefully this could still work
very well.

Small to medium sized organizations or departments of larger organizations
can use proxy address rewriting boxes to do multi-address multihoming
processing for a large number of hosts and/or servers, if we create a
protocol that allows this.

Individual hosts can do their own MAMH processing, similar to mobile IP or
SCTP.

So there is really no problem, as long as we can make something good for
multi-address multihoming and this is implemented widely enough to be
useful.

---

From: Michel Py <[email-masked]>
Date: Tue, 11 Sep 2001 20:44:46 -0700 (PDT)

Iljitsch -

--- Iljitsch van Beijnum <[email-masked]> wrote:
>> Unfortunately, the differences in IP are
>> somewhat bigger than an order of magnitude in
>> size or the quality of the seats. The slowest
>> devices on the network are five orders of magnitude
>> slower than the fastest. If we compare DS3 to the
>> Mercedes and an ADSL user to a pedestrian, there
>> are also snails (cell phone modem) and vehicles
>> going mach 4 (Gigabit Ethernet) on the road.

Good point.

> ISPs can still do what they do now by getting a TLA

There is some danger here. As of today, there can be
only 8K TLAs and there are more ASNs allocated
already. I fear a rush to get a TLA "just in case"
by people that don't really need one. To be honest,
it has crossed my mind. With several thousand modems
and multiple DS3s OC48s I would probably qualify for
it. With such scarce numbers, it might even be a
sound business decision. If I could get an IPv4
class A today for a few thousand dollars, I certainly
would. Just in case.

>> So there is really no problem, as long as we can
>> make something good for multi-address multihoming
>> and this is implemented widely enough to be useful.

There needs to be some mutual awareness between all
the different solutions. As of today, there are still
people that say that we should design a mach 4 Yugo...

Michel