Subject: Re: A new spin on multihoming: multihoming classes.

From: "J. Noel Chiappa" <[email-masked]>
Date: Thu, 6 Sep 2001 16:45:52 -0400

> From: RJ Atkinson <[email-masked]>

    >> my impression is that large (and small) providers would like fairly
    >> stable routing which converges predictably in reasonable time.  if that
    >> can be done with ten, 100k, or 5,000,000 routes is not so important.

As has been discussed considerably, the likelihood of getting the predicate
("converges predictably in reasonable time") gets smaller as the number gets
larger.

    > Some few folk think that somewhere between 100K and 300K prefixes it
    > isn't stable .. when using current BGP and current BGP algorithms.
    > ... I haven't seen any equations yet myself.

I doubt you will; the problem is too complex to analyze in closed form (it
will vary depending on the exact topology), and it's much easier to either
simply gather empirical data, or (for the really ambitious) do simulations.

	Noel

---

From: Michel Py <[email-masked]>
Date: Thu, 6 Sep 2001 20:26:24 -0700 (PDT)

Tony -

Tony Hain wrote:
> Actually for the most part they are the same people
> that insisted that the only IPv6 addressing/routing
> mechanism be a clone of IPv4/CIDR.

Yep.

> The other point is that many of them simply don't
> want to implement IPv6,

Right again.

> and the lack of a solution to the multi-homing
problem
> is a sufficient justification for now.

Until there is customer demand or senior management
reads something about it in a fashion magazine and
decide they need it yesterday.

> Once that problem is solved 
> I am sure there will be another reason.

No doubt about that either.

> The point I was trying to make initially is that
> the reasons sites multi-home has absolutely 
> nothing to do with their size, or the size of the
> pipe they connect with. It is simply a function of
> their desire to be independent of the provider. 
> This could be for the ability to change providers,
> or simply to be immune to problems any one may have.
 
Today, provider independence exits in IPv4. Its name
is NAT.
Even for small setups, and even if (in the US) they
can get
a PA block, most choose to get only a handful of
public
IPv4 addresses and use RFC1918 private addresses for
all
their hosts. Switching ISPs? simple, just change the
outside
address of the router and a few DNS entries.
Lots of people have a PI block these days:
192.168.0.0/16.

I did not want to open that can of worms before, but
there are
good possibilities that the provider independance you
mention
will be provided for IPv6 in a very similar way it is
provided
in IPv4: NAT to a link-local or a site-local address,
with the
nice addition that IPv6 would provide a 1host-to-1host
NAT
translation making it a lot easier on peer to peer
applications.
(as related to multihoming, a 1-to-many NAT). By
hosting
the DNS server on the inside and NATting DNS replies
(this already
works for IPv4), this could provide a reasonably
redundant setup.
Given, load balancing would be problematic if not
impossible and
open sessions would die on link failure but for a
home/soho setup
it's probably a reasonable annoyance. Don't like the
idea? me
neither, but it has had most of its growing pains
already, and you
can't beat the price.

Michel.

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com