Subject: Re: Multihoming draft available

From: "Michel Py" <[email-masked]>
Date: Mon, 3 Sep 2001 19:32:40 -0700

Ramki,
 
How does NLMP address the following scenario?
 
Entreprise ACME is multihomed.
Acme's web server has either two NICs or two IPv6 addresses
bound to the same interface.
www.acme.com <http://www.acme.com>  has two AAAA records:
1234:5678::1 from ISP "A"
2345:6789::1 from ISP "B"
 
Joe's address is 2345:CAFE::1234.
Joe wants to access Acme's web site. Joe types www.acme.com
<http://www.acme.com> .
Joe's DNS server returns both AAAA record and Joe's PC picks
1234:5678::1 as the IPv6 address for www.acme.com <http://www.acme.com>
.
Joe sends traffic to that IP address.
 
Unless ISP "A" and "B" have a peering agreement (unlikely to
happen; it would require each ISP to peer with every other ISP)
Joe's traffic is going to hit the interconnect between A and B
(if there is one) and then be carried by ISP "B".
Since both Joe and Acme are connected to ISP "A", this is not good.
 
I might have missed it, but I have not seen yet any DNS that would
be smart enough to analyse the routing table and alter the
order/preference of AAAA records.
 
Thanks,
Michel.

---

From: Ramakrishna Gummadi <[email-masked]>
Date: Mon, 3 Sep 2001 20:08:57 -0700 (PDT)

Hi Michel,
This is the "performance" problem, and, like the draft says, all of a
site's prefixes would be known to all of its direct ISPs (but not leaked
outside any of the direct ISPs) to avoid this problem. Alternatively, DNS,
etc., that returned the answer could be more intelligent (look at the
source address and return a suitable destination address), but this is
optional.