Subject: RE: PI/metro/geo [Re: The state of IPv6 multihoming development]

From: "Michel Py" <[email-masked]>
Date: Fri, 1 Nov 2002 14:40:54 -0800

Tony,

> Tony Hain wrote:
> You raise a point here that I think gets lost in the
> mapping proposals. 'As far as your own hosts, the DNS
> and remote hosts are concerned, hosts in your network
> have a single address.' If the upper 48 bits are constant
> in DNS, but continually changing in the routing system,
> there needs to be a way to pass the possible set of
> topologically appropriate replacement values between the
> CPE routers. Since this protocol would inherently have to
> be run between organizations that have no trust
> relationship, how that be deployable? If it were run
> between the PE routers, trust is managable to a point,
> but what would prevent something like the POTS practice
> of slamming?

I'm not sure I understand your question correctly. Slamming as I
understand it is make the customer switch to another (yours!) long
distance company in order to get the money.

We are talking about multihomed sites here, so a provider that wants to
slam would either:

a) Try to reduce the traffic on their customer's link by providing
routes that have crappy metrics (if the customers pays a flat fee).

b) Try to increase the traffic on their customer's link by providing
routes that have very good metrics, which will eventually push the
customer towards a bigger, more expensive pipe.

Both of these are practiced today with IPv4. I'm not saying it's a good
practice, and one better have a good explanation if caught, but it does
happen. Are we looking at a solution that *also* solves this problem?

Michel.

---

From: "Tony Hain" <[email-masked]>
Date: Fri, 1 Nov 2002 16:10:06 -0800

Michel Py wrote:
> ...
> I'm not sure I understand your question correctly. Slamming 
> as I understand it is make the customer switch to another 
> (yours!) long distance company in order to get the money.
> 
> We are talking about multihomed sites here, so a provider 
> that wants to slam would either:
> 
> a) Try to reduce the traffic on their customer's link by 
> providing routes that have crappy metrics (if the customers 
> pays a flat fee).
> 
> b) Try to increase the traffic on their customer's link by 
> providing routes that have very good metrics, which will 
> eventually push the customer towards a bigger, more expensive pipe.
> 
> Both of these are practiced today with IPv4. I'm not saying 
> it's a good practice, and one better have a good explanation 
> if caught, but it does happen. Are we looking at a solution 
> that *also* solves this problem?

I don't expect to solve it, but if we are talking about a system to
distribute mapping tables to align with current topology at the ingress
and restore the original values at the egress, we should make sure the
process does not make it easy to quietly influence which provider
carries the traffic. The obvious method to prevent this would be for the
site being mapped to sign its preferences, but that brings along its own
operational and scaling issues. 

Tony