Subject: RE: SIP again

From: "Christian Huitema" <[email-masked]>
Date: Fri, 8 Nov 2002 17:07:18 -0800

> > The IPv6 architecture is pretty clear about that one: the only
packets
> > that a router is expected to process are those in which the first
> > payload is a "per hop option", or those in which the destination
address
> > is one of the router's own addresses. All other payloads are
supposedly
> > end-to-end.
> 
> That is a correct argument, but is not enough.
> 
> The proper conclusion is that none of the IPv6 options are useful.
> 
> Per hop options are, undoubtedly, evil.
> 
> Others are end-to-end specific to each form of communication,
> which means they belong to not IP but transport layer.

Loose source routing belongs to the transport layer?

-- Christian Huitema

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 9 Nov 2002 14:44:43 +0859 ()

Christian;

> Loose source routing belongs to the transport layer?

I'm not sure whether loose source routing is ever necessary
for some application.

But, if it is, it belongs to the transport layer under the
application.

						Masataka Ohta