Subject: RE: Notes about identifier - locator separator

From: "Christian Huitema" <[email-masked]>
Date: Fri, 8 Nov 2002 11:32:57 -0800

> The presence of IPv4 options in a packet header cause the IPv4
> packet to be kicked out of the silicon-path of many of today's
> high speed routers. Given that history, I could easily forsee
> a silicon-forwarder for IPv6 that kicks packets to the slow
> path if the next-header field is _not_ one of several known
> values (on the theory that if the next header is not X, Y, or Z
> then there _might_ be something in there that the router needs
> to look at...). This has undesired effects on throughput.

The IPv6 architecture is pretty clear about that one: the only packets
that a router is expected to process are those in which the first
payload is a "per hop option", or those in which the destination address
is one of the router's own addresses. All other payloads are supposedly
end-to-end.

-- Christian Huitema

---

From: Eliot Lear <[email-masked]>
Date: Fri, 08 Nov 2002 11:55:07 -0800

> is one of the router's own addresses. All other payloads are supposedly

Well there's architecture and reality.  Reality says that devices are 
going to look well inside the header for port information, firewall 
processing, and packet classification, to name a few.

Eliot

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 8 Nov 2002 23:27:07 +0100 (CET)

> is one of the router's own addresses. All other payloads are supposedly

And there is an explicit "router alert" option to signal to routers they
should inspect the packet more closely.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 8 Nov 2002 23:31:09 +0100 (CET)

> processing, and packet classification, to name a few.

The flow label is supposed to help with this. Also, it should be
possible to do IP layer-only filtering on the real big boxes. And the
option would only be in a relatively small number of packets.

But it never hurts to implement all of this in the fast path, of course.  :-)

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 9 Nov 2002 09:58:56 +0859 ()

Christian;

> is one of the router's own addresses. All other payloads are supposedly

That is a correct argument, but is not enough.

The proper conclusion is that none of the IPv6 options are useful.

Per hop options are, undoubtedly, evil.

Others are end-to-end specific to each form of communication,
which means they belong to not IP but transport layer.

							Masataka Ohta

---

From: RJ Atkinson <[email-masked]>
Date: Fri, 8 Nov 2002 20:42:26 -0500

On Friday, Nov 8, 2002, at 17:31 America/Montreal, someone wrote:
> The flow label is supposed to help with this.

I don't know of any real implementation of IPv6 that even
*looks* at the Flow Label when trying to forward a packet.
Colour me very sceptical of the many claims made that
the Flow Label is useful to IPv6 routers.[1]

Ran
[email-masked]

[1] I've only worked on 4 IPv6 implementations so far,
including the one most widely deployed as a router;
this scepticism is probably due to lack of implementation
experience on my part.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sat, 9 Nov 2002 17:57:50 +0100 (CET)

> the Flow Label is useful to IPv6 routers.[1]

I don't think this wg is limited to solutions that work only with
existing implementations.  :-)

The Indian said it in "Wayne's World 2": "Book them and they'll come."
If we make a standard that solves real-world problems, the vendors will
implement them.