Subject: Location

From: "Bound, Jim" <[email-masked]>
Date: Mon, 17 Mar 2003 00:57:15 -0500

Location:
 
Do we believe that providers should know location of all nodes on the
Internet without peering?
 
Do we believe that providers should know location of all nodes within a
specific topology, without peering?
 
Do we believe that providers should know location of all nodes within a
specific topology within specific rendezvous points within the
aforementioned specific topology, without peering?
 
Do we believe that providers should only know peerings for providers
that exist near specific locations?
 
I did not use the word geographic or other boundary descriptive
associations for topology for that attribute for now.  We could do that
later I suggest.
 
/jim

---

From: Michael Richardson <[email-masked]>
Date: Mon, 17 Mar 2003 15:39:23 -0800

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Bound," == Bound, Jim <[email-masked]> writes:
    Bound> Location:
 
    Bound> Do we believe that providers should know location of all nodes on
    Bound> the Internet without peering?

  It took me a bit to understand the question. 

  I think that providers should be able to tell:
    1) if a node is reachable by peering or by another method.
    2) if another method, then they should be able to identify the method
       from the address.

  So, my answer is possibly no.
  I don't see how we can scale without losing information.

]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [

---

From: Randy Bush <[email-masked]>
Date: Mon, 17 Mar 2003 16:09:22 -0800

>   I don't see how we can scale without losing information.

s/losing/(scoping|hiding)/

---

From: Michael Richardson <[email-masked]>
Date: Tue, 18 Mar 2003 09:28:06 -0800

>>>>> "Randy" == Randy Bush <[email-masked]> writes:

    Randy> s/losing/(scoping|hiding)/
 
  Yes, I agree. Hiding is the right thought.