Subject: RE: Reducing Peerings for MH Routing within a site via end systems

From: "Tony Li" <[email-masked]>
Date: Mon, 17 Mar 2003 20:19:52 -0800

Jim,

|    >If a host has multiple locators and a single identifier 
|    and other hosts
|    are able >to change the locator that they are using at 
|    will, then it
|    implies that special
|    
|    Clarification.  Above you have "conjunction" ...and other hosts?  I
|    assume you mean any host can change their locator?

I think that a host should be able to change the set of locators
that make it reachable at will.  The rate that the system can
disseminate these changes is still TBD, but there obviously
needs to be an upper bound (no pun intended ;-).

Correspondent hosts are free to try different locators at any
time.  Typically they will use transport layer hints to
trigger things.

|    >Effectively, the site has PA space from each of its 
|    providers and that
|    PA space >is nicely aggregated in global routing.
|    
|    So the locators for this site is known by all of the sites 
|    providers,
|    correct?

Yes.  Even more strongly, the locators are allocated by the
providers.

|    IPsec between those two peers without any translation of 
|    the packets
|    headers.  

Ipsec, in particular, needs to use the identifier in crafting
the security association, NOT the locators.  [This would also
allow Ipsec to work through NAT.  ;-) ]

|    Do we agree on that and this is a core principle for any Internet
|    engineer one way or the other?  

Please restate with dereferenced pronouns.

|    >One could reasonably argue that you take the layer of 
|    separation down 
|    >recursively.
|    
|    Within the IGP from the Provider space?  If that, then I agree.

Within the site IGP, but using the locators provided in PA space.

|    >Note that this alleviates the most painful reason to 
|    avoid PA space:
|    
|    But above you state "nicely aggregates provider space"?  Can you
|    rectify?

These aren't incompatible.  Your locators are aggregateable and you
don't need to renumber.  Should make everyone happy...  ;-)

|    >renumbering is now a non-issue.  You assign a new locator to your
|    entire site, 
|    >advertise it to the world and you're good to go.  Individual host
|    identifiers 
|    >need not change.  No host renumbering.
|    
|    But still implies locators can change?  For example one move to
|    completely new providers?

Of course.  You add new provider, configure edge router with new
locator prefix, update the locator database and you're done.

|    Your location is not worldwide provider space but only for relative
|    provider space for a site?
|    Is that correct?

Locators are part of what we would now think of as PA space.  That is,
they are topologically significant information that vary per-provider.

Tony

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 18 Mar 2003 14:15:09 +0859 ()

Tony;

> needs to be an upper bound (no pun intended ;-).

You don't have to determine it. Cache period of DNS, for example, is
configurable.

> locator prefix, update the locator database and you're done.

IPv6 WG is seriously considering to automate prefix configuration of
routers. But, it seems to me that the automatic update of the database
is impossible, if, as is often the case, the prefix of servers of the
database is being configured. :-)

							Masataka Ohta