Subject: RE: Again no multi6 at IETF#56

From: "Michel Py" <[email-masked]>
Date: Tue, 11 Mar 2003 07:47:43 -0800

ipv6mh does meet in SFO on Sunday March 16 and probably some ad-hoc
meetings during the week as well such as the one Jordi called in
Atlanta. Details on the meeting location will be posted on the ipv6mh
mailing list. Non-members are welcomed too.

                       _   ____  __      __  ____   _    _   _    _
                      | | |  _ \ \ \    / / / ___| | \  / | | |  | |
Michel Py             | | | |_| | \ \  / / | |__   |  \/  | | |__| |
Sr. Network Engineer  | | |  __/   \ \/ /  |  _ \  | \  / | |  __  |
CCIE #6673            | | | |       \  /   | |_| | | |\/| | | |  | |
[email-masked]          |_| |_|        \/     \___/  |_|  |_| |_|  |_|
                                IPv6 Multihoming Solutions
                        http://arneill-py.sacramento.ca.us/ipv6mh
                     http://arneill-py.sacramento.ca.us/public/ipv6mh/

---

From: "Bound, Jim" <[email-masked]>
Date: Tue, 11 Mar 2003 18:09:53 -0500

See the URLs.
Thank You,
/jim

> -----Original Message-----
> From: Masataka Ohta [mailto:[email-masked]] 
> Sent: Tuesday, March 11, 2003 5:54 PM
> To: Bound, Jim
> Cc: Michel Py; Randy Bush; RJ Atkinson; [email-masked]
> Subject: Re: Again no multi6 at IETF#56
> 
> 
> Jim;
> 
> > They are already being assigned and used folks.  Now not 
> just by Asia 
> > and European ISPs, but U.S. ISPs and IXs too.  It has begun!!
> 
> I'm afraid you have been saying "It has begu!!" for these 
> eight years that we should assume that it won't begin for 
> next eight years.
> 
> Thank you.
> 
> > Taking what IPv6 is today and working it is the
> > only course I think for time-to-market of this spec in or out of the
> 
> Taking what IPv6 has been for these eight years and?
> 
> 							Masataka Ohta
>

---

From: "Michel Py" <[email-masked]>
Date: Wed, 12 Mar 2003 07:49:22 -0800

> Tim Chown wrote:
> Given the 6+ hours of ipv6mh sessions in Atlanta, I see
> no problem filling a 1 hour (or more) slot with multi6
> discussion. There have been at least 1,000 posts to ipv6mh
> (and multi6) since Atlanta.   So I would not be worried
> at all about running out of steam inside an hour :)
> Of course a productive meeting is another matter. That
> means we have to approve or ditch the requirements draft,
> approve a new charter, and get real progress moving...

Exactly, but what makes you think that there has been changes WRT to
this?

Michel.

---

From: "Tony Li" <[email-masked]>
Date: Fri, 14 Mar 2003 12:08:16 -0800

Gentlefolk,

I think we're missing the big picture here.  Handing out addresses
before you understand how addresses will be used is not a good idea.
We did this in IPv4 and it resulted in the swamp.  

To not make this mistake again, we need to have a firm routing
architecture for v6 in hand that includes support for multi-homing
as a first level, non-scalability-impacting element.

We are not there yet.

Tony

---

From: "Michel Py" <[email-masked]>
Date: Fri, 14 Mar 2003 13:50:54 -0800

> Tony Li wrote:
> I think we're missing the big picture here. Handing
> out addresses before you understand how addresses
> will be used is not a good idea. We did this in IPv4
> and it resulted in the swamp.
> To not make this mistake again, we need to have a
> firm routing architecture for v6 in hand that includes
> support for multi-homing as a first level,
> non-scalability-impacting element.
> We are not there yet.

I could not agree more.

Michel.

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 14 Mar 2003 17:34:33 -0500

There is mini ARIN work shop April 6th and that week in Memphis.  A few
End users I know will be there and downstream providers that are using
the address space and going to request more.  ARIN listens to all input.
/jim

> From: Bob Hinden [mailto:[email-masked]] 
> Sent: Friday, March 14, 2003 12:30 PM
> To: Randy Bush
> Cc: [email-masked]
> Randy,
> At 02:27 PM 3/13/2003, Randy Bush wrote:
> > > You can do this in multiple ways. You could (playing the devils
> > > advocate) argue that the IETF should create technical 
> specifications 
> > > that can handle the policy of the RIRs. After all, to a 
> large extent 
> > > the RIR membership is most likely a better representation of 
> > > "end-users" (for some definition of users) than the IETF is.
> >
> >problem is that the rirs, aside from missing protocol folk, are also 
> >missing router/backbone ops folk.  so they get a very narrow view.
> 
> I agree.  It's not clear to me that either the IETF or the 
> RIRs represent 
> the "end-users".  The RIRs are focused on their members who 
> are mostly ISPs 
> and the IETF is populated by people from vendors, standards 
> professionals, 
> some ISPs, and researchers.  IMHO neither groups primary focus is the 
> "end-users".  I would think that the ISOC could possibly fill 
> this role.
> 
> > > A better way to move forward is most likely to have the IETF 
> > > _cooperate_ with the RIRs on a working policy.
> >
> >bingo!
> 
> YES!
> 
> Bob
> 
> 
>

---

From: "Tony Li" <[email-masked]>
Date: Fri, 14 Mar 2003 17:07:33 -0800

|    I don't agree.  Not because I don't believe multi6 issues 
|    should not be
|    done. But, because RIRs are dealing with free enterprise.  

So you're saying that you're waiting for the market to deliver
a routing architecture?  Or that the RIRs are going to?

|    Does this effort want to fix the multihome 
|    problem or the
|    routing architecture to be something other than what we have?  Two
|    different goals. 

The goal is to fix the multihoming problem, but to do it will take
a routing architecture that is different than what we have.

|    But, whatever is done will now have to be 
|    done while
|    IPv6 is in process in the market. I would suggest solving 
|    the multihome
|    problem is a good focus first, using IPv6 as defined.

Well, that's kinda hard, because IPv6 as defined simply ingrains
the problem.

Tony

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 14 Mar 2003 20:08:51 -0500

Masataka,

Exactly.  Free Enterprise means no Free stuff including the Internet.

Thanks
/jim

>Sent: Friday, March 14, 2003 6:56 PM
>To: Bound, Jim
>Cc: Michel Py; Tony Li; Randy Bush; Kurt Erik Lindqvist; Bob 
>Hinden; [email-masked]
>> I don't agree.  Not because I don't believe multi6 issues should not 
>> be done. But, because RIRs are dealing with free enterprise.
>
>There ain't no such thing as a free Internet.
>
>							Masataka Ohta
>

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 14 Mar 2003 20:16:56 -0500

>a routing architecture?  Or that the RIRs are going to?

RIRs will just give out addresses that is all.  THe market will deliver
a routing architecture via new industry consortia or we will figure it
out here.

>The goal is to fix the multihoming problem, but to do it will 
>take a routing architecture that is different than what we have.

Might be good to define routing architecture? If we begin by reducing
traffic that causes problems for routing at the ISP in the end systems I
believe that is a start.  If new routing architecture means change to
IPv6 then I say engineers go in a room and make work what you have.
Extensions to IPv6 are acceptable I think.

>Well, that's kinda hard, because IPv6 as defined simply 
>ingrains the problem.

That's where we  will never agree and I don't use the word never to
often.  One possible solution to this statemate is for someone to define
what exactly routing architecture would look like as a model.  Then if
we all agreed on that model each could apply that model to their
favorite solution.  I for one would look at extensions to IPv6 that are
quite possible and there are many places to define extensions (e.g. DST
Options, Hop-by-Hop, Next Headers new formats).

/jim

---

From: "Tony Li" <[email-masked]>
Date: Fri, 14 Mar 2003 23:42:12 -0800

|    RIRs will just give out addresses that is all.  THe market 
|    will deliver
|    a routing architecture via new industry consortia or we 
|    will figure it
|    out here.

A new industry consortia is now in charge of IPv6?  Please, point
us at it.  Figuring it out here is 'challenging'.

|    >|    Does this effort want to fix the multihome 
|    >|    problem or the
|    >|    routing architecture to be something other than what 
|    we have?  Two
|    >|    different goals.
|    >
|    >The goal is to fix the multihoming problem, but to do it will 
|    >take a routing architecture that is different than what we have.
|    
|    Might be good to define routing architecture?

10 years and we still don't understand the problem that we're trying
to solve?  Sigh.  

Routing is the other half of ROAD.  The part that we didn't ever
finish.

Ok, just for posterity: routing architecture tells you how
packets get from point A to point B in the network.  It includes
the semantics of the address, the routing protocols, and the forwarding
paradigm.

|    If we begin 
|    by reducing
|    traffic that causes problems for routing at the ISP in the 
|    end systems I
|    believe that is a start.

Ok, let's turn off v6.  Solved.

|    If new routing architecture 
|    means change to
|    IPv6 then I say engineers go in a room and make work what you have.
|    Extensions to IPv6 are acceptable I think.

Extensions imply that the architecture could not support that case
properly
as a first class citizen and that you're crocking and kludging to make
it work.  Seems like a pretty poor basis for a "new" protocol when
you're
trying to get it deployed and you admit up front that it doesn't cut it.

|    >Well, that's kinda hard, because IPv6 as defined simply 
|    >ingrains the problem.
|    
|    That's where we  will never agree and I don't use the word never to
|    often.  One possible solution to this statemate is for 
|    someone to define
|    what exactly routing architecture would look like as a 
|    model.  Then if
|    we all agreed on that model each could apply that model to their
|    favorite solution.  I for one would look at extensions to 
|    IPv6 that are
|    quite possible and there are many places to define 
|    extensions (e.g. DST
|    Options, Hop-by-Hop, Next Headers new formats).

Jim, if you're going to be so closed minded as to say that we will never
agree, then I don't see how you can reasonably expect anyone to change
the architecture.  Multihoming can never be a first class citizen in
the architecture if you do not divorce the 'locator' from the
'identifier'.
And that's what IPv6 insists on today.  If we continue down that path,
then the only alternatives are:

1) Forbid multihoming.  Not gonna happen.

2) All multihomed sites get global addresses and the routing subsystem
implodes.  This is the only way to get a single 'identifier' and then
use it for 'location' across all of my exit paths.  I must advertise
the route throughout the topology.

Which of these do you choose?  My vote:

3) Change the semantics of a v6 address.

Tony

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 15 Mar 2003 21:00:47 -0500

>..which is why I fail to see what this discussion is about. 
>The RIRs do 
>registry and address policy. The IETF do architecture, protocols and 
>some technology. There are well established rules to handle 
>the overlap.

I don't get the discussion either.  The IETF will never control what the
RIRs do and lots of people would scream with far more influence than the
IETF if this even was suggested.  Also the IETF is a standards body.
The IETF can suggest the architecture through the standards.  No one
builds networks based on the IETF opinion or whatever.  IETF is a just a
standards body and no more.  

/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 15 Mar 2003 21:02:22 -0500

Unlike the IETF RIRs do have to respond to market pressure.  RIRs do
take into consideration the IETF standards.  But not as gospel.
/jim

>From: David Conrad [mailto:[email-masked]] 
>Sent: Friday, March 14, 2003 9:57 PM
>To: Masataka Ohta
>Cc: Bob Hinden; Randy Bush; [email-masked]
>Ohta-san,
>On Friday, March 14, 2003, at 02:35  PM, Masataka Ohta wrote:
>>> Perhaps, say, Thomas Narten, Takeshi Arano, or David Kessens could
>>> work
>>> with ARIN and the other RIRs to come up with IPv6 policies?
>> None of them is IETF.
>
>True, however at least two of the three are quite active in IPv6 
>related issues within the IETF and I think it safe to assume technical 
>concerns from the IETF (and elsewhere) were taken into account during 
>the development of the current v6 policies.
>
>> IPng WG has no idea on addressing architecture for multihoming.
>> IPng WG has no idea on how global routing table size should
>> be managed.
>
>Yes.  However, the RIRs have come under significant criticism in the 
>past for being perceived as road blocks to IPv6 allocations and have, 
>in fact, reduced the requirements for v6 space.  Even in this list, 
>they are criticized for making obtaining address space 'hard'.
>
>Seems they are damned if they do and damned if they don't.
>
>Rgds,
>-drc
>
>
>

---

From: "Tony Li" <[email-masked]>
Date: Sat, 15 Mar 2003 22:40:05 -0800

Jim,

|    >3) Change the semantics of a v6 address.
|    
|    So you are not suggesting a syntax change only semantics 
|    to the 128bits?

Correct.  If it matters, yes, I don't believe that the current
IPv6 approach is the ultimately correct way of approaching things,
but I'm not trying to cause a revolution here.  Just prevent v6
from being a total waste of time.  We can work with the 128 bits
for now.

|    But I don't believe location and identification should be 
|    different. The
|    address should be overloaded to support both context.I 
|    believe that is
|    possible.  The address is both a location and an 
|    identifier. The IPv6
|    address supports location top down from the left most bits 
|    for routing.
|    So I believe what you ask exists now.

I'm asking that we separate the identifier and the location.  Can't
do that if they're one and the same.  I agree that the current
semantics are one and the same today.  This is exactly what makes
multihoming hard.  

|    Do you agree with the way we have stated the multi6 problem? 

Not particularly.  But I can state it very succinctly: a host 
needs one identifier and multiple locators.

Tony

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Mar 2003 07:04:27 -0500

Errrr forget that I will never get through baggage check :---)  Leaving
now.
But we all have to compromise or this will not get done.
/jim

> From: Bound, Jim 
> Sent: Sunday, March 16, 2003 6:49 AM
> To: 'Masataka Ohta'
> Cc: Tony Li; Michel Py; Randy Bush; Kurt Erik Lindqvist; Bob 
> Subject: RE: Again no multi6 at IETF#56
> 
> 
> You don't get it.  Your own country has IPv6 deployed as I 
> depicted in your native backbone.  You never will get it I 
> fear.  Hope I can talk to you face to face a the IETF to see 
> if we can resolve.  I have a kanto sword given to me my 
> martial arts master should I bring it :--)
> 
> /jim
> 
>  
> 
> 
> > Sent: Sunday, March 16, 2003 12:41 AM
> > To: Bound, Jim
> > Cc: Tony Li; Michel Py; Randy Bush; Kurt Erik Lindqvist; Bob 
> > > If this and many other specs do not begin to produce 
> solutions in a
> > > timely manner then I predict there will be a deployment 
> > body for IPv6
> > > to go work on those specs and send them to the IETF but not
> > with the
> > > intention of waiting for 4 years for them to complete but 
> implement
> > > and work the IETF at same time.  So my statement was the 
> > result of an
> > > "if".
> > 
> > 4 years?
> > 
> > 8 years have already wasted because some people has been
> > believing leagacy IPv6 were deployable.
> > 
> > 						Masataka Ohta
> > 
>

---

From: "J. Noel Chiappa" <[email-masked]>
Date: Sun, 16 Mar 2003 13:02:15 -0500

> From: "Bound, Jim" <[email-masked]>

    > I am suspect of the entire notion of the separation, which just being
    > technically accute having heard many solutions to this over the years.

Those many solutions would includ MIPv6, right Jim?

	Noel

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Mar 2003 20:12:41 -0500

> Those many solutions would includ MIPv6, right Jim?

How does MIPv6 fit the model?

Also I am not against trying I just said suspect.

WOuld like to see model though as I believe the two can be overloaded.
Maybe not.

/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Mar 2003 23:43:29 -0500

> Because it separates location from identity.

You believe this because the CoA is not the HoA?

/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Mar 2003 23:54:31 -0500

I am not convinced yet either.

But the fact that the MN can restate its location via CoA via BU via
RR+IPsec with HA.  Then the type-2 RH permits packet to get to MN via CN
via HoA.

Seems there is a bit of the abstraction for sure.

It also makes the MIPv6 MHH spec out quite believable.

But that is only part of the solution and I will stop there as I said we
need the model defined even before the architecture solution.  

We could view the MH model as XML
We could view the MH Architecture as Java
We could view the MH implementations as JDK X.X version

XML can support multiple descriptions.
Java can compile multiple descriptions.
The JDK can provide multiple primitives for exectution via libraries.

/jim

> From: Pekka Nikander [mailto:[email-masked]] 
> Sent: Sunday, March 16, 2003 9:27 PM
> To: J. Noel Chiappa
> Cc: Bound, Jim; [email-masked]
> J. Noel Chiappa wrote:
> YMMV.  In my opinion it does not.  It does *almost*
> separate location from identity, but not quite.
> At least if you do with the current security
> solutions.  If you invent better scalable security,
> then maybe.
> 
> [For current MN-HA security, you need a pre-established 
> security context.  For MN-CN security, you rely on HoT 
> packets, periodically (every 5 minutes) sent through the Home Agent.]
> 
> --Pekka Nikander
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 17 Mar 2003 02:52:12 -0500

> 	Freedom from choice: it's what you want.
> 					-- Devo

Ouch.  Whip it Whip it good :--)

   Same folks right >?>>

/jim

---

From: "Tony Li" <[email-masked]>
Date: Sun, 23 Mar 2003 23:38:39 -0800

|    Tony Li wrote:
|    ...
|    > We are currently trying to hold people off from 
|    deploying v6 because
|    > this issue is not closed. 
|    
|    Who's "we" please? There's a fair number of people who certainly
|    aren't trying to do anything of the kind.

Some of us who aren't fans of the current routing architecture.
Not all of them are IETF folks and I'm certainly not in a position
where I can claim to speak for them.

Tony

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 24 Mar 2003 16:41:15 -0500

Sean,

Agree with all except question.

>Whether this happens by engineering IPv6 in directions different from
-- but
 >informed by -- IPv4, or by non-deployment, possibly will be influenced
somewhat >by  cooperation here and between multi6 and the Internet Area.

The Internet Area does not influence deployment either?  The IETF does
not influence deployment was my statement.

Regards,
/jim