Subject: RE: Again no multi6 at IETF#56

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Mar 2003 06:53:38 -0500

Tony,

Could you write up your technical idea without a lot of man hours to
describe and why it solves the multihome problem.  I would listen for
one.  But I am suspect of the entire notion of the separation, which
just being technically accute having heard many solutions to this over
the years.  This could not be agreed on regardless of IPv6 all the way
back to NIMROD, which had nothing to do with IPv6.

/jim

> -----Original Message-----
> From: Tony Li [mailto:[email-masked]] 
> Sent: Sunday, March 16, 2003 1:40 AM
> To: Bound, Jim; Michel Py; Randy Bush; Kurt Erik Lindqvist
> Cc: Bob Hinden; [email-masked]
> Subject: RE: Again no multi6 at IETF#56
> 
> 
> 
> Jim,
> 
> |    >3) Change the semantics of a v6 address.
> |    
> |    So you are not suggesting a syntax change only semantics 
> |    to the 128bits?
> 
> 
> Correct.  If it matters, yes, I don't believe that the 
> current IPv6 approach is the ultimately correct way of 
> approaching things, but I'm not trying to cause a revolution 
> here.  Just prevent v6 from being a total waste of time.  We 
> can work with the 128 bits for now.
> 
> 
> |    But I don't believe location and identification should be 
> |    different. The
> |    address should be overloaded to support both context.I 
> |    believe that is
> |    possible.  The address is both a location and an 
> |    identifier. The IPv6
> |    address supports location top down from the left most bits 
> |    for routing.
> |    So I believe what you ask exists now.
> 
> 
> I'm asking that we separate the identifier and the location.  
> Can't do that if they're one and the same.  I agree that the 
> current semantics are one and the same today.  This is 
> exactly what makes multihoming hard.  
>     
> 
> |    Do you agree with the way we have stated the multi6 problem?
> 
> 
> Not particularly.  But I can state it very succinctly: a host 
> needs one identifier and multiple locators.
> 
> Tony
> 
>

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sun, 16 Mar 2003 16:23:43 +0100 (CET)

On Sun, 16 Mar 2003, Bound, Jim wrote:

> describe and why it solves the multihome problem.

I'm not Tony, but:

Traditional multihoming as is done in IPv4 will not scale.

An alternative is to give each host in a multihomed site an address for
each ISP the site is connected to. When (the link to) one ISP fails, the
communciation is diverted over the other ISP. However, current transport
protocols are unable to jump to new addresses in mid-session. Solution:
separate the identifier and locator functions of the IP address.
Transport protocols then use the identifier, which doesn't change during
the lifetime of the session, while IP uses the locator, which may be
changed at any time in order to route around broken parts of the
network.

A few things that need to be addressed to make this happen:

- Locators must always be present in each packet. But what about the
  identifiers? Do we include them in each packet (= tunneling) or are
  they implied?

- How do we discover identifiers and/or locators?

- How to we authenticate the relationship between locators and
  identifiers?

There is also the question of what makes good identifiers. HIP uses the
fingerprint of a cryptographic key. MHAP uses provider-independent IPv6
addresses that aren't visible in the global routing table. I myself have
suggested to use FQDNs as the first choice.

Note that there seems consensus here that we shouldn't try to revive GSE
or 8+8: some kind of "16+16" would be much easier to deploy.

Iljitsch

---

From: RJ Atkinson <[email-masked]>
Date: Sun, 16 Mar 2003 12:21:19 -0500

On Sunday, Mar 16, 2003, at 10:23 America/Montreal, Iljitsch van 
> or 8+8: some kind of "16+16" would be much easier to deploy.

It is not clear to me that this group has consensus on anything
other than:
	 "The current IPv4/IPv6 multihoming approach does not
	scale adequately."

Ran