Subject: [multimob] What is multicast mobility?

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 23 May 2007 14:08:20 -0700 (PDT)

Hello Folks,
  Suresh, Thomas and I initiated this activity and now I would like to propose a work plan and get your comments and reactions.
  
Item 1. 
Work on MLDv2 extensions. This work will concentrate on the router part and will involve how to track
per-host multicast listener status and build per host context. Per host multicast listener
context block, etc. will be defined.

Item 2.
Base protocol MIPv6 extensions on handling multicast sessions such as bandwidth inefficiency inherent in the home agent's unicasting  multicast packets through the tunnel.

Item 3. 
Handoff survival of local (at a foreign link) multicast sessions will be taken up in the context of care-of address based
 multicast group subscriptions.

  We solicit draft submissions in the above or related areas for IETF-69 as well as discussions on the mailing list so that we can organize an adhoc BOF meeting in Chicago.

  Any comments?

Regards,

Behcet

_______________________________________________
multimob mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/multimob

---

From: Hitoshi Asaeda <[email-masked]>
Date: Thu, 24 May 2007 14:54:46 +0900 (JST)

Hello Behcet,

> context block, etc. will be defined.

As you may know, the standard specification of MLDv2 is very complex
for regular or low-cost mobile terminals.
In fact, MBONED WG has been working on the "Lightweight IGMPv3 and
MLDv2" specification.
http://www.ietf.org/internet-drafts/draft-ietf-mboned-lightweight-igmpv3-mldv2-00.txt

This spec mainly aims to simplify the protocol spec by eliminating an
EXCLUDE filter-mdoe operation from the standard protocols and
corresponding message types. These protocols would also reduce the
implementation costs, while they keep interoperability with the
standard protocols.

We are currently working for the implementation design and its actual
implementations. If you are interested in this proposal, you may want
to read the I-D. We'd welcome your comment.

Regards,
--
Hitoshi Asaeda

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 24 May 2007 11:51:25 +0200

Behcet Sarikaya wrote:
> Hello Folks, Suresh, Thomas and I initiated this activity and now I
> would like to propose a work plan and get your comments and
> reactions.
> 
> Item 1. Work on MLDv2 extensions. This work will concentrate on the
> router part and will involve how to track per-host multicast listener
> status and build per host context. Per host multicast listener 

Sorry, isn't MLDv2 router implementation already keeping track of 
listener status?

> Item 2. Base protocol MIPv6 extensions on handling multicast sessions
> such as bandwidth inefficiency inherent in the home agent's
> unicasting multicast packets through the tunnel.

What could the HA do?  Not unicast the multicast packets through the tunnel?

> Item 3. Handoff survival of local (at a foreign link) multicast
> sessions will be taken up in the context of care-of address based

What's the influence of re-subscribing a new CoA upon each movement, on 
the infrastructure routing?

Alex

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: "Decoy M" <[email-masked]>
Date: Thu, 24 May 2007 16:05:48 +0300

> Sorry, isn't MLDv2 router implementation already keeping track of

[Decoy] I think most of th routers doesnt keep track of the indivisual
multicast listeners but they just check whether some bosyis interested in
the multicast channel or not. So explicit Host tracking may not be required.
This requires table maintainance and other work as each and every Host
information needs to be stored and maintained.