Subject: Re: [multimob] multimob@IETF69 Meeting summary

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Aug 2007 07:51:33 -0700 (PDT)

Let me clarify. Bidirectional tunneling mentioned in Suresh's meeting summary refers to the tunnel between MN and HA as in MIP6/HMIP6. There could be Bi-Dir PIM and as Thomas says it could be of interest to mobopts. Bi-Dir PIM is not of interest to multimob. This is also clear from the meeting summary.
Let's take any further discussion on Bi-Dir PIM to mobopts.

Regards,

Behcet

----- Original Message ----
From: Thomas C Schmidt <[email-masked]>
To: Marshall Eubanks <[email-masked]>
Cc: [email-masked]; mobopts <[email-masked]>
Sent: Tuesday, July 31, 2007 6:24:13 PM
Subject: Re: [multimob] multimob@IETF69 Meeting summary

Hi Marshall,

Marshall Eubanks wrote:

>> Three approaches to multicast mobility were discussed
>>
>> * Remote Subscription
>> * Bidirectional tunneling
> 
> I suspect this could be done using Bi-Dir PIM more or less as is. There 
> would have to be changes to support
> SSM, and Bi-Dir has never been made interdomain, but neither should be 
> that difficult in IPv6.
> 
> If anyone is interested in exploring this, please let me know.
> 
This remark on source-mobility agnostics of Bi-Dir PIM we already 
started to discuss in MOBOPTS, cf. 
http://tools.ietf.org/html/draft-irtf-mobopts-mmcastv6-ps ... and we 
started keeping an eye on it a while ago: it's really interesting!

And yes, we are looking at this and are interested in working a way 
further down there ...

For the moment I personally doubt, though, that Bi-Dir can easily be 
extended to scale beyond domains.

Anyway, Bi-Dir PIM can at least be embedded in (mobility-agnostic) 
hybrid approaches, cf.
http://samrg.org/about/meetings/ietf69/mw69-foilsV2.pdf

Cheers,

thomas
-- 

° Prof. Dr. Thomas Schmidt
° HAW Hamburg, Dept. Informatik
° University of Applied Sciences
° Berliner Tor 7, D 20099 Hamburg
° Germany, Fon: +49-40-42875-8157
° http://www.informatik.haw-hamburg.de/~schmidt

_______________________________________________
multimob mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/multimob

_______________________________________________
multimob mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/multimob

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 1 Aug 2007 11:49:11 -0400

On Aug 1, 2007, at 10:51 AM, Behcet Sarikaya wrote:

> Let me clarify. Bidirectional tunneling mentioned in Suresh's  
> meeting summary refers to the tunnel between MN and HA as in MIP6/ 
> HMIP6. There could be Bi-Dir PIM and as Thomas says it could be of  
> interest to mobopts. Bi-Dir PIM is not of interest to multimob.  
> This is also clear from the meeting summary.

Why ? I was at the meeting and I did not get that impression. Please  
be specific.

Regards
Marshall

---

From: Thomas C Schmidt <[email-masked]>
Date: Wed, 01 Aug 2007 12:38:35 -0500

Hi all,

Marshall Eubanks wrote:
>> Let me clarify. Bidirectional tunneling mentioned in Suresh's meeting 
>> summary refers to the tunnel between MN and HA as in MIP6/HMIP6. There 
>> could be Bi-Dir PIM and as Thomas says it could be of interest to 
>> mobopts. Bi-Dir PIM is not of interest to multimob. This is also clear 
>> from the meeting summary.
> 
> Why ? I was at the meeting and I did not get that impression. Please be 
> specific.
> 

I would not see such differentiation ...
to make things clear: bidirectional tunneling and bi-dir PIM only share 
the "bi-directional" in the name - Bi-Dir PIM is not a tunneling protocol.

On the other hand, bi-dir PIM is of special interest for source 
mobility, for receiver mobility it should admit similar behaviour as PIM-SM.

Cheers,

thomas

--

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 1 Aug 2007 13:49:25 -0400

On Aug 1, 2007, at 1:38 PM, Thomas C Schmidt wrote:

>>> HMIP6. There could be Bi-Dir PIM and as Thomas says it could be  
>>> of interest to mobopts. Bi-Dir PIM is not of interest to  
>>> multimob. This is also clear from the meeting summary.
>> Why ? I was at the meeting and I did not get that impression.  
>> Please be specific.
>
> to make things clear: bidirectional tunneling and bi-dir PIM only  
> share the "bi-directional" in the name - Bi-Dir PIM is not a  
> tunneling protocol.
>

Absolutely correct. It is a means of setting up PIM to pass multicast  
packets to and from a Rendezvous Point. No
tunneling is involved.

> mobility, for receiver mobility it should admit similar behaviour  

I would also agree here, with the addition that it might also be  
useful when the sources are also receivers (the service model  
basically assumes that nodes will be both).

Regards
Marshall

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 01 Aug 2007 17:51:53 -0400

> Why ? I was at the meeting and I did not get that impression. Please be 

I agree with you. I did not get that impression either. In fact we did 
not accept or rule out anything in the solution space. I think we should 
keep our options open. If Bi-Dir PIM solves some of the problems we 
elect to solve, we need to consider it.

Cheers
Suresh