Subject: [multimob] Adoption of draft-schmidt-multimob-pmipv6-mcast-deployment as a WG document

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 10 Dec 2009 08:03:45 -0800 (PST)

Hello all,
  Consensus on IGMP/MLD Proxy at MAG has been confirmed. Based on  evaluation of the four solution drafts, draft-schmidt-multimob-pmipv6-mcast-deployment comes closest to the charter item:

Initial version of a document explaining the use of multicast in PMIPv6. 

The latest version of this document can be found at:
http://tools.ietf.org/id/draft-schmidt-multimob-pmipv6-mcast-deployment-02.txt

This mail starts a WG adoption call on this draft.

The intended status for this document is BCP.
If adopted, the draft will be named:

draft-ietf-multimob-pmipv6-base-solution.

Please respond if you are for ADOPTING or

you are NOT for ADOPTING it by December 18, 2009.

Chairs

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 10 Dec 2009 17:14:59 +0100

Hi Behcet,

I do NOT support the ADOPTION of this document. We have just confirmed
consensus  on an approach and this is translated in adopting a
particular document? AFAIK, there are several documents following the
same IGMP/MLD approach and we haven't had much discussion on the pros
and cons of each of them. IMHO, it is early to make such an adoption
call and I strongly disagree with it.

Thanks,

Carlos

On Thu, 2009-12-10 at 08:03 -0800, Behcet Sarikaya wrote:
> _______________________________________________
> multimob mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multimob
-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Thu, 10 Dec 2009 14:02:10 -0500

Behcet,

I see that the evaluation slides have finally been posted as I requested at the meeting, and I appreciate that. However, they were never presented and I believe that some discussion on this evaluation slides is required before jumping to a conclusion and adopting a draft.

We have agreed that the MLD Proxy be at the MAG. Nonetheless, there are still open issues. For instance, we have not discussed about the role of the LMA and this could imply different solutions depending on whether we want to first solve the avalanche or the tunnel convergence problem. I believe that some discussion is still needed.

Therefore, at this point I DO NOT SUPPORT ADOPTING draft-schmidt-multimob-pmipv6-mcast-deployment as a WG draft.

Regards,

Juan Carlos

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Thursday, 10 December, 2009 11:04 AM
To: [email-masked]
Subject: [multimob] Adoption ofdraft-schmidt-multimob-pmipv6-mcast-deployment as a WG document

Hello all,

Chairs

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Fri, 11 Dec 2009 00:01:52 +0100

Hi Behcet, hi all,

I don't understand this "call for adoption" at the current moment.

We had the consensus at the Hiroshima meeting (affirmed by the recent 
mailing) that MLD/IGMP proxy at the MAG should be the favorite approach 
to a base solution.

We also had a number of questions and issues raised at the Hiroshima 
meeting that were to be addressed in updates of the corresponding 
proposals currently around.

To recall, we had three original solutions:

[Direct Routing Option:]
If native multicast routing reaches all MAGs in a PMIP domain, then 
straight-forward MLD proxying can be applied at MAGs with neither 
participation of the LMAs, nor tunneling.
This is proposed in parts of [draft-sijeon-multimob-mms-pmip6-01], if 
you strip context transfer and predictive operations off the document.

[Dedicated Multicast LMA:]
If all multicast traffic of an entire PMIP domain is managed by a single 
LMA, then all MAGs may choose a tunnel with this particular LMA for 
multicast uplink. There is no need for proxy binding caches and 
MN-specific states at the LMA.
This is proposed in section 3. of [draft-zuniga-multimob-smspmip-00], if 
you strip handover-specifics off the document.

[Proxy instance per LMA:]
If multicast traffic in PMIP should follow unicast paths, then it 
arrives at the MN via MN-specific LMAs and MAGs on the basis of proxy 
binding caches. This approach is a direct extension of unicast, 
facilitated by placing a proxy instance per MAG-LMA uplink on MAGs and 
proposed in [draft-schmidt-multimob-pmipv6-mcast-deployment].

Questions and issues raised at the meeting were concerned with 
efficiency, the MLD-related behavior of current router implementations 
and "the right way to organize an uplink". Contributers were asked to 
update the drafts following further investigations.

The latter has not happened, now. Personally, we are working on "our 
homework" and furthermore have indicated an elegant path to merge 
draft-sijeon-multimob-mms-pmip6-01 into 
draft-schmidt-multimob-pmipv6-mcast-deployment. We are about to prepare 
our update  and I guess some room for discussion should be left once all 
updates have been prepared.

So I don't see why this call for working group adoption precedes the 
updates of the drafts. I would suggest to await updates and perform the 
call after the discussion has reached some level of insight.

Best regards,

Thomas

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 11 Dec 2009 10:45:05 +0900 (JST)

> you are NOT for ADOPTING it by December 18, 2009.

I agree with others.

We don't say whether this draft is appropriate for the basic solution
or not.
This call for consensus is not appropriate at this moment.

Regards,
--
Hitoshi Asaeda

---

From: <[email-masked]>
Date: Fri, 11 Dec 2009 11:10:27 +0100

I second what have been already said. There are other proposals which are worth to be considered and discussed. It is too early for a WGLC.

BR,
Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la
> part de Carlos Jesús Bernardos Cano
> Envoyé : jeudi 10 décembre 2009 17:15
> À : Behcet Sarikaya
> Cc : [email-masked]
> Objet : Re: [multimob] Adoption of draft-schmidt-multimob-pmipv6-mcast-
> deployment as a WG document
> 
> Hi Behcet,
> 
> >   Consensus on IGMP/MLD Proxy at MAG has been confirmed. Based on
> evaluation of the four solution drafts, draft-schmidt-multimob-pmipv6-
> mcast-deployment comes closest to the charter item:
> >

---

From: "Lu, Guang" <[email-masked]>
Date: Fri, 11 Dec 2009 09:17:24 -0500

It is TOO EARLY for the WG to adopt any solution right now. The multiple drafts should be updated, and further evaluated before any adoption should be made. IMO, if different solutions work well in different use cases, the WG draft should make recommendations that allow various solutions to be used.  

At the IETF 76 meeting, the WG reached consensus on two things. 
First is to adopt the approach of IGMP/MLD proxy at the MAG (which was voted again recently on the mailing list)
Second, there are several proposed solutions under the IGMP/MLD proxy approach. The WG agreed that no specific draft was adopted.  This is because more work needs to be done on the "basic" stuff.

Below are quotes from IETF 76 minutes regarding: 
" Consensus call:
Multicast not locally available (no MLD Proxy at the MAG) forward IGMP/MLD to LMA, decap multicast data from LMA? None.
IGMP/MLD Proxy at the MAG? 16 votes.
Chairs. There is a consensus on proxy approaches.
We have decided on a (technical) direction to go, not on a particular draft.
"

"Jari: Basic stuff has to be done to move to the interesting problems.
However, we have not to sacrifice anything if solution space needs further
investigation."

Best Regards,
Guang

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Friday, December 11, 2009 5:10 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [multimob] Adoption ofdraft-schmidt-multimob-pmipv6-mcast-
> I second what have been already said. There are other proposals which
> are worth to be considered and discussed. It is too early for a WGLC.
> 
> BR,
> Pierrick
> 
> > > http://tools.ietf.org/id/draft-schmidt-multimob-pmipv6-mcast-
> deployment-
> > 02.txt
> > >

---

From: "Seil Jeon" <[email-masked]>
Date: Fri, 11 Dec 2009 23:55:46 +0900

Hi Behcet and multimob friends,

I also totally agree with other's opinions that we need discussion to determine the WG solution because we have just got consensus of direction to go where.
Consensus means that proxy MLD at the MAG as we know.

Of course, for a long time, we have talked about the various solutions through multimob mailing.
As the first result, we have arranged the issues of each solution at the hiroshima meeting.

As a next step, as schmidt says, it would be better discussion on the updated drafts, if necessarilly.

Best Regards,

Seil Jeon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Friday, December 11, 2009 1:04 AM
To: [email-masked]
Subject: [multimob] Adoption ofdraft-schmidt-multimob-pmipv6-mcast-deployment as a WG document

Hello all,

Chairs