Subject: Re: [netmod] Working Group Last Call: draft-ietf-netmod-yang-05.txt

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Mon, 18 May 2009 10:57:23 +0200

Continued my review from page 110 onwards. Again, I see no showstoppers.
Following are more or less nits/editorial comments, except for maybe the
comment on section 15 (security considerations).

- page 110, sect 8.2 2nd para:
     In this example, the mandatory constraints on the "longitude" leaf is
     not enforced on devices that lack the the "has-gps" feature:
  s/the the/the/

- page 113, section 9.1
     When NETCONF servers sends data, it MUST be in the canonical form.
  s/sends/send/
  or s/NETCONF servers/a NETCONF server/

- page 135, last bullet
     o  The "prefix" statment may be changed, provided all local uses of
         the prefix also are changed.
  s/statment/statement/

- section 13
  The subsections have a title that ends in a colon (:).
  Not sure the RFC editor will accept that?
  Any reason why we do not use a period?

- section 15
         YANG is dependent upon:
  Is it indeed YANG that depends on it?
  Or is it any data that is modeled in the YANG language that depends on it?

Bert

  ----- Original Message ----- 
  From: Bert Wijnen (IETF) 
  To: David Partain ; NETMOD Working Group 
  Sent: Monday, May 18, 2009 12:34 AM
  Subject: Re: [netmod] Working Group Last Call: draft-ietf-netmod-yang-05.txt

  Sofar (I have reviewed the document up to (and including) page 109, I have
  not seen any showstoppers. In general, this is a well written document.

  My review comments, none of them are fatal or showstoppers:

  - I suspect (but am not sure) that either IESG members or RFC-Editor may
    want us to expand acronyms like YANG and YIN when we first use them.
    In fact that applies to all acronyms we use.
    
  - In the abstract, I would leave out the 1st par.
    Certainly, in a year or so, the statement is (hopefully) no longer true.
    Besides, it is more of a "sales" statement than anything else.
    In the second para it states:
      YANG models the operations and content layers of NETCONF ...
    I guess you/we mean: YANG is used to model the .....

  - Page 11:
    o  MIB: A Management Information Base, traditionally referring to a
       management information defined using SNMP's SMI.

    I would say either "A Management Information Base Module" or "Management Information Base"
    And "a management information defined" probly should be "a management information model defined.." ??
    Or maybe just remove the "a".

  - Page 12
     o  A container node without a "presence" statement, which has has at
        least one mandatory node as a child.
    s/has has/has/

  - Page 13
     scripts to operate on the models.  The conversion from YANG to YIN is
     loss-less, so content in YIN can round-tripped back into YANG.
    s/can round-tripped/can be round-tripped/ ??

  - Page 21
    Not that it matters much, but when I see:
       typedef percent {
           type uint16 {
               range "0 .. 100";
           }
           description "Percentage";
       }

    I always wonder: why is this s uint16 and not a uint8 ??

  - Page 25
    The name of the example notification "link-failure" is a bit strange
    Specifically since the example notification informs about a "link UP" condition,
    so that is recovery from a failure. Maybe better to name it "link-status-change"
    or some such?

  - Page 29, sect 5.2
      The name of the file SHOULD be on the form:
    s/on the form/of the form/

  - Page 47, section 7.1.10 states/uses:
                Phone: +1 800 555 0815
    According to www.ietf.org/ID-Checklist.html section 3.6.D I think we better use
                Phone: +1 800 555 0100

  - Same in section 7.2.3

  - Page 64, section 7.7.3, 3rd line
         A valid leaf-list or list MUST have least min-elements entries.
    s/have least/have at least/

  I have reviewed up to (and including) page 109.

  Bert
    ----- Original Message ----- 
    From: David Partain 
    To: [email-masked] 
    Sent: Thursday, April 30, 2009 9:04 AM
    Subject: [netmod] Working Group Last Call: draft-ietf-netmod-yang-05.txt

    Dear all,

    This is the working group last call on the current working group document:

    - YANG - A data modeling language for NETCONF: 
    http://tools.ietf.org/html/draft-ietf-netmod-yang-05.txt

    The authors and the chairs think that this document is mature enough for WGLC.  
    This WGLC will last until May 15, 2009.

    Please review and send comments to this list.

    Thanks.

    David^2
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 18 May 2009 13:29:55 +0200 (CEST)

Hi,

> comment on section 15 (security considerations).

I applied all your patches.

>   Or is it any data that is modeled in the YANG language that depends on it?

I think it should be "Data modeled in YANG is dependent upon:".

/martin

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Mon, 18 May 2009 13:32:27 +0200

That would address my comment.

Bert
  ----- Original Message ----- 
  From: Martin Bjorklund 
  To: [email-masked] 
  Cc: [email-masked] ; [email-masked] 
  Sent: Monday, May 18, 2009 1:29 PM
  Subject: Re: [netmod] Working Group Last Call: draft-ietf-netmod-yang-05.txt

  /martin