Subject: Re: [netmod] varbinds instead of leafrefs in notifications

From: David Partain <[email-masked]>
Date: Tue, 14 Jul 2009 14:14:55 +0200

On Thursday 04 June 2009 12.49.37 Martin Bjorklund wrote:
> Juergen Schoenwaelder <[email-masked]> wrote:
> > On Thu, Jun 04, 2009 at 10:09:37AM +0200, Balazs Lengyel wrote:
> > > I really liked Andy's varbind idea. Can we have this for
> > > notifications? It is simple, elegant and solves a real use-case. It
> > > will result in much less confusion then understanding leafrefs in
> > > notifications, it is also much more compact especially for lists
> > > with multiple keys or lists within lists.
> >
> > There are many questions that need to be asked about this new feature
> > (and let us be clear that this is a new feature), such as:
>
> Yes, and as we think more and try to document it (and implement it!)
> we will find new questions.  I strongly prefer to postpone this new
> feature.  If we keep the current leafref and later find a beautiful
> way to handle notifications, well the worst thing that happened is
> that we get a deprecated use case for leafrefs.

Hi all,

No new features at this point...  Much too close to "the end" of our first 
round of YANG fun.

cheers,

David

---

From: Andy Bierman <[email-masked]>
Date: Tue, 14 Jul 2009 08:04:20 -0700

> No new features at this point...  Much too close to "the end" of our first 

Agreed.
Next time around there will probably be some
vendor extensions to choose from, when looking
at new features to standardize.

It has come to my attention that not everybody thinks
the XPath filtering should return a full-blown XML tree.
Some people would prefer the option of getting back
a varbind list representing the XPath node-set result,
instead of XML subtrees.

(So, it's not just notifications that need varbinds.)

> David

Andy