Subject: [netmod] yang-06; 9.7.3 (bits ordering)

From: Andy Bierman <[email-masked]>
Date: Thu, 02 Jul 2009 09:11:48 -0700

Hi,

I do not like the canonical ordering for the bits data type.
It is based on the order the bit statements appear in the
YANG file.  It should be based on the 'position' number
given explicitly or automatically in the bit-stmt.

Otherwise, what is the point of the position sub-stmt?
It is just another special description clause?

It seems non-intuitive to the YANG writer as well.
It seems from reading a YANG module (not 1 sentence buried
on page 120 of a 173 page draft), that by setting the
position, you are setting the canonical order.
One would not guess that the position-stmt is merely
ornamentation.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 02 Jul 2009 18:52:01 +0200 (CEST)

> given explicitly or automatically in the bit-stmt.

I agree.

/martin