Subject: [netmod] CLR request

From: Andy Bierman <[email-masked]>
Date: Wed, 12 Aug 2009 08:15:19 -0700

Hi,

I have some early implementation experience that suggests
that 2 specific corner-cases are very hard to implement
correctly in the agent protocol stack:

   1) leafref chains (leafref points to leafref points to ...)
   2) leafrefs that point to instance-identifiers

I suspect that nobody will want to remove these features,
even though there are no use cases that matter
to our problem space to back them up.

This is kind of like retrieving the main module while
parsing a submodule, just to get the prefix.  This
was eventually fixed in the belongs-to-stmt.
I hope I don't hear any whining a year from now
how difficult this bit is to code, as if the issue
was never raised before.

If we are going to end up with these
CLRs to get people to implement YANG, then let's add
them now, or decide now that this is not a concern
to the WG, or any unreasonable implementation burden.

Andy

---

From: WashamFan <[email-masked]>
Date: Mon, 17 Aug 2009 10:09:58 +0800

Hi,
 
>     2) leafrefs that point to instance-identifiers

Why these are special cases?
In 1), let assume leafref leaf A points to leafref leaf B points to
leaf C, then A's value space would be constrained by B only, A
doesn't need to care about C.
In 2), why instance-identifier leaf is special? It could be interpreted
as a string leaf with 'XPath like' value.

I did not do relevant implementation yet. So, I am sorry if I miss
somthing.

washam

---

From: Andy Bierman <[email-masked]>
Date: Mon, 17 Aug 2009 01:03:08 -0700

> I did not do relevant implementation yet. So, I am sorry if I miss

we are not concerned with the implementation complexity
of YANG, so you didn't miss anything.  Every little YANG
detail is wonderful and important and easy to code...

Andy