Subject: Re: [netmod] mandatory mess

From: Ladislav Lhotka <[email-masked]>
Date: Sat, 01 Aug 2009 13:13:55 +0200

Phil Shafer píše v Čt 30. 07. 2009 v 19:33 -0400:
> Ladislav Lhotka writes:
> >So one has to come to the conclusion in this case that a mandatory node
> >has to be set by the client in order to get into the datastore and thus
> >cannot be supplied by the server in an "initial factory setting".
> 
> I don't grok the hangup here, but perhaps if you view it
> this way it will help.  On some boxes, when the startup
> mechanism notices that the configuration database is empty,
> a "local client application" is triggered that loads some
> factory default configuration into the configuration database.
> And this "local client" need not be a NETCONF client, it
> can be something as mundane as:
> 
>    [ -s $config ] || cp $factory_defaults $config

So if I unwrap my device and switch it on, mandatory (and perhaps some
other) nodes are filled in. Now:

1. Is this factory default configuration (part of) the 'initial default
state' that RFC 4741 talks about?

2. Will the values set this way be returned in get-config having
with-defaults=false?

3. Is it possible that this factory default configuration sets some
optional leafs to values that differ from the defaults specified in the
data model? 

Lada

> Thanks,
>  Phil
-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Phil Shafer <[email-masked]>
Date: Sat, 8 Aug 2009 10:35:47 -0400

>state' that RFC 4741 talks about?

No, I don't think so.  This is just a default config content that the
device will supply if you don't give one.

>2. Will the values set this way be returned in get-config having

No.  You are free to delete such "factory default" config.

>optional leafs to values that differ from the defaults specified in the

Sure, I could have a default syslog file called "messages" that has
a large value for "size" and "count" that are not the normal defaults.

Thanks,
 Phil