Subject: Re: [netmod] Configuration nodes was Re: meaning of defau

From: David Partain <[email-masked]>
Date: Wed, 2 Sep 2009 13:39:33 +0200

On Friday 28 August 2009 22.40.08 Martin Bjorklund wrote:
> Andy Bierman <[email-masked]> wrote:
> > Martin Bjorklund wrote:
> > > Andy Bierman <[email-masked]> wrote:
> > >> We all agree that only actual instances of a leaf object
> > >> matter here.  The whole premise behind filter='explicit'
> > >> is that the client does not need to know the server
> > >> selected values of these instances because the exact
> > >> value the server has selected is described somehow in
> > >> the optional-to-use user documentation.
> > >
> > > You keep saying this, and we keep saying that this is not the way it
> > > works.  The premise is that the client knows the (static) default
> > > value from the "default" statement (if it needs to know it at all).
> >
> > if this is true, then why does the 'explicit' mode
> > of with-defaults just look at whether the leaf was
> > explicitly set and not the YANG default?
>
> I didn't write that draft - you did ;)  But I assume that it is
> supposed to be DML-agnostic?  For me it would be fine to make it
> YANG-specific, or at least be very specific that *if* the data model
> is written in YANG, it means that it applies to leafs with the
> "default" statement that are not explicitly set.

Hi all,

I agree with Martin here.  If we need to add YANGish clarifications 
to :with-defaults, let's do so (but please talk about it in NETCONF...)

Cheers,

David

---

From: Andy Bierman <[email-masked]>
Date: Wed, 02 Sep 2009 05:10:36 -0700

>> I didn't write that draft - you did ;)  

Actually, the draft I submitted was much simpler and
much more clear than what the WG has now.
It was a simple boolean for a simple concept
(do you want the defaults or not?)

But I assume that it is
> to :with-defaults, let's do so (but please talk about it in NETCONF...)

sure -- but IMO what mailing list we use is irrelevant.
The with-defaults draft needs to align with YANG
definitions, so do we send an email to NETCONF
if we just refer to the <with-defaults> parameter,
but send the email to NETMOD if we ask about the
meaning of a default?

> David

Andy

---

From: David Partain <[email-masked]>
Date: Wed, 2 Sep 2009 16:15:39 +0200

Hi,

> sure -- but IMO what mailing list we use is irrelevant.

In principle, I agree since it's the same people in both places.  I just hope 
the (other) NETCONF folks are all watching.

> The with-defaults draft needs to align with YANG definitions

We agree.  So let's do that.

Cheers,

David