Subject: [netmod] Null namespace for a module?

From: Balazs Lengyel <[email-masked]>
Date: Tue, 15 Sep 2009 10:55:38 +0200

Hello,
Is it allowed to use a NULL empty namespace for a YANG module?
namespace "";

Background: We have legacy nodes that have big models, that do not have a namespace, and as 
their model is strictly managed, avoiding all naming collisions, there is no need for the 
namespace.

Balazs

---

From: WashamFan <[email-masked]>
Date: Fri, 18 Sep 2009 17:17:00 +0800

Personally, NULL namespace should be allowed but recommended not to use, IMO.

washam

----- Original Message -----
From: Balazs Lengyel <[email-masked]>
Date: Tuesday, September 15, 2009 4:58 pm
Subject: [netmod] Null namespace for a module?
To: NETMOD Working Group <[email-masked]>

>  _______________________________________________
>  netmod mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 18 Sep 2009 11:38:19 +0200 (CEST)

> Personally, NULL namespace should be allowed but recommended not to use, IMO.

It is currently not allowed, and I don't think it is a good idea to
allow it.  There can only be one module with a NULL namespace, and it
is bound to lead to interoperability problems if more than one such
module is used in a network.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 18 Sep 2009 12:49:58 +0200

> module is used in a network.

+1. Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C