Subject: Re: [netmod] Configuration nodes was Re: meaning of defau

From: David Partain <[email-masked]>
Date: Wed, 2 Sep 2009 12:49:43 +0200

On Thursday 27 August 2009 17.57.43 Andy Bierman wrote:
> If this filtering was just limited to YANG default-stmts,
> then it would be fine, but it is not.

I just be really thick, but I thought that's _exactly_ what it was limited to.  

We need to work on the interaction between this and :with-defaults (which 
should be done in NETCONF...), but I've never seen anyone suggesting the 
server should just magically decide what it will or will not send.

David

---

From: Andy Bierman <[email-masked]>
Date: Wed, 02 Sep 2009 04:19:57 -0700

> I just be really thick, but I thought that's _exactly_ what it was limited to.  

maybe you should catch up on the mail threads.
We are trying to resolve terminology errors in
the with-defaults spec.  We were combining
poorly written text in with-defaults
with the inherently complex YANG document definitions
and they did not align correctly.

I am not convinced the complexity we continue
to pile onto YANG is directly proportional to
its usefulness, but one could have
said that at 50 pages, 80 pages, 120 pages...

> David

Andy

---

From: David Partain <[email-masked]>
Date: Wed, 2 Sep 2009 13:46:13 +0200

> and they did not align correctly.

Thanks, Andy.  I'm perfectly aware of what the discussion is about.

David

---

From: Andy Bierman <[email-masked]>
Date: Wed, 02 Sep 2009 05:59:59 -0700

> Thanks, Andy.  I'm perfectly aware of what the discussion is about.

great then -- glad you can join us.

The threads are way too long and repetitive.
It would be great if they were resolved sooner.

I am having a hard time believing that Joel and I
misinterpreted the meaning of 'explicit' with-defaults
retrieval so incorrectly.

We repeatedly asked if this referred just to nodes
set by the client, and were told yes.
We asked, will server-created leaf instances that do not
contain the YANG default-stmt value be returned?
We were told no.

Now we are told the opposite, that 'explicit'
means set by the client AND the server (who's left?)
and all server-created leaf instances are returned
in a <get-config>.

Explicit just means: "if the client set it, return it,
even if the value is the YANG default".  This was not made clear
until recently.

Andy

---

From: Phil Shafer <[email-masked]>
Date: Wed, 2 Sep 2009 10:09:03 -0400

>even if the value is the YANG default".  This was not made clear

In any event, let's stop with the finger pointing and be happy that
we've finally arrived back at the same concensus we arrived at last
time.  Take a moment, enjoy the calm.

Thanks,
 Phil

---

From: David Partain <[email-masked]>
Date: Wed, 2 Sep 2009 16:19:20 +0200

Hi,

> It would be great if they were resolved sooner.

That's not _just_ my job...  That's why I'm nagging at people to be as 
succinct as possible, use relevant subject lines, etc. etc.

> even if the value is the YANG default".  This was not made clear

OK.  That's how I understood it all along, but clearly everyone didn't.  So, 
can we put that text in the right place in :with-defaults and take (at least) 
that confusion off the table?

Thanks.

David

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 3 Sep 2009 20:17:02 +0200

> even if the value is the YANG default".  This was not made clear

Not sure this is correct since it does not matter who or what created
the config leaf. But note that this does not mean operational state is
config. This is where the communication problem is.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>