Subject: Re: [netmod] meaning of default

From: Balazs Lengyel <[email-masked]>
Date: Wed, 21 Oct 2009 13:47:32 +0200

Hello,
I am rejoining after a long pause so I am not up to date with all emails, still I would like to 
reiterate one point:

Earlier it was intentionally left open whether a leaf not set by the client, which has a 
default value exists in the database or not. For many existing node it does exist in the 
database (e.g. Ericsson), for other it does not (e.g. Juniper). We should not try to specify in 
YANG if it exists or not.

Balazs

---

From: Andy Bierman <[email-masked]>
Date: Wed, 21 Oct 2009 08:11:00 -0700

Balazs Lengyel wrote:
> Hello,
> I am rejoining after a long pause so I am not up to date with all
> emails, still I would like to reiterate one point:
> 
> Earlier it was intentionally left open whether a leaf not set by the
> client, which has a default value exists in the database or not. For
> many existing node it does exist in the database (e.g. Ericsson), for
> other it does not (e.g. Juniper). We should not try to specify in YANG
> if it exists or not.
> 

We agreed that the validation is done against
a conceptual XML document containing the explicit nodes
plus the YANG defaults.

Now there is some complications for the candidate
because some s-c leafs cannot appear in candidate
until after the commit.

Unless the leaf contains the YANG default value,
it is not a default -- it is an explicit leaf.

> Balazs

Andy