Subject: Re: [netmod] [Netconf] 4741bis, issue 14, capabilities changed error

From: Washam Fan <[email-masked]>
Date: Thu, 10 Dec 2009 20:50:59 +0800

Hi,

>>   The capabilities of a NETCONF server may change over time.  However,
>>   once a NETCONF server has announced its capabilities in the <hello>
>>   message, the capabilities for that session MUST NOT change.  A
>>   server MUST reply with a 'capabilities-changed' error if the client
>>   sends a request which is affected by a modified capability.
>>
>> And maybe add:
>>
>>   A server MAY choose to send 'capabilities-changed' as the response
>>   to any request other than <close-session> if its capabilities has
>>   changed.
>>
>>
>
>
> I agree with Phil that this is a vendor-specific
> detail, and there are many mechanisms that might be used
> to deal with changing capabilities,

> or the specific operation
> may not be affected by the capability change at all.

As I pointed out long time ago, this might be where warning
usage enters in. closing or re-initiating sessions might be costly
when operations are not affected by the capability change,
maybe casting a warning would suffice in this case. (Yes,
warning usage is still up in the air)

washam

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Dec 2009 15:10:20 +0100

> warning usage is still up in the air)

I don't think NETCONF has a working mechanism for warnings.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>