Subject: [netmod] yang-09, sec.10, revision rules

From: Andy Bierman <[email-masked]>
Date: Mon, 07 Dec 2009 11:05:14 -0800

Hi,

[this WGLC comment got lost in the wrong thread]

It does not make any sense to talk about different versions
of a YANG [sub]module without a new revision date.  There is no way
to even distinguish which is the old version and which is
the new version in a standard way.

Sec 10:

  For any published change, a new "revision" statement (Section 7.1.9)
  SHOULD be included in front of the existing revision statements.

Edit 1:  s/SHOULD/MUST

Edit 2:  state (somewhere in sec. 10) that a module without
         revisions MUST NOT change (ever)

Summary:
   - if you use a revision in the first publication,
     you have to keep using revisions correctly every
     time the module is changed.
   - if you choose not to use revisions, then there
     is only one revision (ala no namespace in XML)
     that is possible.  Therefore no changes to the
     module are allowed at all.

Either that, or add text that explains how the standard is
used to distinguish different versions of a conceptual
YANG [sub]module, by some means other than the revision date.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 07 Dec 2009 20:43:49 +0100 (CET)

>   SHOULD be included in front of the existing revision statements.

I agree.

>          revisions MUST NOT change (ever)

I don't think this is necessary, but I'm ok with adding it.

/martin