Subject: [netmod] closure on identifier rule change

From: Andy Bierman <[email-masked]>
Date: Tue, 05 Jan 2010 11:33:05 -0800

Hi,

I think there is WG consensus to change the identifier
rules to disallow the 'xml' prefix (in any form).

This change has a real impact, because 'xml' is such
an obvious prefix to use, especially if one is concerned
with reusing identifiers from other access methods
(like CLI/SSH or SMI/SNMP).

But better to start enforcing the CLR now.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 05 Jan 2010 21:29:52 +0100 (CET)

> rules to disallow the 'xml' prefix (in any form).

Yes.  I have made this change, currently as a comment in the grammar:

;; An identifier MUST NOT start with (('X'|'x') ('M'|'m') ('L'|'l'))
identifier          = (ALPHA / "_")
                      *(ALPHA / DIGIT / "_" / "-" / ".")

And the main text says:

  The identifier syntax is formally defined by the rule "identifier"
  in ^grammar^.

/martin