Subject: Re: [netmod] Default presence containers

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Fri, 28 Mar 2014 15:27:08 +0000

Did this get lost in the weeds? Or is it just that no one thinks it’s a
valid concern?

-Jeff

On 3/26/14, 10:16 AM, "Lange, Jeffrey K (GE Energy Management)"
<[email-masked]> wrote:

>Is there any way in YANG that one can create a presence container with a
>default state? 6020 does not list ³default² as a sub statement to
>container. If not, perhaps this is a useful feature for YANG 1.1
>
>e.g. (from 6020):
>
>container system {
>    description "Contains various system parameters";
>    container services {
>        description "Configure externally available services";
>        container "ssh" {
>            presence "Enables SSH";
>            description "SSH service specific configuration²;
>            default present; // or not-present
>        }
>    }
>}
>
>Thanks!
>-Jeff
>
> 
>
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Fri, 28 Mar 2014 08:36:12 -0700

On Fri, Mar 28, 2014 at 8:27 AM, Lange, Jeffrey K (GE Energy Management) <
[email-masked]> wrote:

> Did this get lost in the weeds? Or is it just that no one thinks it's a
> valid concern?
>
>

I think this is interesting.
A new statement should be used instead of overloading the default-stmt.
That is supposed to be for a leaf only, and the string must be valid for
the data type.

Maybe:

   default-presence true|false;

> -Jeff

Andy