Subject: [netmod] draft-huang-netmod-acl (Stateless Packet Filter Configuration)

From: "Steve Cheng (scheng2)" <[email-masked]>
Date: Sun, 2 Mar 2014 18:23:27 +0000

Hi Team,

I went through the draft with some colleagues and we do have quite some questions about this draft. I'm in IETF London meeting so if you are interested in this topic, we can talk in person. I'd like to list all questions about checking with a few folks first.

Anyway, one dummy question to get started. Why do we name it "SPF" instead of "ACL". Taking a look at major vendors (Haihua/Cisco/ALU/Juniper), none of them call this SPF.

*         Cisco/Haihua call it "ACL", ALU calls it "Filter", and Juniper calls it stateless firewall filter.

ACL has been around for a long time with huge customer base. Not sure why renaming it to SPF. I heard this was discussed before but I simply don't quite understand the reason.

Thanks,

Steve Cheng

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 3 Mar 2014 10:45:10 +0100

> ACL has been around for a long time with huge customer base. Not sure why renaming it to SPF. I heard this was discussed before but I simply don't quite understand the reason.

I guess it is called stateless packet filter because that is what it
really is that you are modeling.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 3 Mar 2014 10:10:27 +0000

> really is that you are modeling.

+1. It neither controls access nor filters firewalls. :-)

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Steve Cheng (scheng2)" <[email-masked]>
Date: Mon, 3 Mar 2014 10:26:24 +0000

Well, we are modeling something already exists for 15+ years which is known as ACL...

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Monday, March 03, 2014 1:45 AM
To: Steve Cheng (scheng2)
Cc: [email-masked]
Subject: Re: [netmod] draft-huang-netmod-acl (Stateless Packet Filter Configuration)

> ACL has been around for a long time with huge customer base. Not sure why renaming it to SPF. I heard this was discussed before but I simply don't quite understand the reason.

I guess it is called stateless packet filter because that is what it really is that you are modeling.

/js