Subject: [netmod] new YANG 1.1 issue: default for leaf-list

From: Andy Bierman <[email-masked]>
Date: Fri, 28 Mar 2014 08:43:42 -0700

Hi,

Not sure if this is too difficult or too minor...

There are use cases where a leaf-list is initialized
with some default value if no client value is provided
(same as a leaf).

E.g.

   leaf-list ncport {
      type inet:port-number;
      description
         "The port numbers that should be accepted for NETCONF sessions";
      default "[830]";
   }

This would require some new syntax to represent an array of default values.

Proposal: support default for leaf-list somehow

Andy

---

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Fri, 28 Mar 2014 15:46:53 +0000

I like this.  I’ve had to implement my way around this limitation with description text that explained what the behavior is if the leaf-list is empty.

-Jeff

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 28, 2014 at 11:43 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [netmod] new YANG 1.1 issue: default for leaf-list

Hi,

E.g.

   leaf-list ncport {
      type inet:port-number;
      description

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 28 Mar 2014 22:37:53 +0100 (CET)

Hi,

Added as Y28.

/martin