Subject: [netmod] new YANG 1.1 issue: remove deviations

From: Andy Bierman <[email-masked]>
Date: Sun, 30 Mar 2014 10:27:31 -0700

Hi,

I don't think YANG deviation statements are being used,
nor are they likely to ever be used. They are not allowed
to appear in standard YANG modules, so I am asking
vendors out there:

   Do you use (or plan to use) deviation statements in your YANG modules?

If consensus is no, then deviations should be removed from YANG 1.1.
YANG would be simpler without them.
IMO, conformance information should be handled differently anyway.

Andy

---

From: "Patrick Gili (pgili)" <[email-masked]>
Date: Mon, 31 Mar 2014 13:10:39 +0000

Hi Andy,

I don't think it is a good idea to remove deviations. While we are not publishing deviations at this time, we are dealing with a use case that may require the use of deviations.

Cheers,
-Patrick

From: netmod [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Sunday, March 30, 2014 1:28 PM
To: [email-masked]
Subject: [netmod] new YANG 1.1 issue: remove deviations

Hi,

Andy