Subject: [netmod] Fwd: New Version Notification for draft-lhotka-netmod-yang-metadata-00.txt

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 11 Sep 2014 14:21:09 +0200

Hi,

this draft tries to cover all aspects of defining and using metadata annotations with YANG-based data, including their encoding in both XML and JSON. Consequently, I plan to remove the section on metadata encoding from draft-ietf-netmod-yang-json.

Lada

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-lhotka-netmod-yang-metadata-00.txt
> Date: 11 Sep 2014 14:03:37 GMT+2
> To: Ladislav Lhotka <[email-masked]>, "Ladislav Lhotka" <[email-masked]>
> 
> 
> A new version of I-D, draft-lhotka-netmod-yang-metadata-00.txt
> has been successfully submitted by Ladislav Lhotka and posted to the
> IETF repository.
> 
> Name:		draft-lhotka-netmod-yang-metadata
> Revision:	00
> Title:		Defining and Using Metadata with YANG
> Document date:	2014-09-11
> Group:		Individual Submission
> Pages:		14
> URL:            http://www.ietf.org/internet-drafts/draft-lhotka-netmod-yang-metadata-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-lhotka-netmod-yang-metadata/
> Htmlized:       http://tools.ietf.org/html/draft-lhotka-netmod-yang-metadata-00
> 
> 
> Abstract:
>   This document defines a YANG extension statement that allows for
>   defining metadata annotions in YANG modules.  The document also
>   specifies the encoding of annotations and rules for annotating
>   instances of YANG data nodes.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Sun, 14 Sep 2014 10:29:45 -0700

On Thu, Sep 11, 2014 at 5:21 AM, Ladislav Lhotka <[email-masked]> wrote:

> Hi,
>
> this draft tries to cover all aspects of defining and using metadata
> annotations with YANG-based data, including their encoding in both XML and
> JSON. Consequently, I plan to remove the section on metadata encoding from
> draft-ietf-netmod-yang-json.
>
>
I reviewed this draft and it looks good.  I did not find any problems with
the mappings
or the YANG extension, and plan to implement soon.

> Lada
Andy

> > URL:
> http://www.ietf.org/internet-drafts/draft-lhotka-netmod-yang-metadata-00.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-lhotka-netmod-yang-metadata/
> > Htmlized:
> http://tools.ietf.org/html/draft-lhotka-netmod-yang-metadata-00
> >
> >
> > Abstract:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 15 Sep 2014 07:41:30 +0200

On 14 Sep 2014, at 19:29, Andy Bierman <[email-masked]> wrote:

> I reviewed this draft and it looks good.  I did not find any problems with the mappings

Thanks. I have already implemented it in the DSDL plugin of pyang - the generated RELAX NG schema can now validate instance documents containing annotations.

Lada