Subject: [netmod] YANG 1.1 Y16 (optimized hello) and revisions

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Mon, 22 Sep 2014 17:31:40 +0000

Hi all,

I saw the minutes about Y16 from the Sept 17/18 interim meeting (and some of the followup discussions in the meeting minutes thread) but I didn't notice discussion about revisions.

In Y16-02 how would indications of revisions work for an <id-of-module-set> ?   The 100+ modules in a hello can each have a revision indicated but once we aggregate them up into a single "set" does a new revision of one of the modules constitute a new set ?   a new overall revision for the set ?

Regards,
Jason

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 22 Sep 2014 20:15:21 +0200

> In Y16-02 how would indications of revisions work for an <id-of-module-set> ?   The 100+ modules in a hello can each have a revision indicated but once we aggregate them up into a single "set" does…

We did not work out the details but the general idea was that whenever
things change, there would have to be a new identifier for the module
set. And the silent assumption in NETCONF is that capability changes
lead to a restart of a session. Not exactly sure at the moment how
this would be dealt with in RESTCONF (perhaps the ID is carried in a
header on every response message).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>