Subject: [netmod] Any tool to test NETCONF/YANG RFC compliance?

From: Johnson Zhu <[email-masked]>
Date: Thu, 27 Nov 2014 07:20:15 +0000

Hi,

We are looking some third party tool to test NETCONF/YANG RFC compliance.

Any recommendation?

/Johnson

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 27 Nov 2014 08:53:50 +0100

> We are looking some third party tool to test NETCONF/YANG RFC compliance.

You can test data model compliance by saving protocol messages, such as replies to <get> or <get-config>, in a file and then use pyang for validating them. Here is a tutorial:

https://code.google.com/p/pyang/wiki/InstanceValidation

Lada

>  
> Any recommendation?
>  
> /Johnson
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C