Subject: [netmod] How to: partial support of YANG models

From: Johnson Zhu <[email-masked]>
Date: Wed, 12 Nov 2014 23:51:18 +0000

Hi,

If IETF YANG model becomes formal one (let's say OSPF), there will be good chance that vendor device cannot fully support all functions in OSPF YANG.

What the vendor should do with OSPF YANG model?

My thought is to use 'deviate' statement, but I am worried we abuse the meaning/power of 'deviate'.

Any other choice do we have?

Thanks
/Johnson

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 12 Nov 2014 14:00:34 -1000

On 12 Nov 2014, at 13:51, Johnson Zhu <[email-masked]> wrote:

> Hi,
>  
> If IETF YANG model becomes formal one (let’s say OSPF), there will be good chance that vendor device cannot fully support all functions in OSPF YANG.
>  
> My thought is to use ‘deviate’ statement, but I am worried we abuse the meaning/power of ‘deviate’.

Yes, vendors are extremely reluctant to admit they deviate from the standard.

> Any other choice do we have?

Andy addresses these issues in his draft:

draft-bierman-netmod-yang-conformance-04

Lada

>  
> Thanks
> /Johnson
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: [email-masked]
Date: Thu, 13 Nov 2014 08:48:17 +0800

I think you can use feature or deviation. If you don't support some 
features, these features should not be advertised in hello message. If you 
don't support some data nodes, or want
 to change the definition of data nodes, you can use deviation.

Frank Feng   冯冲
BN Product Team
BN产品团队

Add: ZTE Corporation, 50 Software Avenue, YuHuaTai District, Nanjing, P.R. 
China,210012
南京市雨花台区软件大道50号中兴通讯
Mp:+86-18913852612
E-mail: [email-masked]

"netmod" <[email-masked]> 写于 2014-11-13 07:51:18:

> Johnson Zhu <[email-masked]> 
> 发件人:  "netmod" <[email-masked]>
> 
> 2014-11-13 07:51
> 
> 收件人
> 
> "[email-masked]" <[email-masked]>, 
> 
> 抄送
> 
> 主题
> 
> [netmod]  How to: partial support of YANG models
> 
> Hi,
> 
> If IETF YANG model becomes formal one (let’s say OSPF), there will 
> be good chance that vendor device cannot fully support all functions
> in OSPF YANG.
> 
> /Johnson_______________________________________________
> netmod mailing list
> [email-masked]

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.