Subject: [netmod] current IETF91 Netmod Preliminary Agenda

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 4 Nov 2014 16:03:35 +0100

This is the current agenda I have to-date. Are there any other requests for discussion slots?

	--Tom

	Peer Mount Discussion/drafts 	15 min 	Eric Voit [email-masked]
	http://datatracker.ietf.org/doc/draft-voit-netmod-peer-mount-requirements/

	“Design Teams” update.  	10 min	[email-masked]

		o   List of all known “design teams” that are working on 
			YANG models (especially ones that may be 		
			progressing outside of the IETF mailing lists)
		
		o   Ideally a brief status update from one of the primary 
			leaders/contributors (i.e. a few bullet points / 1-2 minutes) 
			for each one (not to discuss the technical details of specific 
			models – that could be other agenda items)

	YANG conformance issues. 	10 min  Andy Bierman Andy Bierman <[email-masked]>
	http://www.ietf.org/id/draft-bierman-netmod-yang-conformance-04.txt

	draft-ietf-netmod-routing-cfg-16		5	Lada Lhotka [email-masked]
	draft-ietf-netmod-yang-json-01			5	Lada Lhotka [email-masked]
	draft-lhotka-netmod-yang-metadata-00		5	Lada Lhotka [email-masked]

	Dana Blair [email-masked]		
	Dean Bogdanovic [email-masked]		10	ACL Yang Model

	Mahesh Jethanandani [email-masked] 	10	BFD Yang Model

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 4 Nov 2014 17:36:20 +0100

Sorry for replying to my own post, but I forgot to mention this is an initial/draft agenda. Please comment/bash ASAP.

	--Tom

> On Nov 4, 2014:4:03 PM, at 4:03 PM, Thomas D. Nadeau <[email-masked]> wrote:
> 
>

---

From: Andy Bierman <[email-masked]>
Date: Tue, 4 Nov 2014 09:10:17 -0800

>         Sorry for replying to my own post, but I forgot to mention this is an initial/draft agenda. Please comment/bash ASAP.

I will bash....

It has been a tradition to discuss chartered work before
want-to-be-chartered work.
I see that is no longer the case. YANG "Peer Mount Requirements" is a
contentious
topic and will probably go over 15 minutes.  Is this discussion
limited to the YANG
language aspects or will the protocol aspects be on the agenda as well?

I notice YANG 1.1 is not on the agenda at all.
I know Martin and Juergen cannot be there, but we have
support for remote attendance and there are plenty of
open issues to discuss.

>         --Tom

Andy

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 4 Nov 2014 17:24:12 +0000

> From: netmod, November 04, 2014 12:10 PM
> >         Sorry for replying to my own post, but I forgot to mention this is an
> initial/draft agenda. Please comment/bash ASAP.
> 
> I will bash....
> 
> It has been a tradition to discuss chartered work before want-to-be-chartered
> work.
> contentious topic and will probably go over 15 minutes.  Is this discussion limited
> to the YANG language aspects or will the protocol aspects be on the agenda as
> well?

I agree 15 minutes might be insufficient.  I was hoping the agenda would hit the four related drafts.  Discussions should range from requirements, to protocols, to example YANG models.

  (1) Requirements for Peer Mounting of YANG subtrees from Remote Datastores
  draft-voit-netmod-peer-mount-requirements-01.txt

  (2) Mounting YANG-Defined Information from Remote Datastores 
  draft-clemm-netmod-mount-02.txt

  (3) Subscribing to datastore push updates
  draft-netmod-clemm-datastore-push-00.txt

  (4) Cloud SLA YANG Model incorporating Peer Mount Semantics
  draft-tripathy-cloud-sla-yang-model-00.txt
 
Tom, could you include these four drafts?   Both Alex and I will be in the room to split time on the discussions.

Thanks,
Eric

> I know Martin and Juergen cannot be there, but we have support for remote
> attendance and there are plenty of open issues to discuss.
> 
> 
> >
> >         --Tom
> 
> Andy
> 
> >
> >

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 4 Nov 2014 18:28:37 +0100

> On Nov 4, 2014, at 6:10 PM, Andy Bierman <[email-masked]> wrote:
> 

There are some in scope and some maybe-in-scope later parts of this. Les discuss how best to structure the discussion.

> support for remote attendance and there are plenty of

No one volunteered the section. Shall I put you down to lead the discussion ? ;)

Tom

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 4 Nov 2014 18:30:07 +0100

> Tom, could you include these four drafts?   Both Alex and I will be in the room to split time on the discussions.

Yes I meant to. We also have plenty of runway so we can give 15 min to each doc.

Tom

---

From: Benoit Claise <[email-masked]>
Date: Tue, 04 Nov 2014 18:30:26 +0100

> want-to-be-chartered work.
And that's still the right thing to do.

And btw, since the syslog YANG adopted has been accepted as WG document, 
this should be presented.

Regards, Benoit

---

From: Andy Bierman <[email-masked]>
Date: Tue, 4 Nov 2014 10:10:26 -0800

> No one volunteered the section. Shall I put you down to lead the discussion ? ;)

OK -- I will lead the YANG 1.1 discussion.
Instead of a hour on 4 YANG mount drafts on Thursday,
I suggest spending 30 - 45 minutes on the YANG 1.1
open issue list.

There is plenty of time on Friday to discuss unchartered work.

Andy

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 04 Nov 2014 18:36:27 +0000

Tom, the Thursday session is one hour long. The discussion of individual
design teams is 35 min. long not counting the time the chairs need to
agenda bashing and giving updates. Andy needs 10 min. for conformance and
30-45 min. to discuss YANG 1.1. Seems we need to divide up 1.1 discussion
between Thursday and Friday leaving whatever non-chartered work for any
remaining time.

On Tue Nov 04 2014 at 10:10:37 AM Andy Bierman <[email-masked]> wrote:

> >>>        Sorry for replying to my own post, but I forgot to mention this
> is an initial/draft agenda. Please comment/bash ASAP.
> >>
> >> I will bash....
> >>
> > There are some in scope and some maybe-in-scope later parts of this. Les
> discuss how best to structure the discussion.
> >
> >
> >>

---

From: Andy Bierman <[email-masked]>
Date: Tue, 4 Nov 2014 10:57:30 -0800

Hi,

It is 1640 - 1910 : 2.5 hours

None of these design teams working on NETMOD chartered drafts.
IMO we should be focusing on finishing chartered NETMOD work.

I don't agree these IETF WG meetings should be slideware forums to
promote anything related to YANG.  (There should be a meeting slot for
this sort of thing -- something between a Bar Bof and a real BoF).

Andy

On Tue, Nov 4, 2014 at 10:36 AM, Mahesh Jethanandani
<[email-masked]> wrote:
> design teams is 35 min. long not counting the time the chairs need to agenda
> bashing and giving updates. Andy needs 10 min. for conformance and 30-45
> min. to discuss YANG 1.1. Seems we need to divide up 1.1 discussion between
> Thursday and Friday leaving whatever non-chartered work for any remaining
> time.
>

---

From: "Aseem Choudhary (asechoud)" <[email-masked]>
Date: Tue, 4 Nov 2014 22:55:37 +0000

Hi Tom

We need 10 minutes to present Diffserv yang model:

http://tools.ietf.org/html/draft-asechoud-netmod-diffserv-model-00.txt

-thanks,
Aseem Choudhary
Shitanshu Shah

On 11/4/14, 7:03 AM, "Thomas D. Nadeau" <[email-masked]> wrote:

>	³Design Teams² update.  	10 min	[email-masked]
>
>		o   List of all known ³design teams² that are working on
>			models  that could be other agenda items)
>

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Wed, 5 Nov 2014 14:15:52 +0000

Hi guys,

When I suggested the "Design Team Update" agenda item I didn't realize there were quite so many YANG models out there.   Having any sort of verbal update for these isn't going to make sense given the number of them.   We should probably drop that from the agenda.    At this point it seems that people will have to follow the models they are interested in in the appropriate WGs.

Jason

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Tuesday, November 04, 2014 11:36 AM
To: NETMOD Working Group
Cc: [email-masked]
Subject: Re: [netmod] current IETF91 Netmod Preliminary Agenda

	--Tom