Subject: [netmod] Fwd: New Version Notification for draft-lhotka-netmod-yang-annotations-00.txt

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 28 Nov 2014 14:36:09 +0100

Hi,

this draft contains the module “ietf-yang-annotations” that is intended to contain definitions of generally useful metadata annotations. I included two annotations that I think might be handy. If you know about others, please let me know.

Thanks, Lada

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-lhotka-netmod-yang-annotations-00.txt
> Date: 28 Nov 2014 14:31:57 GMT+1
> To: Ladislav Lhotka <[email-masked]>, "Ladislav Lhotka" <[email-masked]>
> 
> 
> A new version of I-D, draft-lhotka-netmod-yang-annotations-00.txt
> has been successfully submitted by Ladislav Lhotka and posted to the
> IETF repository.
> 
> Name:		draft-lhotka-netmod-yang-annotations
> Revision:	00
> Title:		Common Metadata Annotations for Data Modelled with YANG
> Document date:	2014-11-28
> Group:		Individual Submission
> Pages:		9
> URL:            http://www.ietf.org/internet-drafts/draft-lhotka-netmod-yang-annotations-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-lhotka-netmod-yang-annotations/
> Htmlized:       http://tools.ietf.org/html/draft-lhotka-netmod-yang-annotations-00
> 
> 
> Abstract:
>   This document introduces a collection of common metadata annotations
>   intended for use in data modeled with the YANG language.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Sun, 30 Nov 2014 08:45:56 -0800

Hi,

This draft defines 2 annotations: "inactive" and "type".
I am strongly opposed to the "inactive" annotation.
The "Conditional Enablement" draft by Kent Watsen should
be used for this purpose.  This topic is more complicated than
just defining an "inactive" flag.

The "type" annotation seems useless because the YANG parser
decides what internal type gets assigned to a union.
Sending the types inside the instance document is normally
only done if there is no schema.

Andy

On Fri, Nov 28, 2014 at 5:36 AM, Ladislav Lhotka <[email-masked]> wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod