Subject: Re: [netmod] Fwd: I-D Action: draft-ietf-netmod-routing-cfg-16.txt

From: Benoit Claise <[email-masked]>
Date: Tue, 04 Nov 2014 17:56:59 +0100

Hi Lada,

Thanks for that. So you will be presenting this draft in NETMOD.
But also routing? Including the two routing ADs, just in case...

Regards, Benoit
> Hi,
>
> this revision of the routing draft is a result of synchronisation with the group of routing experts working on the OSPF and ISIS modules.
>
> The sources for the draft, YANG modules and examples are available from this GitHub repo:
>
> https://github.com/yang-routing/yang-routing
>
> Lada
>
> Begin forwarded message:
>
>> From: [email-masked]
>> Subject: [netmod] I-D Action: draft-ietf-netmod-routing-cfg-16.txt
>> Date: 26 Oct 2014 16:28:58 GMT+1
>> To: [email-masked]
>> Cc: [email-masked]
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.
>>
>>         Title           : A YANG Data Model for Routing Management
>>         Author          : Ladislav Lhotka
>> 	Filename        : draft-ietf-netmod-routing-cfg-16.txt
>> 	Pages           : 88
>> 	Date            : 2014-10-26
>>
>> Abstract:
>>    This document contains a specification of three YANG modules.
>>    Together they form the core routing data model which serves as a
>>    framework for configuring and managing a routing subsystem.  It is
>>    expected that these modules will be augmented by additional YANG
>>    modules defining data models for routing protocols and other
>>    functions.  The core routing data model provides common building
>>    blocks for such extensions - routing instances, routes, routing
>>    information bases (RIB), routing protocols and route filters.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-netmod-routing-cfg/
>>
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-ietf-netmod-routing-cfg-16
>>
>> A diff from the previous version is available at:
>> http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-routing-cfg-16
>>
>>
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod
> --
> Ladislav Lhotka, CZ.NIC Labs
> PGP Key ID: E74E8C0C
>
>
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
> .
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 5 Nov 2014 08:39:23 +0100

Hi Benoit,

Alia suggested to have a discussion in rtgwg led not only by me but also by routing folks who have reviewed the draft. I am fine with that, and Alvaro Retana promised to ask some of said folks to get in touch with me, but I haven’t heard from anybody yet.

In any case, I am going to prepare a short presentation about the routing module - I don’t want to just recycle the one I have for NETMOD because I think the focus have to be on general design and not on YANG specifics.

Cheers, Lada

---

From: Benoit Claise <[email-masked]>
Date: Wed, 05 Nov 2014 08:52:50 +0100

Hi Lada,

You're right. At this point in time, the backing from the routing 
experts is more important.

Regards, Benoit

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 5 Nov 2014 09:46:23 +0100

> In any case, I am going to prepare a short presentation about the routing module - I don’t want to just recycle the one I have for NETMOD because I think the focus have to be on general design and…

Lada,

what I like to get out of the meeting is a concrete list of issues
people still have with building concrete data models based on the core
routing model. If no concrete issues are left, we should do another WG
last call and send the document back to the IESG. In other words, I
expect that routing people writing BGP, OSPF, ... data models will
actually drive the discussion by telling us what they believe is still
missing or not workable.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 5 Nov 2014 10:01:32 +0100

> actually drive the discussion by telling us what they believe is still

Yes, I have similar expectations. I can perhaps contribute my impressions from looking over the shoulders of the routing people, and also try to explain the design choices.

Lada

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 5 Nov 2014 10:53:15 +0100

> Yes, I have similar expectations. I can perhaps contribute my impressions from looking over the shoulders of the routing people, and also try to explain the design choices.

My understanding is that the routing discussion is Tuesday 13:00 HST
and ideally there would be results coming out of this meeting to
quickly report to the NETMOD WG at large.

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 5 Nov 2014 12:18:49 +0100

> quickly report to the NETMOD WG at large.

No, it is on the agenda of rtgwg on Wednesday, 9:00:

https://datatracker.ietf.org/meeting/91/agenda/rtgwg/

I will report on the outstanding issues at the NETMOD meeting on Thursday.

Lada