Subject: Re: [netmod] namespace encoding in draft-ietf-netmod-yang-json-02

From: Randy Presuhn <[email-masked]>
Date: Thu, 11 Dec 2014 10:55:53 -0800 (GMT-08:00)

Hi -

>From: Andy Bierman <[email-masked]>
>Sent: Dec 11, 2014 7:50 AM
>To: Martin Bjorklund <[email-masked]>
>Cc: "[email-masked]" <[email-masked]>
>Subject: Re: [netmod] namespace encoding in draft-ietf-netmod-yang-json-02
...
>I can see SHOULD but not MUST for suppressing redundant prefixes.
>Otherwise the receiver MUST reject input it actually understands,
>and that is fragile.

I agree.  RFC 2119 is instructive:
   Imperatives of the type defined in this memo must be used with care
   and sparingly.  In particular, they MUST only be used where it is
   actually required for interoperation or to limit behavior which has
   potential for causing harm (e.g., limiting retransmisssions)  For
   example, they must not be used to try to impose a particular method
   on implementors where the method is not required for 
   interoperability.

Randy

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 12 Dec 2014 09:33:57 +0100

> On 11 Dec 2014, at 19:55, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 

I think SHOULD would be fine as it conveys the message that it is desirable to suppress redundant prefixes where possible.

Thanks, Lada

> 
> Randy
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C