Subject: [netmod] Fw: New Version Notification for draft-bjorklund-yang-conformance-problem-01.txt

From: Martin Bjorklund <[email-masked]>
Date: Wed, 18 Feb 2015 21:46:49 +0100 (CET)

Hi,

I have updated this draft after the ML and VM discussions today.

I have not added anything about a "module compliance"-like solution.
I think such a solution is mostly orthogonal to the issues described
in this draft; it seems more like a replacement for the
"feature/if-feature" statements.  But it would be very useful if
someone could describe such a solution!

/martin

Subject: New Version Notification for draft-bjorklund-yang-conformance-problem-01.txt
From: [email-masked]
To: "Martin Bjorklund" <[email-masked]>, "Martin Bjorklund" <[email-masked]>
Date: Wed, 18 Feb 2015 12:42:53 -0800

A new version of I-D, draft-bjorklund-yang-conformance-problem-01.txt
has been successfully submitted by Martin Bjorklund and posted to the
IETF repository.

Name:		draft-bjorklund-yang-conformance-problem
Revision:	01
Title:		The YANG Conformance Problem
Document date:	2015-02-18
Group:		Individual Submission
Pages:		13
URL:            http://www.ietf.org/internet-drafts/draft-bjorklund-yang-conformance-problem-01.txt
Status:         https://datatracker.ietf.org/doc/draft-bjorklund-yang-conformance-problem/
Htmlized:       http://tools.ietf.org/html/draft-bjorklund-yang-conformance-problem-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-bjorklund-yang-conformance-problem-01

Abstract:
   This document describes the YANG conformance problem.  It is intended
   as a temporary document to help the NETMOD WG in the design of YANG
   1.1.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Qi Sun <[email-masked]>
Date: Fri, 20 Feb 2015 15:03:07 +0100

Hi Martin, 

I’ve read this draft and have some (minor) language related comments. (Maybe because I’m a non-English speaker.)

3.2.1. Solution P1a-01

  Fix the type and grouping when using import-by revision.  In this
  case, it is clear what the types of leaf b and c are, and /b2/y is
  not supported, but /c2/y is.

[Qi] I think “Fix the type and grouping when using import-by revision.” means that “When using import-by revision, the typedef and grouping should be bound to that specific imported revision”, right? I mistakenly thought the word “fix” had the same meaning as in “fix a bug”.

Isn’t this the current practice?

3.4. Problem P2: Conformance Ambiguity
….
    module mod-f {
      ...
      revision 2001-04-01;
      import mod-a {
        prefix a;
        revision-date 2001-01-01;    // uses initial vsn of mod-e
      }
      augment /a:x { ... }
    }
     module mod-g {
      ...
      revision 2002-04-01;          // uses new vsn of mod-e
      import mod-e {
        prefix e;
        revision-date 2002-01-01;
      }
      augment /e:y { ... }
    }

[Qi] I think the intension here is to import “mod-e” instead of “mod-a”? And augment /e:x { … } ?
The comment “// uses new vsn of mod-e” should be placed 3 lines down?

3.7.2. Solution P5-02

   Do nothing.  This is an educational issue.  Make sure generic
  containers like this "system" do not require the implementation of
  many other nodes.

[Qi] I suppose the wording here means: Make sure generic
  containers like this "system" do not contain many other nodes that require
  to be implemented besides the augmented nodes if any.

Hope it helps.

Cheers,
Qi

On Feb 18, 2015, at 9:46 PM, Martin Bjorklund <[email-masked]> wrote:

> Date: February 18, 2015 at 9:42:53 PM GMT+1
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 20 Feb 2015 22:57:49 +0100 (CET)

Qi Sun <[email-masked]> wrote:
> Hi Martin, 
> 
> I’ve read this draft and have some (minor) language related
> comments. (Maybe because I’m a non-English speaker.)
> 
> 3.2.1. Solution P1a-01
> 
> [Qi] I think “Fix the type and grouping when using import-by
> revision.” means that “When using import-by revision, the typedef and
> grouping should be bound to that specific imported revision”, right?

Yes you're right.  Bad wording.

> I
> mistakenly thought the word “fix” had the same meaning as in “fix a
> bug”.
> 

No.  I think it differs across implementations.

> The comment “// uses new vsn of mod-e” should be placed 3 lines down?

Yes, this is a typo.

>   to be implemented besides the augmented nodes if any.

Right.

> Hope it helps.

Thanks for your comments!

/martin

> > Subject: New Version Notification for
> > draft-bjorklund-yang-conformance-problem-01.txt
> > URL:
> > http://www.ietf.org/internet-drafts/draft-bjorklund-yang-conformance-problem-01.txt
> > Status:
> > https://datatracker.ietf.org/doc/draft-bjorklund-yang-conformance-problem/
> > Htmlized:
> > http://tools.ietf.org/html/draft-bjorklund-yang-conformance-problem-01
> > Diff:
> > http://www.ietf.org/rfcdiff?url2=draft-bjorklund-yang-conformance-problem-01
> > 
> > Abstract: