Subject: [netmod] question about feature statements in <hello> message

From: [email-masked]
Date: Fri, 6 Feb 2015 16:27:20 +0800

Hi, everyone

I'm new to netmod/YANG, and I have a question about feature in <hello> 
message

Example :

 M1               M2
 |                |
 |---prefix m1    |--- import M1
 |                |      |
                  |      |--- prefix m1
 |                |
 |---feature a    |--- feature b
                         |
                         |--- if-feature m1:a

M1 and M2 both are yang modules and m2 'import' m1

if Agent doesn't support feature a, but support feature b

then how about the feature messages in <hello> from Agent?

solution 1:
        contain 'feature b' in <hello> from Agent

solution 2:
        Agent automatically filter out 'feature b' because its 'if-feature 
m1:a' statement doesn't support

----------------------------------------
  如有问题，请及时联系！
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 6 Feb 2015 09:44:07 +0100

> m1:a' statement doesn't support

If feature b depends on feature a, then the agent must support (and
hence accounce) feature a when it supports b. So either the agent is
broken (if it does b without a) or the data model is broken (since it
requires a for b even though it is possible to have b without a).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>