Subject: Re: [netmod] yang-json document

From: Randy Presuhn <[email-masked]>
Date: Fri, 6 Feb 2015 11:09:53 -0800 (GMT-08:00)

Hi -

>From: Andy Bierman <[email-masked]>
>Sent: Feb 6, 2015 8:00 AM
>To: Ladislav Lhotka <[email-masked]>
>Cc: Randy Presuhn <[email-masked]>, "[email-masked]" <[email-masked]>
>Subject: Re: [netmod] yang-json document
...
>There is the possibility that a future release of the server will add a module
>that has a top-level data node with the same local-name.  In this case,
>the old client will break.  I have not seen any vendors want to do this.
>
>IMO, SHOULD use the top-level prefix is appropriate, not MUST.

Actually, the case you just described convincingly makes the case
for "MUST" by demonstrating how a permitted (if unwise) deployment /
implementation decision would lead to a non-interoperable (rather
than merely inefficient) situation.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Fri, 6 Feb 2015 11:24:41 -0800

> than merely inefficient) situation.

In theory this is a problem.
In reality, 2 top-level foo objects are never exactly the same.
In almost all cases there will never be a top-level name collision,
and the server knows "interfaces" means the one and only object
named "interfaces".   If our server started rejecting input like this,
then customers would complain.  IMO namespaces should not
get in the way, if possible.

But I can see how the IETF will see this differently and force
everybody to design for maximum interoperability.

> Randy

Andy

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod