Subject: Re: [netmod] [Technical Errata Reported] RFC6020 (4282)

From: Benoit Claise <[email-masked]>
Date: Fri, 06 Mar 2015 14:36:39 +0100

Cesar,

Provide me the exact new text, and I'll cut and paste in the errata.

Regards, Benoit
> There is a problem with this errata due to a paste problem (parentheses
> got stripped out). Where it reads
>
> *unknown_statement2 optsep
>
> It should read
>
> *(unknown_statement2 optsep)
>
> Thanks,
>
>
> - Cesar
>
> On 2/27/15, 10:41 AM, "RFC Errata System" <[email-masked]>
> wrote:
>
>> The following errata report has been submitted for RFC6020,
>> "YANG - A Data Modeling Language for the Network Configuration Protocol
>> (NETCONF)".
>>
>> --------------------------------------
>> You may review the report below and at:
>> http://www.rfc-editor.org/errata_search.php?rfc=6020&eid=4282
>>
>> --------------------------------------
>> Type: Technical
>> Reported by: Cesar Crusius <[email-masked]>
>>
>> Section: 12
>>
>> Original Text
>> -------------
>> unknown-statement   = prefix ":" identifier [sep string] optsep
>>                       (";" / "{" *unknown-statement2 "}")
>> unknown-statement2   = [prefix ":"] identifier [sep string] optsep
>>                       (";" / "{" *unknown-statement2 "}")
>>
>>
>> Corrected Text
>> --------------
>> unknown-statement   = prefix ":" identifier [sep string] optsep
>>                       (";" / "{" optsep *unknown-statement2 optsep "}")
>> unknown-statement2   = [prefix ":"] identifier [sep string] optsep
>>                       (";" / "{" optsep *unknown-statement2 optsep "}")
>>
>>
>> Notes
>> -----
>>
>>
>> Instructions:
>> -------------
>> This erratum is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party (IESG)
>> can log in to change the status and edit the report, if necessary.
>>
>> --------------------------------------
>> RFC6020 (draft-ietf-netmod-yang-13)
>> --------------------------------------
>> Title               : YANG - A Data Modeling Language for the Network
>> Configuration Protocol (NETCONF)
>> Publication Date    : October 2010
>> Author(s)           : M. Bjorklund, Ed.
>> Category            : PROPOSED STANDARD
>> Source              : NETCONF Data Modeling Language
>> Area                : Operations and Management
>> Stream              : IETF
>> Verifying Party     : IESG
>>

---

From: "Cesar Crusius (ccrusius)" <[email-masked]>
Date: Fri, 6 Mar 2015 15:53:34 +0000

Hi Benoit,

For 4282, the new text should be

unknown-statement   = prefix ":" identifier [sep string] optsep
                    (";" / "{" optsep *(unknown-statement2 optsep) "}")
unknown-statement2   = [prefix ":"] identifier [sep string] optsep
                     (";" / "{" optsep *(unknown-statement2 optsep) "}")

Best,

- Cesar

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 11 Mar 2015 09:00:00 +0100 (CET)

Hi,

>                      (";" / "{" optsep *(unknown-statement2 optsep) "}")

This errata can be accepted.

In draft-ietf-netmod-rfc6020bis this rule has been rewritten a bit.

/martin