Subject: [netmod] [Technical Errata Reported] RFC6020 (4292)

From: RFC Errata System <[email-masked]>
Date: Sat, 7 Mar 2015 09:45:34 -0800 (PST)

The following errata report has been submitted for RFC6020,
"YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6020&eid=4292

--------------------------------------
Type: Technical
Reported by: Cesar Crusius <[email-masked]>

Section: 12

Original Text
-------------
   type-stmt           = type-keyword sep identifier-ref-arg-str optsep
                         (";" /
                          "{" stmtsep
                              type-body-stmts
                          "}")

Corrected Text
--------------
   type-stmt           = type-keyword sep identifier-ref-arg-str optsep
                         (";" /
                          "{" stmtsep
                              [ type-body-stmts ]
                          "}")

Notes
-----
Every statement that can end with a single ';' should also accept ending with '{ stmtsep }' (that is what the 'stmtend' rule implies). This is the only instance I found so far of a statement that does not follow this rule.

The other option would be to replace all ";" in rules like that with 'stmtend'.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6020 (draft-ietf-netmod-yang-13)
--------------------------------------
Title               : YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)
Publication Date    : October 2010
Author(s)           : M. Bjorklund, Ed.
Category            : PROPOSED STANDARD
Source              : NETCONF Data Modeling Language
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Andy Bierman <[email-masked]>
Date: Sat, 7 Mar 2015 10:27:27 -0800

Hi,

I just confirmed that both pyang and yangdump-pro accept "type string {}"
instead of "type string;"

This is because every single place that ";" could be used,
a sub-section of extension statements could be present instead.

Andy

On Sat, Mar 7, 2015 at 9:45 AM, RFC Errata System
<[email-masked]> wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Sat, 07 Mar 2015 20:23:35 +0100 (CET)

> "YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)".

This is ok.  I will fix it also in draft-ietf-netmod-rfc6020bis-04.

/martin