Subject: [netmod] syslog-model-03: Severity enum values vs identity

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Fri, 27 Mar 2015 00:27:52 +0000

Hi all,

Should we consider removing the enum values (if we want to keep this as an enum) ?  Those are values that are only visible when they are used to encode severity when sending to a remote syslog receiver and I'm not sure if those should really be in the config model. There has also been some debate about the use of enum values in general in netmod (considered removing that from the YANG language altogether).

It may also be useful to change the severity enum to a set of identities.  That leaves it a bit more flexible for potential augmentation.

We should add a description that clarifies/defines what "increasing severity" is (since that is the default for how severity 'matches' in the selector/filter.  i.e. say that the order of severity amongst the values is the following in increasing severity order: debug (least severe)->info...->emergency(most severe).

Perhaps reference RFC 5424 again here like is done in the facility identities.

Regards,
Jason

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 27 Mar 2015 02:15:13 +0100

> Should we consider removing the enum values (if we want to keep this as an enum) ?  Those are values that are only visible when they are used to encode severity when sending to a remote syslog rece…

Removing enums from YANG was never a concrete proposal.
 
> Perhaps reference RFC 5424 again here like is done in the facility identities.

My understanding is that severity values are limited due to the way
the protocol works and hence making them extensible in the
configuration data model may not really be meaningful. Am I missing
something?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>