Subject: Re: [netmod] Y45 - imports

From: Randy Presuhn <[email-masked]>
Date: Mon, 23 Mar 2015 15:12:09 -0700 (GMT-07:00)

Hi -

>From: Ladislav Lhotka <[email-masked]>
>Sent: Mar 23, 2015 2:51 PM
>To: NETMOD Working Group <[email-masked]>
>Subject: [netmod] Y45 - imports
>
>Hi,
>
>as a follow-up to today’s discussion about Y45, I propose the following change to the semantics of imports:
>
>Sec. 7.1.5:
>
>OLD
>
>   When the optional "revision-date" substatement is present, any
>   typedef, grouping, extension, feature, and identity referenced by
>   definitions in the local module are taken from the specified revision
>   of the imported module.  It is an error if the specified revision of
>   the imported module does not exist.  If no "revision-date"
>   substatement is present, it is undefined from which revision of the
>   module they are taken.
>
>NEW
>
>   When the optional "revision-date" substatement is present, all
>   typedefs and groupings referenced by definitions in the local module
>   are taken from the specified revision of the imported module. It is
>   an error if the specified revision of the imported module does not exist.
>   If no "revision-date” substatement is present, they are taken from the highest
>   revision of the imported module that is less or equal to the revision
>   of the importing module.
...

Just to be clear:

  (1) this is an admission that a server may end up implement multiple
      revisions of an imported module.  (Could happen when importing
      modules have different dates...)

  (2) "highest revision of the imported module" means the highest
      revision *known* *to* *the* *server*; there may be other ones
      out there, but only the ones the server is aware of count.

Randy

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 23 Mar 2015 17:26:24 -0500

> On 23 Mar 2015, at 17:12, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 
>      modules have different dates…)

Yes, and I think it is better than admitting ripple efects caused by updating the imported module.

>      out there, but only the ones the server is aware of count.

For IETF-published modules this should’t be an issue, and in any case it might be advisable to always use “revision-date”.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C