Subject: [netmod] [Editorial Errata Reported] RFC6020 (4291)

From: RFC Errata System <[email-masked]>
Date: Sat, 7 Mar 2015 09:40:19 -0800 (PST)

The following errata report has been submitted for RFC6020,
"YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6020&eid=4291

--------------------------------------
Type: Editorial
Reported by: Cesar Crusius <[email-masked]>

Section: 12

Original Text
-------------
   deviate-not-supported-stmt =
                         deviate-keyword sep
                         not-supported-keyword optsep
                         (";" /
                          "{" stmtsep
                          "}") 

Corrected Text
--------------
   deviate-not-supported-stmt =
                         deviate-keyword sep
                         not-supported-keyword
                         stmtend

Notes
-----
The rule is not incorrect, but unnecessarily replicates 'stmtend' within it.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6020 (draft-ietf-netmod-yang-13)
--------------------------------------
Title               : YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)
Publication Date    : October 2010
Author(s)           : M. Bjorklund, Ed.
Category            : PROPOSED STANDARD
Source              : NETCONF Data Modeling Language
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Bjorklund <[email-masked]>
Date: Sat, 07 Mar 2015 20:22:34 +0100 (CET)

> "YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)".

This is already fixed in the upcoming
draft-ietf-netmod-rfc6020bis-04.

Since this is not really a bug, I don't know if it is worth the effort
to accept this errata.

/martin