Subject: [netmod] review of draft-openconfig-netmod-model-structure-00

From: Kent Watsen <[email-masked]>
Date: Thu, 18 Jun 2015 01:24:13 +0000

[As an individual contributor]

In preparing to tomorrow's virtual interim meeting, I reread the
model-structure draft with an eye towards understanding the problem
statements.  So far as I can tell, there are four problem statements:

 1: disparate models exist without guidance how they stitch
    together 

 2: some uber modules, importing many other modules, exist
    but are incomplete

 3: a multi-rooted tree that does not follow any logical
    construction is difficult to work with operationally

 4: no model catalog/registry is available to discover models

My issue with these problem statements is that they are provided without
clear examples illustrating the actual problems.  Some references to
drafts are provided, but it's left to the reader to determine what the
problems are.  For instance,

 - for (1), RFCs 7223 and 7317 are provided as an example, but
   without explanation.  Is the issue that interfaces defined
   in 7223 would be used by the NTP server defined in 7317?
 
 - for (2), drafts-ietf-netmod-routing-cfg is provided as an
   example.   Looking at it, I see that YANG module
   ietf-ipv6-unicast-routing imports a number of other modules,
   but it's not clear why there is an expectation that it
   should be any more than it is.

 - for (3), RFCs 7223 and 7277 are provided as an example,
   which I found confusing as 7277 actually augments 7223.
   But it may be that this example was meant to highlight
   a rare case where a good thing occurred (the text isn't
   clear and, if so, a read it wrong the first time)

Interestingly, Section 4.2 (service-layer composition) describes what I
view to be the expected solution to many of these issues, and yet it's not
described as such.  This implies that there may be yet another problem
statement missing in my list above.

Thanks,
Kent

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 18 Jun 2015 14:24:12 +0200

Hi Kent,

>  2: some uber modules, importing many other modules, exist

To be fair, the draft doesn't say this. In the particular case of
[RTG-CFG], it is expected that a number of other modules will import
(and augment) ietf-routing, so it is the other way around.

Otherwise I agree with your assessment.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Qin Wu <[email-masked]>
Date: Thu, 18 Jun 2015 13:33:37 +0000

Hi, Kent:
-----邮件原件-----
>发件人: netmod [mailto:[email-masked]] 代表 Kent Watsen
>发送时间: 2015年6月18日 9:24
>收件人: [email-masked]
>主题: [netmod] review of draft-openconfig-netmod-model-structure-00
>
>
>In preparing to tomorrow's virtual interim meeting, I reread the model-structure draft with an eye towards understanding the problem statements.  So far as I can tell, there are four problem 
>statements:
>
>My issue with these problem statements is that they are provided without clear examples illustrating the actual problems.  Some references to drafts are provided, but it's left to the reader to 
>determine what the problems are.  For instance,
>

Interestingly, Section 4.2 (service-layer composition) describes what I view to be the expected solution to many of these issues, and yet it's not described as such.  

[Qin]: service layer composition follows top down approach, another approach is bottom up approach or map network technology specific model to technology independent model, what model structure draft proposed solution, in my understanding, is pull vs push approaches discussed in the section 3, one example for pull vs push approach, I think is
drafts-ietf-netmod-routing-cfg follows push approach while draft-shaikh-idr-bgp-model-02 follows pull approach, I am wondering how to come up hybrid construction which combines both approaches. But it will be interesting to see that happen.

This implies that there may be yet another problem statement missing in my list above.

[Qin]: Another problem statement is linking to l3sm work and YANG classification work.