Subject: [netmod] YANG repo syntax issues

From: Andy Bierman <[email-masked]>
Date: Sat, 13 Jun 2015 08:13:37 -0700

Hi,

I was checking our compiler against the yang repo directory "standard",
and these errors and warnings showed up. Error 250 is
sometimes a false positive, but these expressions should
be checked.

Top-level mandatory nodes (which include mandatory
nodes in NP-containers) are not allowed in IETF modules
according to RFC 6087.

Andy

Error: object 'active-route' not found in module ietf-routing in Xpath
target /rt:active-route/rt:output/rt:route
ietf-isis.yang:240.5: error(250): definition not found

*** /home/andy/swdev/YANG_GIT/yang/standard/ietf/DRAFT/ietf-isis.yang
*** 1 Errors, 0 Warnings

Error: object 'access-list' not found in module ietf-acl in Xpath target
/ietf-acl:access-list/ietf-acl:access-list-entries/ietf-acl:matches
newco-acl.yang:16.5: error(250): definition not found

Error: object 'access-list' not found in module ietf-acl in Xpath target
/ietf-acl:access-list/ietf-acl:access-list-entries/ietf-acl:actions
newco-acl.yang:28.5: error(250): definition not found

*** /home/andy/swdev/YANG_GIT/yang/standard/ietf/DRAFT/newco-acl.yang
*** 2 Errors, 0 Warnings

Warning: top-level NP container 'syslog' is mandatory
ietf-syslog.yang:238.3: warning(1048): top-level object is mandatory

*** /home/andy/swdev/YANG_GIT/yang/standard/ietf/DRAFT/ietf-syslog.yang
*** 0 Errors, 1 Warnings

Warning: top-level NP container 'configlet' is mandatory
ietf-netconf-zerotouch.yang:50.3: warning(1048): top-level object is
mandatory

***
/home/andy/swdev/YANG_GIT/yang/standard/ietf/DRAFT/ietf-netconf-zerotouch.yang
*** 0 Errors, 1 Warnings

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 15 Jun 2015 13:30:03 +0200

> *** /home/andy/swdev/YANG_GIT/yang/standard/ietf/DRAFT/ietf-isis.yang

The ietf-isis module is out of sync with ietf-routing.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Nadeau Thomas <[email-masked]>
Date: Mon, 15 Jun 2015 08:23:38 -0400

Can you post this in the messages/discussion on Git?  I will also chase down fixing this warning.

	—Tom

> On Jun 13, 2015:11:13 AM, at 11:13 AM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> Error: object 'active-route' not found in module ietf-routing in Xpath target /rt:active-route/rt:output/rt:route
> Error: object 'access-list' not found in module ietf-acl in Xpath target /ietf-acl:access-list/ietf-acl:access-list-entries/ietf-acl:matches
> Error: object 'access-list' not found in module ietf-acl in Xpath target /ietf-acl:access-list/ietf-acl:access-list-entries/ietf-acl:actions
> ietf-netconf-zerotouch.yang:50.3: warning(1048): top-level object is mandatory
> 
> *** /home/andy/swdev/YANG_GIT/yang/standard/ietf/DRAFT/ietf-netconf-zerotouch.yang
> *** 0 Errors, 1 Warnings
> 
> 
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 15 Jun 2015 14:30:14 +0200

> On 15 Jun 2015, at 14:23, Nadeau Thomas <[email-masked]> wrote:
> 
> 

I don’t think it is an error or problem that needs to be fixed. The drafts are being developed by different WGs with their own schedules. The next revision of draft-ietf-isis-yang-isis-cfg will be aligned with ietf-routing again.

Lada