Subject: Re: [netmod] [Rtg-yang-coord] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Wed, 1 Jul 2015 09:27:35 +0000

Hello Susan,
-          Topology model which is a composite of:
o   Generic topology model: draft-ietf-i2rs-yang-network-topo-01<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/>
o   L3 topology model: draft-ietf-i2rs-yang-l3-topology-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/>
o   L2 topology model: draft-ietf-i2rs-yang-l2-network-topology-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/>
o   L1 Topology model: draft-zhang-i2rs-l1-topo-yang-model-01 (-02 released later this week).
o   Service topology model: draft-hares-i2rs-service-topo-yang-model-00 (released on Wednesday)

At this time, none of the Topology models utilize Traffic engineering.  It is anticipated that these models will support traffic engineering.

Reading this , my question is whether there is intention for Traffic Engineering part of topology model to exploit/coordinate with Teas , and particularly with
 draft-liu-teas-yang-te-topo or to proceed with distinct contributions internal to I2RS.

Thanks
Sergio

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 2 Jul 2015 14:06:00 -0700

> On Jun 30, 2015, at 3:13 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 
> What might be interesting for a NETCONF speaking slot is an analysis of what requirements from “draft-ietf-i2rs-pub-sub-requirements” are met by “draft-clemm-netconf-yang-push”. 

Susan or somebody from i2rs WG can decide whether the suggested presentation would help clarify i2rs requirements to NETCONF. From a personal perspective it would certainly help to have examples of how the requirements could be met.

Cheers.

Mahesh Jethanandani
[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 2 Jul 2015 17:06:41 -0400

Mahesh: 

I think this would really help show how the requirements can be met. Let’s plan on Eric doing an analysis of what requirements are met by “draft-clemm-netconf-yang-push”. 

Sue 

From: i2rs [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: Thursday, July 02, 2015 5:06 PM
To: Eric Voit (evoit)
Cc: [email-masked]; [email-masked]; NETMOD Working Group; BRUNGARD, DEBORAH A; Alexander Clemm (alex); Netconf; Susan Hares
Subject: Re: [i2rs] [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Cheers.

Mahesh Jethanandani

[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 2 Jul 2015 17:35:04 -0400

Mahesh: 

I’m trying to schedule a set of meeting before I2RS presents at NETCONF so it would be helpful to know when the I2RS session would be schedule in NETCONF. 

Is I2RS requirements presentation at the Tuesday meeting with Netconf [15:20 – 17:20] which is just before the I2RS meeting [17:40- 18:40].  This back-to-back session would allow us to encourage people to hear the presentations in NETCONF and then come to I2RS to discuss any open issues for I2RS.  

Do you think we should present the NETMOD requirements before the NETCONF requirements?  I can request a brief presentation in NETMOD.  I am working on a draft to express I2RS requirements for netmod.  The requirements for NETMO will not be an I2RS WG document – only a chair’s observations on the differences between the yang modules. 

Sue Hares 

 

Cheers.

Mahesh Jethanandani

[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 3 Jul 2015 15:39:23 -0400

Sergio: 

Just in case you missed in the rest of the email threads: 

Yes – I2RS plans to coordinate the topology model with the TEAS Topology model.  The work began with the authors last week, and will continue in a discussion of the TEAS And Topology authors next week (7/8)  in a conference call, and at IETF on Sunday (7/19 from 6-7pm). 

The I2RS WG will provide an update on the merging of these two models.  If you are a TEAS author, please let me know.   If you wish to help on an I2RS Topology model, the I2RS working group would appreciate your review of any model. 

I am personally working on the service layer model. 

Sue Hares 

From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
Sent: Wednesday, July 01, 2015 5:28 AM
To: Susan Hares; 'Mahesh Jethanandani'
Cc: [email-masked]; [email-masked]; 'NETMOD Working Group'; 'Netconf'; 'BRUNGARD, DEBORAH A'
Subject: RE: [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Hello Susan,

o   Generic topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/> draft-ietf-i2rs-yang-network-topo-01 

o   L3 topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/> draft-ietf-i2rs-yang-l3-topology-00 

o   L2 topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/> draft-ietf-i2rs-yang-l2-network-topology-00 

Thanks

Sergio