Subject: [netmod] new YANG 1.1 Issue Y62: YANG should not be NETCONF-specific

From: Andy Bierman <[email-masked]>
Date: Sat, 25 Jul 2015 17:26:16 -0700

Hi,

The WG should decide what it means for YANG to not
be NETCONF-specific.  Why does YANG define extensions
to NETCONF operations (like insert)? IMO the normative text
about NETCONF should not be in the YANG RFC.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 26 Jul 2015 09:09:19 +0200

> about NETCONF should not be in the YANG RFC.

So what is your proposal?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Sun, 26 Jul 2015 12:46:22 +0200

> On 26 Jul 2015, at 02:26, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 

This is essentially what I proposed in Berlin (IETF 87):

http://www.ietf.org/proceedings/87/minutes/minutes-87-netmod

(first item in Open mike section).

Another thing that I realized only recently is that some properties that are inherent to the conceptual data tree are defined in “XML Mapping” sections.

I think most YANG concepts and statements can be defined in terms of data tree properties. Separate documents would then define different encodings, and “profiles” for management protocols.

It would need massive changes in 6020bis text though.

Lada

> 
> Andy
> 
> 
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 26 Jul 2015 12:55:15 +0200

Any are concrete actionable proposals?

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Sun, 26 Jul 2015 13:06:54 +0200

> On 26 Jul 2015, at 12:55, Juergen Schoenwaelder <[email-masked]> wrote:
> 

Start rewriting 6020bis, but only if we decide to go that way - it is a difficult decision. I will be slightly in favor of doing so.

Lada

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 26 Jul 2015 13:49:37 +0200

Lada,

there won't be any decision as long as there is not a concrete
actionable proposal to be discussed. Such a proposal does not have to
be 'complete rewrite' but it needs to be a detailed list of what would
have to change so that it is possible to assess such a proposal.

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 29 Jul 2015 11:49:01 +0200

> have to change so that it is possible to assess such a proposal.

This is still quite some work, so I'd first like to see an elementary
consensus that it is a good thing to do now.

Clearly it would mean further delay for 6020bis and all other documents
that depend on it. And frankly - I need to show my employer that at
least some of my IETF work ever gets finished.

Lada

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 29 Jul 2015 12:34:24 +0200

> consensus that it is a good thing to do now.

I think the WG needs to see a half way complete list of changes that
this implies in order to form an opinion, something like 'section X
needs to be rewritten', 'section X needs to be split into A and B',
'section X does not require any changes' etc. Unless we have an
outline of how much work this is, we simply do not know what we are
talking about.

> least some of my IETF work ever gets finished.

I agree. If such a reorganization costs say more of four additional
weeks, I have a hard time to like it.

/js

---

From: Tina TSOU <[email-masked]>
Date: Wed, 29 Jul 2015 10:41:50 +0000

Dear all,

Agree with Lada and Juergen, regarding quantifying the changes and the time frame.

Thank you,
Tina

On Jul 29, 2015, at 6:35 PM, Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, Jul 29, 2015 at 11:49:01AM +0200, Ladislav Lhotka wrote:
Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> writes:

Lada,

/js

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod